Closed Bug 1679125 Opened 2 years ago Closed 4 months ago

Scrolling stops after a while or not working on certain test page

Categories

(Core :: Panning and Zooming, defect, P2)

Desktop
All
defect

Tracking

()

RESOLVED DUPLICATE of bug 1765204
Tracking Status
firefox83 --- wontfix
firefox84 --- wontfix
firefox85 --- wontfix

People

(Reporter: atrif, Unassigned)

References

(Regression)

Details

(Keywords: regression)

Affected versions

  • 83.0 (20201112153044)
  • 84.0b4 (20201122152513)
  • 85.0a1(20201123214551)

Affected platforms

  • Windows 10x64
  • macOS 10.15
  • Ubuntu 18.0

Steps to reproduce

  1. Open Firefox and https://bug1241394.bmoattachments.org/attachment.cgi?id=8710335.
  2. Scroll using the mouse wheel.

Expected result

  • The scroll on the page performs as expected.

Actual result

  • Scrolling is not working or it’s working and stops after a few scrolls.

Regression range

  • I will search for one ASAP.

Notes

  • If the issue is not reproducible press up/ down arrow button from the keyboard or drag the scroll bar and then try to scroll.
  • After using auto scrolling on the page the issue is not reproducible.

Suggested Severity: S3

Has Regression Range: --- → no
Has STR: --- → yes
Component: Layout: Scrolling and Overflow → Panning and Zooming
QA Whiteboard: [qa-regression-triage]

(In reply to Timothy Nikkel (:tnikkel) from comment #1)

It fails with webrender. Works without. With webrender forced on the behaviour changes several times, but this is one regression range

https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=0d4e73bc2cd705d7a021c75a0e8aeb174ab4db59&tochange=317b91c1fbd51e48238d05bb3e90663245e751f3

thinking it could be

https://hg.mozilla.org/mozilla-central/rev/5fc179e245d51289f1f7bcaba0c29189d3336fbf

Thank you! Changing the flags based on the above.

Has Regression Range: no → yes
Severity: -- → S2

Filling in bug 1421380 as the suspected regressor. Also updating severity to S3 as suggested in comment 0, and since we've been shipping this regression for 20+ releases with no user reports that I'm aware of.

Severity: S2 → S3
Priority: -- → P2
Regressed by: 1421380

Scroll doesn't work on Jetlag page on 87.0b4 under Ubuntu 20.04 as well.

(In reply to Catalin Sasca, QA [:csasca] from comment #4)

Scroll doesn't work on Jetlag page on 87.0b4 under Ubuntu 20.04 as well.

Is it the same issue as this bug though?

(In reply to Timothy Nikkel (:tnikkel) from comment #5)

(In reply to Catalin Sasca, QA [:csasca] from comment #4)

Scroll doesn't work on Jetlag page on 87.0b4 under Ubuntu 20.04 as well.

Is it the same issue as this bug though?

In case of jetlag.photos, dom.event.wheel-deltaMode-lines.always-disabled = true(default in Nightly) fixes.
So, I think it is a different bug.

So then should I file a new bug for jetlag?

Filled Bug 1696106 for the Jetlag page scrolling issue.

This does appear to be fixed by the patches in bug 1765204.

I am also unable to reproduce the issue with the fixes for bug 1765204

Thanks for checking, let's close this as a duplicate.

Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1765204
You need to log in before you can comment on or make changes to this bug.