Closed Bug 1679136 Opened 2 years ago Closed 2 years ago

[Firefox Alpenglow] Separators in the Bookmarks toolbar are almost invisible

Categories

(Firefox :: Theme, defect, P2)

defect

Tracking

()

VERIFIED FIXED
85 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox83 --- unaffected
firefox84 --- verified
firefox85 --- verified

People

(Reporter: oana.botisan, Assigned: Gijs)

References

(Regression)

Details

(Keywords: regression)

Attachments

(5 files)

Affected versions

  • Firefox 84.0b4
  • Firefox 85.0a1

Affected platforms

  • Ubuntu 18.04 x64
  • Windows 10 x64
  • macOS 10.15

Preconditions

  • Make sure that the Firefox Alpenglow is enabled.

Steps to reproduce

  1. Open Bookmarks Toolbar
  2. Add a few separators via context menu ( right-click on Bookmarks Toolbar and click on "New Separator").

Expected result

  • The separator is visible.

Actual result

  • Separator is almost invisible.

Regression range

  • If it's a regression, I will try to find it asap.

Suggested severity

  • S3
Has STR: --- → yes
See Also: → 1679139
QA Whiteboard: [qa-regression-triage]
Has Regression Range: --- → yes
Severity: -- → S3
Flags: needinfo?(gijskruitbosch+bugs)
Priority: -- → P2
Regressed by: 1665442

I'm on a data-limited mobile connection until next Tuesday, and I don't have a build handy that has both alpenglow and the pre-patch appearance. Can you take a screenshot of what the separators used to look like, ie what's the expected look of the separators in the light/dark alpenglow theme? And what does the hamburger menu separator look like in those cases?

Flags: needinfo?(gijskruitbosch+bugs) → needinfo?(oana.botisan)
Attached image dark alpenglow.png
Flags: needinfo?(oana.botisan)
Attached image Light Alpenglow.png

The hamburger menu separators or any other menu on the url bar don't seem to be changed. They are the same on the latest version as they were on the older unaffected version.

(In reply to Oana Botisan, Desktop Release QA from comment #5)

The hamburger menu separators or any other menu on the url bar don't seem to be changed. They are the same on the latest version as they were on the older unaffected version.

Sure, but the new separators now look the same as the one next to the hamburger, which was always very very faint / invisible (also in the "unaffected" version).

I'll see if I can find any designs / ideas around what these should look like.

Flags: needinfo?(gijskruitbosch+bugs)
Attached image Screenshot_30.png

The separators from the hamburger menu are a bit faded, but they are distinguishable. The bookmark separator are invisible.

(In reply to Oana Botisan, Desktop Release QA from comment #7)

The separators from the hamburger menu are a bit faded, but they are distinguishable. The bookmark separator are invisible.

I don't mean the ones inside the menu, I mean the vertical line to the left of the hamburger button itself, which is just as invisible as the bookmarks ones...

I don't mean the ones inside the menu, I mean the vertical line to the left of the hamburger button itself, which is just as invisible as the bookmarks ones...

In that case, that one is affected too. I looked inside the menu bar. Sorry for the confusion.

See Also: 1679139
Duplicate of this bug: 1679139
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Flags: needinfo?(gijskruitbosch+bugs)

Comment on attachment 9190894 [details]
Bug 1679136 - fix separator colour in alpenglow light and dark, r?jaws

Beta/Release Uplift Approval Request

  • User impact if declined: Separators are invisible
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: See comment #0
  • List of other uplifts needed: n/a
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Super low risk. Just changing some CSS variables for the alpenglow theme only, and incrementing the version number so this change takes effect.
  • String changes made/needed: nope
Attachment #9190894 - Flags: approval-mozilla-beta?
Flags: qe-verify+
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/568324188993
fix separator colour in alpenglow light and dark, r=jaws
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → 85 Branch

Comment on attachment 9190894 [details]
Bug 1679136 - fix separator colour in alpenglow light and dark, r?jaws

Approved for 84.0b8.

Attachment #9190894 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
QA Whiteboard: [qa-regression-triage] → [qa-regression-triage][qa-triaged]

I verified the fix using Latest Nightly 85.0a1 and Firefox 84.0b8 on Windows 10 x64 (both with dark and light theme), Ubuntu 18.04 x64 and macOS 11.0.1. The issue is not reproducing anymore.
On Ubuntu and macOS even though the line is visible is still lighter than the ones that are on Windows. Is that intended? Or it's the difference on the settings from my monitors?

(In reply to Oana Botisan, Desktop Release QA from comment #17)

I verified the fix using Latest Nightly 85.0a1 and Firefox 84.0b8 on Windows 10 x64 (both with dark and light theme), Ubuntu 18.04 x64 and macOS 11.0.1. The issue is not reproducing anymore.

Thanks for the quick verification.

On Ubuntu and macOS even though the line is visible is still lighter than the ones that are on Windows. Is that intended? Or it's the difference on the settings from my monitors?

The exact colour will depend on the background - it's semi-transparent. The semi-transparent colour specified is the same cross-platform, so for separators in exactly the same place there shouldn't be a difference across platforms. Happy to take a look at a specific screenshot if you think there's still something off compared to Windows?

Flags: needinfo?(oana.botisan)

I was working on the image and just realized they are exactly the same colour. I think the difference I saw was because of my monitor settings (my main monitor has really low brightness). Sorry for the confusion.
I will mark this issue as verified fixed.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
Flags: needinfo?(oana.botisan)
QA Whiteboard: [qa-regression-triage][qa-triaged] → [qa-triaged]
You need to log in before you can comment on or make changes to this bug.