Closed Bug 1679164 Opened 2 years ago Closed 2 years ago

[macOS] Horizontal scrollbar will disappear after the page is completely loaded

Categories

(Core :: Layout: Scrolling and Overflow, defect)

Desktop
macOS
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox84 --- affected
firefox85 --- affected

People

(Reporter: csasca, Unassigned)

Details

(Keywords: regressionwindow-wanted)

Affected versions

  • Firefox 84.0b4
  • Firefox 85.0a1

Affected platforms

  • macOS 10.15.7

Steps to reproduce

  1. Launch Firefox
  2. Access this example page

Expected result

  • The scrollbar from the block with numbers is present at all times

Actual result

  • After the page is loaded, the scrollbar will disappear

Regression range

  • I will see if there is a regression here.

Additional notes

  • The issue can be seen in the following attachment
  • The scrollbar will appear only if the user will drag with selection inside the block and quickly click on it, or by manually scrolling with the keyboard (shift + LR arrows)

Suggested severity

  • S3-S4
Has Regression Range: --- → no
Has STR: --- → yes
QA Whiteboard: [qa-regression-triage]

I'm not sure there's a bug here. The behavior is dependent on the macOS System Preferences setting "Show scroll bars: Automatically based on mouse or trackpad / When scrolling / Always". If it's not set to "Always", then the scrollbar will not always appear.

Could you check what scrollbars setting you have in System Prefs (and try the other options), and then confirm whether the behavior seems buggy?

Flags: needinfo?(catalin.sasca)

Yes, it is set on "Automatically based on mouse or trackpad". It seems that the scrollbar is now present at all times, but may sometimes not appear for some reason (can't reproduce anymore but may still happen).

We can close this eventually, and if there will be a strange behavior anymore, we'll see about it. Thanks Jonathan!

Flags: needinfo?(catalin.sasca)

Let's close as WFM for now; please re-open or file a new bug if you see behavior that still seems wrong.

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.