Application Support Files seem to use absolute pathnames for cache, etc.

VERIFIED DUPLICATE of bug 157662

Status

Camino Graveyard
Preferences
--
minor
VERIFIED DUPLICATE of bug 157662
16 years ago
16 years ago

People

(Reporter: Christian Mittendorf, Assigned: Conrad Carlen (not reading bugmail))

Tracking

Details

(Reporter)

Description

16 years ago
I did move my home directory to another harddisk (on the same machine) and
another user account name (I changed my login from cmittend to cmittendorf :-).
Thereafter I was unable to startup Chimera. It stopped working directly after
showing the splash screen. 
I nailed down the problem to be related to the files that Chimera is storing in
the Application Support directory.
Due to my changes Chimera was using the right files in my current Application
Support directory (~/Library...), however: using this information Chimera tried
to open files with an absolute pathname (/Users/cmittend/Library...) using my
old username as home dir. But this path is no longer available (I unmounted the
old hard disk) and Chimera quietly stopped working.
Not a very common scenario, I know.

Comment 1

16 years ago
Christian, what build ID are you reporting this bug against?

Comment 2

16 years ago
Profile, -> ccarlen
Assignee: sfraser → ccarlen
(Reporter)

Comment 3

16 years ago
It's Chimera 0.5, Build ID: 2002090913

Comment 4

16 years ago
I just had the same problem under Win2K. Also I checked under Linux and it also
has absolute paths all over the place.

Problem was that I reinstalled Win2k (not uncommon) on another partition which
invalidated the paths.

I think the paths should be relative by default. Also it would be great if a
profile could be stored anywhere. The data is too important to be hidden the way
it is now. The danger of losing all your mail and stuff when reinstalling your
OS is just too big.

Comment 5

16 years ago
Dup of/related to bug 157662 or bug 165841?
Bug 165841 is about customizable paths, which is why it wasn't duped to bug
157662. The latter is literally the same as this, except that this is for
Chimera. It seems to me though that Chimera actually uses the same profile
registry system, with few changes (restriction to one profile per user, move to
"Application Support" folder, etc.).

*** This bug has been marked as a duplicate of 157662 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
v dup
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.