Closed Bug 1679201 Opened 2 years ago Closed 2 years ago

Browser crash when dragging tab during video call

Categories

(Core :: WebRTC: Audio/Video, defect)

Firefox 83
x86_64
Linux
defect

Tracking

()

RESOLVED DUPLICATE of bug 1627673

People

(Reporter: eric, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:83.0) Gecko/20100101 Firefox/83.0

Steps to reproduce:

Specifically Firefox 83.0 64-bit on Linux Ubuntu 18.04 Kernel 4.15.0.

  1. Open two separate firefox windows, each with multiple tabs open
  2. In window #1, open a video call on Jitsi Meet (https://meet.jit.si/CompulsoryClinicsSailCuriously or similar)
  3. In window #2 drag a tab downward to create a new window

Actual results:

Firefox crashes. My webcam light is still on, and my camera reports being "in use" so I can't use it again until I reboot.

Expected results:

The tab you dragged should create a new window with only that tab in it.

Summary: Browser crash when dragging tab → Browser crash when dragging tab during video call
OS: Unspecified → Linux
Hardware: Unspecified → x86_64

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: Untriaged → WebRTC: Audio/Video
Product: Firefox → Core

I ran into the same problem multiple times on macOS (Mozilla/5.0 (Macintosh; Intel Mac OS X 10.14; rv:83.0) Gecko/20100101 Firefox/83.0) while on a Google Meet call today. One time, it crashed the entire browser; one time it crashed just the tab; and one time it didn't crash the browser or tab but left the tabs in a janky state.

Specifically, the tab I was attempting to drag appeared to be floating between two other tabs, but I couldn't actually click on it in that apparent position. Its actual position (as far as where I could click on it) was still in its previous, pre-drag position. Cmd+Tab and Cmd+Shift+Tab also acted as if it was in its pre-drag position. I had to restart the browser to get the tabs to appear normal again.

Hi Eric (and Adam), thanks for reporting!

I'm not able to reproduce. Would you happen to have the crash report from about:crashes? If you submit that and link it here that would be extremely helpful.

If this reproduces 100% of the time, then another thing that would be very helpful is running the https://mozilla.github.io/mozregression tool on it to narrow down a regression range. Thanks!

Flags: needinfo?(eric)
Flags: needinfo?(adam)

I don't have access to the machine with that crash report at this moment, but I will be able to get that some time next week or so. I did click the "submit crash" button that popped up at the time it happened, so it's possible my crash report may already be in your system somewhere.

Flags: needinfo?(adam)

It most likely is, but we have no way of correlating it to you.

If you recall the date (and time, but hopefully your Firefox doesn't crash multiple times a day!) that it happened, you should be able to locate it under "Submitted crash reports" in about:crashes. If you could paste that crash id here, when you get a chance, it would let us locate it. Thanks!

My crashes look like a dupe of bug 1627673, which is fixed in Firefox 84.

Flags: needinfo?(eric)

The severity field is not set for this bug.
:jib, could you have a look please?

For more information, please visit auto_nag documentation.

Flags: needinfo?(jib)

Crash reports from both reporters point to the same bug.

Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Flags: needinfo?(jib)
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.