Open Bug 1679311 Opened 2 months ago Updated 26 days ago

Add a way to kill all Google Maps

Categories

(Firefox :: Disability Access, enhancement)

Firefox 83
enhancement

Tracking

()

REOPENED

People

(Reporter: erwinm, Unassigned)

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.14; rv:83.0) Gecko/20100101 Firefox/83.0

Steps to reproduce:

I tried to debug a website to try to schedule an appointment.

Actual results:

The site has an embedded Google Map. So I accidentally ended up zooming the thing.

Zooming pain/animation reliably triggers my migraines.

Expected results:

Safety settings should including options to either (1) kill all Google Maps, embedded in any sites, or to (2) kill the scrolljacking which converts attempts to scroll past into zooming.

Add-ons exist to disable embedded content from specific sites; could you elaborate why that does not work for you?

I've tried that in the past, but Google's aggressive about embedding, so I never found a reliable way to block Google Maps.

Setting a component for this enhancement in order to get the dev team involved.
If you feel it's an incorrect one please feel free to change it to a more appropriate one.

Status: UNCONFIRMED → NEW
Component: Untriaged → Widget: Cocoa
Ever confirmed: true
Product: Firefox → Core

It seems like an addon should be able to address this issue. I'm not sure about the proper component to get some input here, so I'm tentatively assigning this to Firefox:Extension Compatibility for some input.

Component: Widget: Cocoa → Extension Compatibility
Product: Core → Firefox

If you're reporting webcompat bug (a difference in how google maps operate between Firefox and other browser), please reopen this or file a new bug with more details.

If this is a request for a new Firefox feature, it seems very unlikely that we'll be adding a specific option to block one specific site, and is probably a WONTFIX.

As a workaround, you might want to look into one of the many existing blocker extensions that allow you to enter a specific blocklist item to disallow loading of Google maps inside iframes. I believe for example uBlock Origin or AdBlock Plus would work for you, but you should check out their documentation and reach out to their support if you need help.

(Also CCing Raymond in case he wants to chime in directly)

Status: NEW → RESOLVED
Closed: 27 days ago
Resolution: --- → INVALID

I believe for example uBlock Origin or AdBlock Plus would work for you

The following filter can be added in uBO to convert the Google Maps widget into a click to load placeholder:

||www.google.com/maps/embed/$3p,frame,redirect=click2load.html

If I install that filter, and search on https://whosmy.virginiageneralassembly.gov

... I still get hit by an embedded Google Migraine regardless of that filter, I'd have to block all of gstatic to protect against this.

Component: Extension Compatibility → Disability Access

Moving to disability access because I don't think extensions will ever be enough to protect users from this sado-design.

(In reply to MarjaE from comment #0)

or to (2) kill the scrolljacking which converts attempts to scroll past into zooming.

Oh I missed this the first time, reopening so that accessibility folks see it.

Status: RESOLVED → REOPENED
Resolution: INVALID → ---
You need to log in before you can comment on or make changes to this bug.