If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Drawing of a thick border with a very tall element is amusing

VERIFIED DUPLICATE of bug 115526

Status

()

Core
Layout
VERIFIED DUPLICATE of bug 115526
15 years ago
15 years ago

People

(Reporter: Shoji Matsumoto, Assigned: Marc Attinasi)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: DUPEME)

Attachments

(4 attachments, 1 obsolete attachment)

(Reporter)

Description

15 years ago
tested on moz 1.1 and 2002-09-04-08 trunk (linux)

---- test HTML ----
<html>
<head><title>test</title></head>
<body>
<div style="border: double; height:28269px;">
aaa
</div>
</body>
</html>
----------------------

case-1. height <= 28269px, the border is drawn correctly.
case-2. height >= 28270px and <= 28272px, the element is shown as "BLACK BOX".
case-3. height >= 28273px, the border is drawn for upward..

"border: solid 3px" causes the same results.
no problem with "border: solid 1px".
(Reporter)

Comment 1

15 years ago
Created attachment 98703 [details]
case-1 (drawn correctly)
(Reporter)

Updated

15 years ago
Attachment #98703 - Attachment is obsolete: true
(Reporter)

Comment 2

15 years ago
Created attachment 98704 [details]
case-1 (drawn correctly)
(Reporter)

Comment 3

15 years ago
Created attachment 98705 [details]
case-2 (bad case 1)
(Reporter)

Comment 4

15 years ago
Created attachment 98706 [details]
case-3 (bad case 2)
(Reporter)

Comment 5

15 years ago
Created attachment 98707 [details]
screenshot

Updated

15 years ago
Whiteboard: DUPEME
Duplicate of "clipping and border drawing need ConditionRect"

*** This bug has been marked as a duplicate of 115526 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 7

15 years ago
v
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.