Closed Bug 1679386 Opened 8 months ago Closed 8 months ago

Print Preview locks out if going through some "Paper size" options while custom margins are set

Categories

(Toolkit :: Printing, defect)

Desktop
macOS
defect

Tracking

()

RESOLVED DUPLICATE of bug 1674106
Tracking Status
firefox84 --- affected
firefox85 --- affected

People

(Reporter: csasca, Unassigned)

References

(Blocks 2 open bugs)

Details

(Whiteboard: [print2020_v85][old-ui-])

Affected versions

  • Firefox 84.0b4
  • Firefox 85.0a1

Affected platforms

  • macOS 10.15.7 & 11.1

Steps to reproduce

  1. Launch Firefox
  2. Access for example Wikipedia
  3. Access Print Preview
  4. Select "Custom Margins" and enter the 2.00 value on each side
  5. Access random "Paper size" selections

Expected result

  • The print preview is still usable

Actual result

  • Some values on Paper Size like "executive" or "JIS-B5" for example will lock the Print Preview

Regression range

  • This is not a regression, since it reproduces on 83.0b1, where custom margins were introduced.

Additional notes

  • The issue can be seen in the following attachment
  • This issue is reproducing on 2 different machines and 2 different macOS'es (10.15.7 and 11.1), but on a mid 2012 macbook on 10.15.7 we couldn't reproduce it.

Suggested severity

  • S3
Has STR: --- → yes

:csasca, if you think that's a regression, then could you try to find a regression range in using for example mozregression?

Is this related to bug 1674106? I see an error appear on the margins briefly before changing the paper size so maybe it's more timing related but seems like the change in bug 1674106 might help here.

Component: Print Preview → Printing
Flags: needinfo?(emalysz)
Product: Core → Toolkit

Yeah it looks like the patch from bug 1674106 fixed that for me.

Catalin, do you mind confirming you can no longer reproduce before we resolve?

Flags: needinfo?(emalysz) → needinfo?(catalin.sasca)
Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1674106

Yep Emma, it seems that the patch from bug 1674106 fixed it. Thank you and sorry for the late response!

Flags: needinfo?(catalin.sasca)
You need to log in before you can comment on or make changes to this bug.