String selection in select boxes

RESOLVED DUPLICATE of bug 150590

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 150590
17 years ago
17 years ago

People

(Reporter: rst, Assigned: john)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Hi,

when a select box is selected and there are say 200 options available it is
rather comfortable to use the keyboard to select the first option beginning with
'any char'. Indeed, in some situations this is not sufficient for me. I would
like to be able to also type a second char and a third one to come closer to the
final option I want to choose (if you find 150 options commencing with an 'e'
you are very happy if you can jump to 'enhancement' by just typing 'enh' (now it
selects the first option beginning with 'e' than the first one beginning with
'n' then the first one beginning with 'h'). Indeed, this behaviour would
interfere with Mozilla's behaviour that the second option beginning with 'any
char' is selected when re-typing the char.

René

Comment 1

17 years ago
reassigning
Assignee: morse → jkeiser
Component: Form Manager → HTML Form Controls
Dup of "should be able to type words into <select> - incremental search for item"

*** This bug has been marked as a duplicate of 150590 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.