Closed Bug 1679490 Opened 2 months ago Closed 1 month ago

83 consumes all available resources

Categories

(Firefox :: Untriaged, defect)

Firefox 83
defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: billmayhew, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:83.0) Gecko/20100101 Firefox/83.0

Steps to reproduce:

Simple everyday use. Suddenly 83 is spawning OVER 12 PROCESSES on a single-user 64-BIT Windows 10 PC.

(On THANKSGIVING?????)

Actual results:

"Firefox is being updated by another instance." FOR 24 HOURS?

Expected results:

I SHOULD HAVE BEEN ABLE TO DO MY ROUTINE WEB-SURFING WITHOUT DISRUPTION.

QUALITY CONTROL NEEDS TO TEST RESOURCE CONSUMPTION ON AVERAGE/BASIC PCs BEFORE RELEASE. MINE IS A 64-BIT WIN-10 PRO MACHINE W/4GB.

Summary: 83 consumes ALL AVAILABLE RESOURCES. As a delighted (until now) 10-year user: WHERE IS QUALITY CONTROL?? → 83 consumes ALL AVAILABLE RESOURCES. As a delighted (until now) 10-year user: WHERE IS QUALITY CONTROL?? Happy :( Thanksgiving!

Hi Bill. Thanks for reporting this. Please keep things technical and to the point, and please don't use capital letters for no reason.

Please provide clear steps to reproduce, e.g. where and how to see that it is using 12 processes (which is not an issue per se).
Please explain where to see "Firefox is being updated by another instance.", and please explain what "for 24 hours" is supposed to mean. Did you keep Firefox running for 24 hours with that dialog shown for 24 hours, or what? In general, please follow https://developer.mozilla.org/en-US/docs/Mozilla/QA/Bug_writing_guidelines - thanks!

Flags: needinfo?(billmayhew)
Summary: 83 consumes ALL AVAILABLE RESOURCES. As a delighted (until now) 10-year user: WHERE IS QUALITY CONTROL?? Happy :( Thanksgiving! → 83 consumes all available resources

Fair enough! Understood that I need to adjust my expectations for fully-multi-process Firefox.

(Wasn't expecting this to land in bugzilla, I thought this discussion was essentially triage)

Flags: needinfo?(billmayhew)

(In reply to Bill Mayhew from comment #2)

Fair enough! Understood that I need to adjust my expectations for fully-multi-process Firefox.

(Wasn't expecting this to land in bugzilla, I thought this discussion was essentially triage)

No need to keep this as a bug, never intended it to land in bugzilla!

Hi,

As per comment #4, I'll mark it as Resolved - Works for me.

Regards,
Virginia

Status: UNCONFIRMED → RESOLVED
Closed: 1 month ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.