Closed Bug 167951 Opened 17 years ago Closed 10 years ago

Make it possible to resize form fields (resizable textareas)

Categories

(Core :: Layout: Form Controls, enhancement, P5)

enhancement

Tracking

()

RESOLVED FIXED
Future

People

(Reporter: rst, Assigned: enndeakin)

References

(Depends on 2 open bugs, Blocks 1 open bug)

Details

(Keywords: dev-doc-complete, Whiteboard: [parity-webkit] [evang-wanted])

Hi,

many sites offer tinies textareas e.g. to capture customer feedback. If you have
much to say, the textareas quickly get filled and writing is very unnice. In
these situations I wish to be able to simple resize the textarea that I am
writing into to make a 30cols 10 rows teatarea one with 70 cols and 30 rows
which is more comfortable for writing/editing texts.

René
Assignee: morse → jkeiser
Component: Form Manager → HTML Form Controls
reassigning
confirming RFE; note that this is trivially doable with DOM inspector...
Status: UNCONFIRMED → NEW
Ever confirmed: true
Even if it is doable with DOM inspector, this is not the most comfortable way to
do it. Why can't I just grab an edge with my mouse and drag the textarea bigger
or smaller like resizing any browser window? That's how I (as stupid user) wish
that should be doable.
OS: Windows 2000 → All
Hardware: PC → All
Priority: -- → P5
Target Milestone: --- → Future
*** Bug 205209 has been marked as a duplicate of this bug. ***
Contrary to the summary and the "Resizable Form Fields" extension, this should only apply to textareas.
In fact, the reference in the firefox 3 status meeting notes should probably
be to the "Resizeable Textarea" extension ( https://addons.mozilla.org/firefox/3818/ ) from which "Resizable Form Fields"
was developed.
Duplicate of this bug: 384089
Assignee: john → nobody
QA Contact: tpreston → layout.form-controls
Requesting blocking1.9? on behalf of the bug that was just duped here.
Flags: blocking1.9?
Whiteboard: parity-safari
Flags: blocking1.9? → blocking1.9-
Whiteboard: parity-safari → parity-safari [wanted-1.9]
I wonder if Netscape Navigator 9 implements this in a clean way. If they could submit a patch upstream, that would be awesome. Are there any intact contacts?
Whiteboard: parity-safari [wanted-1.9] → parity-safari parity-netscape [wanted-1.9]
Summary: Make it possible to resize form fields → Make it possible to resize form fields {resizable textareas}
Duplicate of this bug: 411157
Flags: wanted1.9+
Whiteboard: parity-safari parity-netscape [wanted-1.9] → parity-safari parity-netscape
Blocks: 410988
Duplicate of this bug: caminotextarearesize
Duplicate of this bug: 425978
Many dupes in 2008: seems that Safari have this feature flashed in the minds..

Now I have to insert additional JavaScript into every HTML page I load (into win32 Seamonkey), just to attach resize functions to onmouse* events. Sure this feature should be implemented in the render core with configurable options for keyboard/mouse control and elements to use (textareas, text inputs, selects, objects (Bug 410988) etc.)

For less annoying control look I'd suggest to use a trigger key (Alt or Ctrl) to get this resize controls visible/workable.
> For less annoying control look I'd suggest to use a trigger key (Alt or Ctrl)
to get this resize controls visible/workable.

Disagree. Little resize gripper doesn't hurt and helps newbies discover them.
Flags: wanted1.9+ → wanted1.9-
Is this bug purely about TEXTAREAs, or would this bug cover SELECT elements as well?
Keywords: polish
Summary: Make it possible to resize form fields {resizable textareas} → Make it possible to resize form fields (resizable textareas)
Keywords: polish
> Little resize gripper doesn't hurt and helps newbies discover them.

In textareas only ;) Ok, it doesn't make a sense, but in a best case all newbie features should be 'offable' in advanced options (e.g. about:config).

> Is this bug purely about TEXTAREAs, or would this bug cover SELECT elements as
> well?

I think this ticket should be stricted to textareas and forced to resolve/wontfix in a short time. There are many core tweaks to do but these small user-friendly features defines the choice of millions.
Bug 410988 propose a larger set of object to be resizeable. IMO it suggests a more general and useful approach.
Keywords: 4xp
Whiteboard: parity-safari parity-netscape → parity-safari, related: 410988
Whiteboard: parity-safari, related: 410988 → [parity-safari] [parity-gbrowser]
Whiteboard: [parity-safari] [parity-gbrowser] → [parity-safari] [parity-chrome]
Keywords: 4xp
Putting this on the radar for 1.9.1, asking for blocking to pick up wanted. As more websites are offering content-creation regions, it's becoming more common that users might want a little more space. There are ways for websites to do this (cf: Wordpress) but it would be good to get to parity with webkit, here.

(In reply to comment #9)
> I wonder if Netscape Navigator 9 implements this in a clean way. If they could
> submit a patch upstream, that would be awesome. Are there any intact contacts?

Chris Finke, maybe? Chris, any ideas if there's stuff we can upstream here?

(In reply to comment #18)
> Bug 410988 propose a larger set of object to be resizeable. IMO it suggests a
> more general and useful approach.

I don't want to see conflation issues here. Let's keep these separate, as the primary functional gain for this is content creation for text. I think the results are far, far less predictable for arbitrary <object> resizing.
Flags: wanted1.9.1?
Keywords: 4xp
I totally sign this request :-)

Google Chrome has exactly that feature by default and it's very useful!
> Putting this on the radar for 1.9.1, asking for blocking to pick up wanted. As
> more websites are offering content-creation regions, it's becoming more common
> that users might want a little more space.

AMO (developer and editor tools) is a particular culprit that comes to mind. Giving really teeny boxes to type your comments/reviews in.
Flags: wanted1.9.1?
Flags: wanted1.9.1-
Flags: blocking1.9.1-
Duplicate of this bug: 467516
We need to fix this for the next version of Firefox. Typing in text areas is becoming more commonplace, and it's an extremely helpful feature to have.

Enn: have time to look into this? Can you take?
Flags: blocking1.9.2+
Please read Bug 442228 Comment #1. 

PS: I do _not_ want to mix issues.
Allowing the user to enable resize for all fields regardless of the CSS flag might be nice.  There's correctness/compliance, and then there's adding features that don't cause any harm because people like them and they're a good idea.  Safari users really like this feature.
As I can see the implementation of CSS 'resize' property is very useful for all but it won't let us to resize all these existing textareas with default properties.

But with the 'resize' property there could be a bit another option for this bug enhancement: "Set initial resize value to 'both' instead of 'none'".
Moreover, the special textarea option could have 3 values: 'Never' (now case), 'Always' (Safari way) and 'CSS-controlled' (using initial 'both' or 'none' according to previous option if no value is set).
https://bugzilla.mozilla.org/show_bug.cgi?id=410988 - That bug is basically the same, but covers things like Flash, Videos etc. It would be nice to resize a <video> element with your mouse.
Assignee: nobody → enndeakin
Status: NEW → ASSIGNED
Depends on: 510333, 510335
No longer depends on: 442228
Depends on: 511180
FYI, Greasemonkey + Resizeable Text Fields script (http://userscripts.org/scripts/show/42433) it's a nice workaround IMHO.
After discussion: this is wanted, not blocking. But it would need to make beta (next week, basically) - risky to take in an RC.
Flags: wanted1.9.2+
Flags: blocking1.9.2-
Flags: blocking1.9.2+
I added some patches for this in bug 442228.

https://build.mozilla.org/tryserver-builds/neil@mozilla.com-resize-textbox/ should have builds with this feature to try out.
Depends on: 442228
Neil, how far from completion is your work on this feature?
It just needs to be checked in.
Whiteboard: [parity-safari] [parity-chrome] → [parity-safari] [parity-chrome] [evang-wanted]
Could you attach the patch and get it reviewed then? :)
Neil tells me that the relevant patch is in bug 442228, and it just got its final reviews a couple of days ago.
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Depends on: 553752
Depends on: 553760
Depends on: 553907
Depends on: 554356
Depends on: 554468
Depends on: 556363
Depends on: 556645
Depends on: 555482
Depends on: 553796
No longer depends on: 554356
No longer depends on: 556645
Depends on: 558201
Depends on: 558203
Depends on: 558254
Depends on: 563085
Whiteboard: [parity-safari] [parity-chrome] [evang-wanted] → [parity-webkit] [evang-wanted]
Documented in the textarea element:

https://developer.mozilla.org/en/HTML/Element/textarea

Documentation of -moz-resize itself is coming up momentarily.
Depends on: 573486
Depends on: 581536
You need to log in before you can comment on or make changes to this bug.