Call for Mozilla web application platform (both on server and client side)

RESOLVED WONTFIX

Status

()

Core
General
--
enhancement
RESOLVED WONTFIX
16 years ago
6 years ago

People

(Reporter: imran.geriskovan, Unassigned)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Err... "Browser-General" is not a good place to report this, but I could not
find a  better place. Anyway it follows like this:

I would like to see mozilla as a web application development platform both on
the server and client side.

For me mozilla is a structure which can operate on DOM and which is also a DOM
itself. (I'm not talking about the visual things). Many real life problems can
be modeled as DOM's interacting with other DOM's (which can be on servers or
browsers) with each other in the net space. Now mozilla have all the
capabilities to support such configuration.

The only thing which missing is the server integration. That is mozilla core
should operate like tomcat, jboss, zope, etc... on the server side. The
programming can be done as usual but it will not be oriented to userinterface.
It will be oriented for dom/data processing and managing interactions.

This will be radical move for mozilla since it will a quite different approach
to the still_unsolved_web_problem.

Any comments?

Comment 1

16 years ago
*** Bug 167948 has been marked as a duplicate of this bug. ***

Updated

16 years ago
Severity: normal → enhancement
so the idea is to have a standalone drop-in DOM module?
(Reporter)

Comment 3

16 years ago
Well, the idea is to have a server side platform like tomcat, jboss, zope, php, etc
using mozilla's capabilities. Ofcourse, DOM structure will bring a new
dicipline/approach. It will enforce a real object oriented style for decomposing
the application components and logic.

The idea is NOT to have ONLY a standalone drop-in DOM module.
Let's not constraint it that way. It may include all modules of Mozilla, except
the ones for rendering things on the display, since it will be on the server
side. Or even the platform may also include graphical things for server side
management and othet things. But this may be optional because the main focus
should be on the server platform to provide a web application framework.

I thing it is quite possible.
Mozilla platform has everything to support this.

Think about php-gtk. Formerly php was an server side platform. Now with php-gtk
you may use it on the client side.

The above is idea is like this. But an inverted version:
That is; we now have Mozilla stuff on the client side to render a browser.
Why not have it on the server side to construct a web application?

If this is achieved in the long run we may expect see real Mozilla applications
partitioned on both the server and client.

And you know what this means: A .Net killer. :))
.Net is such a beast.
(Reporter)

Comment 4

16 years ago
One more thing: If this idea is to be accepted as an strategic orientation than
we need a new product on bugzilla such as "Mozilla server platform" and we need
to to move this bug to it.

I thing this "server side" issue is very important for mozilla in its way to
become a full featured platform. Infact it is critical for its long-term
strategies in an world where .Net exists. Mozilla may use .Net concept as a
lever for itself since MS injects network application concepts to public. And
this is exactly what is needed by Mozilla to expand into that field.

Here Mozilla has two main advantages:
1- It has a compact and reliable technology for this.
2- It is loved by people outside MS camp.

Mozilla may become the .Net of non-MS world.
So if I made my way through the buzzword soup correctly, what you want is to use
the XPCOM architecture on the server, right?  Create various XPCOM components,
have them talk to each other, etc?

You can already do that.  Nothing stopping you...
(Reporter)

Comment 6

16 years ago
Yes, you are right...
Given sufficient time and resources everybody can do everything him/herself...
I can also build Mozilla from scratch if I were immortal...
Did I make mistake with writing this?
If so, I would like to know the "real" purpose for the existance of bugzilla?
Shouldn't I write this?

Do you belive that Mozilla will exist as a standalone browser so long?
".Net"ification will kill it as Netscape was killed.
Being also on the server side may save it.
That was my point. But unfortunately you disliked those "buzzwords"!!!
My point is that I can't understand what you're saying. Exactly what should the
Mozilla application framework be able to do that it cannot currently do?
(Reporter)

Comment 8

16 years ago
Ok then...
Is there any server side Mozilla product out there which can be downloaded and
installed and allows server side application development?

The answer is "May be" for a mozilla developer like you.
But the answer is a big "NO" for a man who is not a mozilla developer.

Technically I know that such a product can be defined and packaged for
distribution utilizing Mozilla technology.

Unfortunately I'm not the one who can do this, even if I would like to...

That was my point for writing this bug.
Best regards..
OK, thank you.  ;)  That's exactly the clear explanation that was needed.

Confirming this, assigning to mitchell; this is a mozilla.org direction issue
that drivers and staff should work out.
Assignee: asa → mitchell
Status: UNCONFIRMED → NEW
Ever confirmed: true
Not sure who might help here -- cc'ing some folks.

/be
This would need to be done in pieces. NSPR and XPCOM can already be used on the
server side. The standalone XSLT engine (Transformiix) can be used on server
side; Expat (the XML parser) as well. From my personal interests I would like to
see the DOM becoming a standalone product sooner rather than later.

Server side components would also require completely new functionality that is
not relevant in a client.

Once we have the pieces it would become relevant to build a server-side
framework distribution a la Tomcat etc.
(Reporter)

Comment 12

15 years ago
XP Server is an app server based on XPCOM and Apache.
Requests are made to the Apache server and handled by
a module. The module reads XML template files and then
uses XPCOM to create a SAX chain of components to
handle the request.  Components can be written in C,
Java, or Javascript. There are existing components for
XML, XSLT, 3D charting, GD graphics, FOP to PDF and
database integration. XP Server was originally written
for a dotcom venture that didn't make it, the code has
been donated to mozdev.org and it's looking for new
owners.

http://xpserver.mozdev.org
(Reporter)

Comment 13

15 years ago
Is it possible to work with these guys?

http://www.whitebeam.org/

Whitebeam...

...is an Open Source project that provides a complete rapid development
environment for Web applications allowing sophisticated, robust and secure
applications to be built using only XML and server-side JavaScript.

The Whitebeam architecture integrates two popular and robust Open Source
platforms - Apache and Mozilla's SpiderMonkey JavaScript engine - with it's own
powerful XML environment and security architecture. The XML environment provides
both event driven and DOM based manipulation of XML trees along with the
powerful XPath querying language - all controlled via simple server-side
JavaScript interface.

Providing an extensible XML based interface to back end objects on any platform,
the client model securely segregates thousands of customer applications within a
single server.

(Reporter)

Comment 14

15 years ago
A site which is aware of the potential:

http://www.mozapps.org

Mozilla Applications
MozApps (Mozilla Application )
Bringing the power of the NET to you, today
Mozilla is, what .NET wants to be!
Summary: Mozilla/Apache on the server + Mozilla as client → Call for Mozilla web application platform (both on server and client side)
Product: Browser → Seamonkey

Updated

12 years ago
Depends on: 255942

Updated

12 years ago
Depends on: 180482

Updated

12 years ago
Assignee: mitchell → nobody
Component: General → General
Product: Mozilla Application Suite → Core
QA Contact: asa → general

Updated

6 years ago
Duplicate of this bug: 542737
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.