Redrawing fails after scrolling page with layer (position: fixed) containing layer (position: fixed; top: X)

RESOLVED FIXED

Status

()

RESOLVED FIXED
16 years ago
2 months ago

People

(Reporter: dsegan, Assigned: roc)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.1) Gecko/20020826
Build Identifier: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.1) Gecko/20020826

Layer (<DIV>) with "position: fixed" (a "parent" layer for the discussion)
containing a layer with "position: relative; top: X" ("child" layer), where
X is a dimension, renders properly, but when there's enough content to enable
scrolling the bottom X pixel lines get cut off and are redrawn in wrong
positions. The "background-color:red" only helps seeing the bug, but it's
visible even with transparent layers.


Reproducible: Always

Steps to Reproduce:
1. Create HTML file with contents:
<html><body>
<div style="position: fixed">
<div style="position: relative; top:15px; background-color:red">
This is a sample text.</div></div>

<h1>Just some text, scroll</h1><p>Scroll<p>Scroll<p>Scroll<p>Scroll<p>Scroll
<h1>Scroll Now!</h1><p>Scroll<p>Scroll<p>Scroll<p>Scroll<p>Scroll<p>Scroll
<h1>Enough Scrolling?</h1><p>Scroll<p>Scroll<p>Scroll<p>Scroll<p>Scroll
</body></html>

2. Scroll the page up and down (resize Mozilla window if neccessary)
Actual Results:  
The bottom 15 pixel lines of the "child" layer are redrawn in wrong positions
(depends on the speed of scrolling, obvious redraw bug).
They're also cut off.

Expected Results:  
The "child" layer should be properly positioned (which it is), and scrolling
should copy the bottom lines also to buffer.

Use Konqueror 3.0 to see what the result should look like, if in any doubt.

Experienced on all of:
Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.1) Gecko/20020826
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020826
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.7) Gecko/20011221


Should the severity of this be "Major", since it effects CSS2 compatibility
claim (and also "standards compatible" claim)? I guess not...
Sounds like a duplicate of some views bug, perhaps.
Assignee: dbaron → roc+moz
Component: Style System → Views
QA Contact: ian → petersen
I can't reproduce this in my 0905 build (which includes a scrolling fix I made
which might have fixed this bug). Danilo, can you please download one of the
latest builds and retest this?
(Reporter)

Comment 3

16 years ago
There's no bug on (at least) build from:
http://ftp.mozilla.org/pub/mozilla/nightly/latest/mozilla-win32-installer-sea.exe
Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.2a) Gecko/20020911

(Sorry for the delay, I have a modem connection)

Also, I apologize for wasting your time, and even more so to David for my
putting a wrong category on the bug report.

I'll download a Linux build too, but I don't expect any problems.

Great job! Thanks and I apologize again.

PS. I changed the "resolution" to "fixed". Maybe that's a mistake (maybe there's
some duplicate of it, but I cannot find it with my keywords), if so, feel free
to fix it (of course :)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
Component: Layout: View Rendering → Layout: Web Painting
Product: Core → Core
You need to log in before you can comment on or make changes to this bug.