Closed Bug 1679626 Opened 1 year ago Closed 1 year ago

Tree broken by bug 1661624 and bug 1678451

Categories

(Thunderbird :: Build Config, defect)

defect

Tracking

(thunderbird_esr78 unaffected, thunderbird84 unaffected)

RESOLVED FIXED
85 Branch
Tracking Status
thunderbird_esr78 --- unaffected
thunderbird84 --- unaffected

People

(Reporter: justdave, Assigned: justdave)

References

Details

Attachments

(1 file)

Decision task failed:

[task 2020-11-28T10:50:57.264Z] Generating tasks for docker-image debian8-base
[task 2020-11-28T10:50:57.264Z] Error loading tasks for kind docker-image:
[task 2020-11-28T10:50:57.264Z] Traceback (most recent call last):
[task 2020-11-28T10:50:57.264Z]   File "/builds/worker/checkouts/gecko/taskcluster/mach_commands.py", line 324, in taskgraph_decision
[task 2020-11-28T10:50:57.264Z]     ret = taskgraph.decision.taskgraph_decision(options)
[task 2020-11-28T10:50:57.265Z]   File "/builds/worker/checkouts/gecko/taskcluster/taskgraph/decision.py", line 234, in taskgraph_decision
[task 2020-11-28T10:50:57.265Z]     full_task_json = tgg.full_task_graph.to_json()
[task 2020-11-28T10:50:57.265Z]   File "/builds/worker/checkouts/gecko/taskcluster/taskgraph/generator.py", line 174, in full_task_graph
[task 2020-11-28T10:50:57.265Z]     return self._run_until("full_task_graph")
[task 2020-11-28T10:50:57.265Z]   File "/builds/worker/checkouts/gecko/taskcluster/taskgraph/generator.py", line 417, in _run_until
[task 2020-11-28T10:50:57.265Z]     k, v = next(self._run)
[task 2020-11-28T10:50:57.265Z]   File "/builds/worker/checkouts/gecko/taskcluster/taskgraph/generator.py", line 294, in _run
[task 2020-11-28T10:50:57.265Z]     self._write_artifacts,
[task 2020-11-28T10:50:57.265Z]   File "/builds/worker/checkouts/gecko/taskcluster/taskgraph/generator.py", line 92, in load_tasks
[task 2020-11-28T10:50:57.265Z]     for task_dict in transforms(trans_config, inputs)
[task 2020-11-28T10:50:57.265Z]   File "/builds/worker/checkouts/gecko/taskcluster/taskgraph/generator.py", line 80, in <listcomp>
[task 2020-11-28T10:50:57.265Z]     Task(
[task 2020-11-28T10:50:57.265Z]   File "/builds/worker/checkouts/gecko/taskcluster/taskgraph/transforms/task.py", line 2110, in check_run_task_caches
[task 2020-11-28T10:50:57.265Z]     for task in tasks:
[task 2020-11-28T10:50:57.265Z]   File "/builds/worker/checkouts/gecko/taskcluster/taskgraph/transforms/task.py", line 2018, in check_task_dependencies
[task 2020-11-28T10:50:57.265Z]     for task in tasks:
[task 2020-11-28T10:50:57.265Z]   File "/builds/worker/checkouts/gecko/taskcluster/taskgraph/transforms/task.py", line 2004, in check_task_identifiers
[task 2020-11-28T10:50:57.265Z]     for task in tasks:
[task 2020-11-28T10:50:57.265Z]   File "/builds/worker/checkouts/gecko/taskcluster/taskgraph/transforms/task.py", line 1985, in chain_of_trust
[task 2020-11-28T10:50:57.265Z]     for task in tasks:
[task 2020-11-28T10:50:57.265Z]   File "/builds/worker/checkouts/gecko/taskcluster/taskgraph/transforms/task.py", line 1776, in build_task
[task 2020-11-28T10:50:57.265Z]     for task in tasks:
[task 2020-11-28T10:50:57.265Z]   File "/builds/worker/checkouts/gecko/taskcluster/taskgraph/transforms/task.py", line 1767, in try_task_config_routes
[task 2020-11-28T10:50:57.265Z]     for task in tasks:
[task 2020-11-28T10:50:57.265Z]   File "/builds/worker/checkouts/gecko/taskcluster/taskgraph/transforms/task.py", line 1757, in try_task_config_chemspill_prio
[task 2020-11-28T10:50:57.265Z]     for task in tasks:
[task 2020-11-28T10:50:57.265Z]   File "/builds/worker/checkouts/gecko/taskcluster/taskgraph/transforms/task.py", line 1747, in try_task_config_env
[task 2020-11-28T10:50:57.265Z]     for task in tasks:
[task 2020-11-28T10:50:57.265Z]   File "/builds/worker/checkouts/gecko/taskcluster/taskgraph/transforms/task.py", line 1709, in add_index_routes
[task 2020-11-28T10:50:57.265Z]     for task in tasks:
[task 2020-11-28T10:50:57.265Z]   File "/builds/worker/checkouts/gecko/taskcluster/taskgraph/transforms/task.py", line 1504, in validate
[task 2020-11-28T10:50:57.265Z]     for task in tasks:
[task 2020-11-28T10:50:57.265Z]   File "/builds/worker/checkouts/gecko/taskcluster/taskgraph/transforms/task.py", line 1481, in task_name_from_label
[task 2020-11-28T10:50:57.265Z]     for task in tasks:
[task 2020-11-28T10:50:57.265Z]   File "/builds/worker/checkouts/gecko/taskcluster/taskgraph/transforms/task.py", line 1436, in set_defaults
[task 2020-11-28T10:50:57.265Z]     for task in tasks:
[task 2020-11-28T10:50:57.265Z]   File "/builds/worker/checkouts/gecko/taskcluster/taskgraph/transforms/task.py", line 1415, in set_implementation
[task 2020-11-28T10:50:57.265Z]     for task in tasks:
[task 2020-11-28T10:50:57.265Z]   File "/builds/worker/checkouts/gecko/taskcluster/taskgraph/transforms/cached_tasks.py", line 61, in cache_task
[task 2020-11-28T10:50:57.265Z]     for task in order_tasks(config, tasks):
[task 2020-11-28T10:50:57.265Z]   File "/builds/worker/checkouts/gecko/taskcluster/taskgraph/transforms/cached_tasks.py", line 19, in order_tasks
[task 2020-11-28T10:50:57.265Z]     pending = deque(tasks)
[task 2020-11-28T10:50:57.265Z]   File "/builds/worker/checkouts/gecko/taskcluster/taskgraph/transforms/docker_image.py", line 94, in fill_template
[task 2020-11-28T10:50:57.265Z]     config.kind, image_name, p
[task 2020-11-28T10:50:57.265Z] Exception: Missing package job for docker-image-debian8-base: deb8-python-psutil

Pushed by justdave@thunderbird.net:
https://hg.mozilla.org/comm-central/rev/78757f77cc0c
Fix tree bustage from Bug 1661624 and 1678451 (ubuntu docker image split and psutil unvendoring) a=bustage

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 85 Branch
Duplicate of this bug: 1679614
You need to log in before you can comment on or make changes to this bug.