crash while changing from tab 1 into 2 (click on the tab top) [@ QDIsPortBuffered]

RESOLVED DUPLICATE of bug 157157

Status

Camino Graveyard
Plug-ins
--
critical
RESOLVED DUPLICATE of bug 157157
16 years ago
16 years ago

People

(Reporter: Julian Mayer, Assigned: Brian Nesse (gone))

Tracking

({crash})

Details

(crash signature)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20020909
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20020909

chimera 0.5 crashed while i clicked on the top of tap 2
on tab 1 i had www.metallica.com, on tab 2 developer.apple.com
i can't dublicate it, but i have a crash log

Reproducible: Couldn't Reproduce

Steps to Reproduce:
1.
2.
3.

Actual Results:  
**********

Date/Time:  2002-09-11 20:15:36 +0200
OS Version: 10.2 (Build 6C115)
Host:       localhost.local.

Command:    Navigator
PID:        24848

Exception:  EXC_BAD_ACCESS (0x0001)
Codes:      KERN_INVALID_ADDRESS (0x0001) at 0x616d657b

Thread 0 Crashed:
 #0   0x91a536e4 in QDIsPortBuffered
 #1   0x91a57eec in QDPlatformGlobalToLocal
 #2   0x0485b46c in 0x485b46c
 #3   0x048ba82c in 0x48ba82c
 #4   0x048c113c in 0x48c113c
 #5   0x048ca62c in 0x48ca62c
 #6   0x048edaec in 0x48edaec
 #7   0x04853070 in 0x4853070
 #8   0x048529b0 in 0x48529b0
 #9   0x006f9c58 in
ns4xPluginStreamListener::OnDataAvailable(nsIPluginStreamInfo *, nsIInputStream
*, unsigned int)
 #10  0x00390e50 in nsPluginStreamListenerPeer::OnDataAvailable(nsIRequest *,
nsISupports *, nsIInputStream *, unsigned int, unsigned int)
 #11  0x001950bc in nsStreamListenerTee::OnDataAvailable(nsIRequest *,
nsISupports *, nsIInputStream *, unsigned int, unsigned int)
 #12  0x004cc060 in nsHttpChannel::OnDataAvailable(nsIRequest *, nsISupports *,
nsIInputStream *, unsigned int, unsigned int)
 #13  0x0018f93c in nsOnDataAvailableEvent::HandleEvent(void)
 #14  0x00195380 in nsARequestObserverEvent::HandlePLEvent(PLEvent *)
 #15  0x05056e80 in PL_HandleEvent
 #16  0x05056d68 in PL_ProcessPendingEvents
 #17  0x05057d30 in nsEventQueueImpl::ProcessPendingEvents(void)
 #18  0x00433b74 in -[EventQueueHandler eventTimer:]
 #19  0x907e521c in __NSFireTimer
 #20  0x90163884 in __CFRunLoopDoTimer
 #21  0x901493e8 in __CFRunLoopRun
 #22  0x90181578 in CFRunLoopRunSpecific
 #23  0x92ba34cc in RunCurrentEventLoopInMode
 #24  0x92bb32f4 in ReceiveNextEventCommon
 #25  0x92bda280 in BlockUntilNextEventMatchingListInMode
 #26  0x93082184 in _DPSNextEvent
 #27  0x930ccf84 in -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:]
 #28  0x930ca500 in -[NSApplication run]
 #29  0x930d2598 in NSApplicationMain
 #30  0x00005024 in main
 #31  0x00004ed4 in _start
 #32  0x00004d04 in start

Thread 1:
 #0   0x90025e8c in select
 #1   0x0101d804 in poll
 #2   0x01019ecc in _pr_poll_with_poll
 #3   0x0016a68c in nsSocketTransportService::Run(void)
 #4   0x050598f0 in nsThread::Main(void *)
 #5   0x0101b388 in _pt_root
 #6   0x90021428 in _pthread_body

Thread 2:
 #0   0x9003f188 in semaphore_wait_signal_trap
 #1   0x9003efa4 in _pthread_cond_wait
 #2   0x01016474 in PR_WaitCondVar
 #3   0x0014b2cc in nsDNSService::DequeuePendingQ(void)
 #4   0x0014acd4 in nsDNSService::Run(void)
 #5   0x050598f0 in nsThread::Main(void *)
 #6   0x0101b388 in _pt_root
 #7   0x90021428 in _pthread_body

Thread 3:
 #0   0x90042d68 in semaphore_timedwait_signal_trap
 #1   0x9003ef94 in _pthread_cond_wait
 #2   0x01016210 in pt_TimedWait
 #3   0x01016488 in PR_WaitCondVar
 #4   0x0505d38c in TimerThread::Run(void)
 #5   0x050598f0 in nsThread::Main(void *)
 #6   0x0101b388 in _pt_root
 #7   0x90021428 in _pthread_body

Thread 4:
 #0   0x9003f188 in semaphore_wait_signal_trap
 #1   0x9003efa4 in _pthread_cond_wait
 #2   0x90824180 in -[NSConditionLock lockWhenCondition:]
 #3   0x933515f4 in -[NSUIHeartBeat _heartBeatThread:]
 #4   0x9081cd38 in forkThreadForFunction
 #5   0x90021428 in _pthread_body

Thread 5:
 #0   0x9003f188 in semaphore_wait_signal_trap
 #1   0x9003efa4 in _pthread_cond_wait
 #2   0x01016474 in PR_WaitCondVar
 #3   0x0505aa2c in nsThreadPool::GetRequest(nsIThread *)
 #4   0x0505b3a0 in nsThreadPoolRunnable::Run(void)
 #5   0x050598f0 in nsThread::Main(void *)
 #6   0x0101b388 in _pt_root
 #7   0x90021428 in _pthread_body

PPC Thread State:
  srr0: 0x91a536e4 srr1: 0x0200f030                vrsave: 0x00000000
   xer: 0x00000000   lr: 0x91a57eec  ctr: 0x90221828   mq: 0x00000000
    r0: 0x00000000   r1: 0xbfffe390   r2: 0x92c7034c   r3: 0x616d6577
    r4: 0xbfffe438   r5: 0x000003df   r6: 0x00000000   r7: 0x00000000
    r8: 0x00000000   r9: 0x0000328b  r10: 0x00000000  r11: 0x00000000
   r12: 0x90221828  r13: 0x00000000  r14: 0x00000000  r15: 0x00000001
   r16: 0x00000001  r17: 0x00000000  r18: 0xbfffe6f8  r19: 0xbfffe704
   r20: 0x042803e0  r21: 0x00000000  r22: 0x0282e9f0  r23: 0xbfffe678
   r24: 0x02ada000  r25: 0x02c394c8  r26: 0x028ff1b8  r27: 0x02ada000
   r28: 0x03ae32b2  r29: 0x03ae32b0  r30: 0xbfffe438  r31: 0x02d142d4



Expected Results:  
no crash
(Reporter)

Comment 1

16 years ago
[loaded plugin /Library/Internet Plug-Ins/Shockwave Flash NP-PPC]
[NSPR: looking up symbol:  NSGetFactory]
[NSPR: looking up symbol:  main]
Sep 11 20:15:36 localhost crashdump: Crash report written to:
/Users/julian/Library/Logs/CrashReporter/Navigator.crash.log

Comment 2

16 years ago
Julian, for future reference, crash reports should be attached to your bugs as a
text file, and not quoted in a bug comment.

Dup of bug 157157?
Keywords: crash
Summary: crash while changing from tab 1 into 2 (click on the tab top) → crash while changing from tab 1 into 2 (click on the tab top) [@ QDIsPortBuffered]

Comment 3

16 years ago
Plugins.
Assignee: saari → bnesse
Component: General → Plug-ins
QA Contact: winnie → petersen
(Assignee)

Comment 4

16 years ago
Dupe of 157157.

*** This bug has been marked as a duplicate of 157157 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Crash Signature: [@ QDIsPortBuffered]
You need to log in before you can comment on or make changes to this bug.