We don't show this application as html the way IE5 does!

VERIFIED DUPLICATE of bug 168022

Status

Core Graveyard
File Handling
VERIFIED DUPLICATE of bug 168022
16 years ago
2 years ago

People

(Reporter: timeless, Assigned: bz)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
We must be doing something wrong
tested
Phoenix: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1b) Gecko/20020910
SeaMonkey: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2a) Gecko/20020906
SeaMonkey: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2a) Gecko/20020910

Phoenix and the old SeaMonkey tell me that I want to save the file.
The New SeaMonkey gives me:
Downloading InstMsiW.exe.htm
You have chosen to download a file of type: "HyperText Markup Language"
[application/octet-stream] from 
...
What should Mozilla do with this file?
 (*) Open using mozilla.exe                                      [ Choose... ]
 ( ) Save file to disk
 [x] Always ask before opening this type of file
------------------------------------------------------------------------------
    [    OK     ] [   Cancel   ]                              [ Advanced... ]

Clicking advanced gives me:

Edit Type
  HyperText Markup Language
-----------------------------------------------------------
  Extension:        htm
  MIME Type:        [application/octet-stream            ] 
  +- Handled By -----------------------------------------+
  | ( ) Save file to disk                                |
  | (*) Application: [F:\Documents and Set] [ Choose...] |
  +------------------------------------------------------+
   [x] Ask me before opening downloaded files of this type
                               [    OK     ] [   Cancel   ]

When I used IE: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)
I got MZ ... (text/html)

Obviously whatever IE does must be right, so I don't know why we even bother
offering to save the file :-)... Although the new seamonkey behavior worries me.
Note: I have two profiles one called "Two" one called "N7", the newer seamonkey
is using the N7 profile, the older is using Two.

I got to that url from
http://www.microsoft.com/msdownload/platformsdk/sdkupdate/default.htm

It's a link for MSI2 for NT4/w2k. unfortunately, it seems that I can't reproduce
the IE behavior, i wonder if they fixed the script.
First, why is this assigned to me?  Second, what did IE do differently?  Third,
why do we care?  I see nothing wrong in our behavior.

*** This bug has been marked as a duplicate of 168022 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

16 years ago
.
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.