Closed Bug 1680972 Opened 3 months ago Closed 3 months ago

The search mode indicator disappears when Ctrl or Shift key is pressed if Windows 10 animations are disabled

Categories

(Firefox :: Address Bar, defect, P3)

Firefox 84
Desktop
All
defect
Points:
2

Tracking

()

VERIFIED FIXED
85 Branch
Iteration:
85.2 - Nov 30 - Dec 13
Tracking Status
firefox-esr78 --- unaffected
firefox83 --- wontfix
firefox84 --- wontfix
firefox85 --- verified
firefox86 --- verified

People

(Reporter: alice0775, Assigned: mak)

References

Details

(Keywords: inputmethod, nightly-community, ux-mode-error)

Attachments

(2 files)

This is annoying when IME is activated

Steps to reproduce:

  1. Activate Search mode
    type @google and space
  2. IME on (MS-IME and ATOK japanese IME)
  3. Type some composition string
  4. Press Ctrl key
    --- Bug, The search mode indicator disappears.
    --- Bug, IME composition string moves to the left.
  5. Release Ctrl key
    --- The search mode indicator reappears.
    --- IME composition string moves to the original position.

Actual results:
The search mode indicator disappears.
IME composition string moves to the left. this is annoying.

Expected results:
The search mode indicator should not disappear.

Has STR: --- → yes
Summary: IME → The search mode indicator disappears when ctrl key is pressed while search mode is activated

:alice0775, if you think that's a regression, could you try to find a regression range using for example mozregression?

not a regression, update 2 IS search mode, this was just not implemented correctly from the beginning. I suspect my patch in bug 1673669 may be fixing this.

Severity: -- → S3
Priority: -- → P3
No longer regressed by: 1658326
Depends on: 1673669
Summary: The search mode indicator disappears when ctrl key is pressed while search mode is activated → The search mode indicator disappears when Ctrl key is pressed during IME composition string conversion

I can still reproduce on Nightly(20201206213246). Bug 1673669 did not fix this.

Keywords: regression
Has Regression Range: yes → no
Keywords: regression
Assignee: nobody → mak
Status: NEW → ASSIGNED
Iteration: --- → 85.2 - Nov 30 - Dec 13
Points: --- → 2

I'm sorry Alice0775, I'm still having difficulties reproducing the bug. I'm on Win10, I type "@google " and that enters search mode, then I enable Japanese IME, press A, the IME popup opens, I try pressing CTRL but nothing happens, I try picking something from the panel and press CTRL, nothing happens. Could you please provide more detailed steps?
I can't find a way for CTRL to make the search mode chiclet disappear, thus I'm probably missing some step or setting, or I'm using the wrong keyboard layout.

Flags: needinfo?(alice0775)

*Nothing special on Windows10 version 1909.
Your str is sufficient to reproduce the issue for me.
Type "@google " and that enters search mode, then I enable Japanese IME, press A, the IME popup opens, I try pressing CTRL.

*If You use Windoes10 version 2004 and 20H2, You may need following Workaround to mitigate MS bug.

  1. Workaround
    https://support.microsoft.com/en-us/help/4564002/you-might-have-issues-on-windows-10-version-20h2-and-windows-10-versio

  2. Without the Workaround,
    The search mode indicator disappear when Ctrl keydown.
    The search mode indicator does not reappear when Ctrl keyup. <- different from version 1909.

Flags: needinfo?(alice0775)

yes, I'm on Windows 2004, are you suggesting that if I "Turn on Use previous version of Microsoft IME" then I should be able to reproduce the bug? I wonder if this CTRL behavior is actually a bug of 1909... I'll try later with that workaround, if I still can't reproduce I may have to hand-off the bug to someone else that can reproduce it.

Yeah, unfortunately I still cannot reproduce even with the old IME version enabled. I'm unassigning because I'm not sure how to proceed without being able to reproduce the bug. If you have further ideas I'll surely try those.
Harry, can you reproduce this one on your Win system?

Status: ASSIGNED → NEW
Iteration: 85.2 - Nov 30 - Dec 13 → ---
Flags: needinfo?(htwyford)
Assignee: mak → nobody

(In reply to Marco Bonardo [:mak] from comment #8)

yes, I'm on Windows 2004, are you suggesting that if I "Turn on Use previous version of Microsoft IME" then I should be able to reproduce the bug?

Yes.
But even without the workaround, the search mode indicator disappears when Ctrl keydown.

I wonder if this CTRL behavior is actually a bug of 1909... I'll try later with that workaround, if I still can't reproduce I may have to hand-off the bug to someone else that can reproduce it.

Nakano san, can you reproduce this?

Flags: needinfo?(masayuki)

STR without IME on (Although I'm not sure this is the same root cause.)

  1. Type @google and hit spacebar
  2. Hit Windows key so that start menu will pop up
  3. Hit Windows key again so that start menu will hide
  4. Ctrl Keydown and keyup

:mak, Can you please try the above STR?

Flags: needinfo?(mak)

nope, I'm sorry, I can't reproduce yet.

Flags: needinfo?(mak)

I cannot reproduce it too. Alice san, what keydown and keyup events are fired for Ctrl key during composition in your environment?
https://w3c.github.io/uievents/tools/key-event-viewer.html

Flags: needinfo?(masayuki) → needinfo?(alice0775)

(In reply to Masayuki Nakano [:masayuki] (he/him)(JST, +0900)(Got a cold, working slower) from comment #13)

I cannot reproduce it too. Alice san, what keydown and keyup events are fired for Ctrl key during composition in your environment?
https://w3c.github.io/uievents/tools/key-event-viewer.html

Attached. See screenshot.

Flags: needinfo?(alice0775) → needinfo?(masayuki)

Odd, same result with mine, but we got different behavior...

Ctrl key events are not handled by MS-IME and ATOK, so, these events are exposed as-is.

According to the screen capture, you hit this style change:
https://searchfox.org/mozilla-central/rev/4415bec7a49c50a338167d9c8934527b9cae59d0/browser/base/content/browser.css#654

It's caused by here:
https://searchfox.org/mozilla-central/rev/4415bec7a49c50a338167d9c8934527b9cae59d0/browser/components/urlbar/UrlbarInput.jsm#2151-2152

It's called by URLBarInput#__on_keydown
https://searchfox.org/mozilla-central/rev/4415bec7a49c50a338167d9c8934527b9cae59d0/browser/components/urlbar/UrlbarInput.jsm#3095,3116

But I don't see the caller... (perhaps, called with Event.type?) So, I still don't see what a pref or something switches the behavior.

Flags: needinfo?(masayuki)

STR without IME:

  1. Click @amazon in top site
    --- Search mode indicator appears. and it has background color as expected.
    --- Dropdown of Addressbar appears as expected.
  2. Type something
    --- Search suggestions in the dropdown are shown as expected.
  3. Hit Windows key or f6 key
    --- Focus moves to elsewhere as expected.
    --- Dropdown of Addressbar is gone.
    --- Background color of the indicator is lost.
  4. Hit Windows key or f6 key again
    --- Addressbar gets focus again as expected.
    --- However, the background color of the indicator is still lost.
  5. Ctrl(or Shift) Keydown and keyup
    --- The indicator disappears/appears

Screencast: https://youtu.be/SXj6uIH8UTY

Can you please try the above STR? (Thank you for your trouble)

Flags: needinfo?(masayuki)

(In reply to Alice0775 White from comment #16)

  1. Hit Windows key or f6 key again
    --- Addressbar gets focus again as expected.
    --- However, the background color of the indicator is still lost.

I don't reproduce this symptom. The megabar gets focused again and the colors are restored correctly. (85.0a1 (2020-12-10), 20H2 (19042.685))

Flags: needinfo?(masayuki)

Okay,
No Bug, if Windows10 animations are enabled.
Bug appears, if Windows10 animations are disabled.

(To turn off animations in Windows 10:
Open "Ease of Access" by pressing the Windows logo key + U > Select "Display" on the left pane>
scroll down to the "Simply and personalize Windows" section > Turn off "Show animations in Windows")

Can you please try STR again? (Thank you very much)

Flags: needinfo?(masayuki)
Summary: The search mode indicator disappears when Ctrl key is pressed during IME composition string conversion → The search mode indicator disappears when Ctrl or Shift key is pressed if Windows 10 animations are disabled

And I can also reproduce the issue on Ubunto20.04 if set ui.prefersReducedMotion to 1 in about:config.

OS: Windows 10 → All

Ah, that helps, I see something with ui.prefersReducedMotion set to 1, let's see

Assignee: nobody → mak
Status: NEW → ASSIGNED
Flags: needinfo?(masayuki)
Flags: needinfo?(htwyford)

The reason for this behavior is that when ui.prefersReducedMotion is set to 1, pressing ESC closes the panel and reverts to the "compact" representation of search mode, that is part of #urlbar-label-box, that (wrongly) obeys to actionoverride for any result type. It should only obey it for overridable result types, that is basically only switchtab.

Iteration: --- → 85.2 - Nov 30 - Dec 13
Pushed by mak77@bonardo.net:
https://hg.mozilla.org/integration/autoland/rev/cbe8ac9bb0c4
Don't hide the Address Bar search mode label when actionoverride is set. r=harry
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → 85 Branch

I have managed to reproduce the issue using the steps and information provided in comment 16 and comment 18 on Fx85.0a1 2020-12-06.

The issue is verified fixed using the latest Fx86.0a1 and Fx85.0b3 on Windows 10 and Ubuntu 18.04. Pressing CTRL no longer makes the search engine disappear from the address bar.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.