Pull-Down menus generated with GoLive don't work

RESOLVED DUPLICATE of bug 155351

Status

Camino Graveyard
HTML Form Controls
RESOLVED DUPLICATE of bug 155351
16 years ago
15 years ago

People

(Reporter: Josh Whitver, Assigned: Brian Ryner (not reading))

Tracking

Details

(URL)

(Reporter)

Description

16 years ago
The pull-down menu on www.whitver.net (pardon the poor web design :) ) does not
function when running Chimera 0.5 on OS X 10.2.

I have also verified that this does not work on other pull-down menus generated
with GoLive (Try the "Go Quickly To..." menu on http://www.gac.edu/).
(Reporter)

Comment 1

16 years ago
As an added detail, I should note that it looks like the mouse-up event isn't
being fully registered if the user picks anything but the top choice in the
menu.  If the user chooses the top choice, the menu works as expected, and if
you go back to the page, it works normally.

If, for the first time, you choose any other option but the first, then the menu
collapses back when you mouse-up (or click the option, if you single-clicked to
expand the pull-down menu), but goes back to displaying the status text.  If you
mouse over the pull-down menu, the right-hand arrow-tab thingy darkens, as
though it were in a state of half-activation.

Comment 2

16 years ago
WorksForMe using Chimera/2002090913 on 10.1.5.
(Reporter)

Comment 3

16 years ago
Could you tell me the sequence of events that you tried?  Which menu item did
you select initially?  Was this after a fresh launch of Chimera, or had you used
other pull-down menus before going to the website(s) mentioned?

(Also, the O.S. factor could be important; could someone with 10.2 give it a go?)

Comment 4

16 years ago
Dup of bug 160707?

Comment 5

15 years ago
WFM 2002102204 Mac OS X 10.2.1

Josh, what version of Chimera are you using?
(Reporter)

Comment 6

15 years ago
Not that version; I'll download the latest nightly and give it a shot.  If that
doesn't work, would it be helpful for me to make a movie and host it somewhere
so you could see exactly what it's doing for me?  I could fire up Snapz Pro and
take care of that pretty easily if upgrading to the newest nightly doesn't fix it.
(Reporter)

Comment 7

15 years ago
I downloaded the 11/01/02 nightly, and it still did the same thing it's always
done.  I'm on 10.2.1, and the behavior exists on both a beige G3 and a gigabit
G4/400.

I've posted a movie of what happens at:
http://www.whitver.net/~josh/chimera-pulldown-bug.mov

As you'll see, the menu simply returns without doing anything.  Then, I move the
cursor over the menu, and the widget at the right darkens, as though it's
somehow stuck in a half-activated state.  The cursor sometimes disappears from
the movie, but whenever the up-down-arrow part of the menu is darkened, the
cursor is hovering over the pull-down.

It's not until I choose the first option in the menu that the menu functions
(the next time I use the menu after choosing the first option, it finally takes
me to the page indicated by the menu).
(Reporter)

Comment 8

15 years ago
Has anyone looked at the movie I created which shows the buggy behavior?  As a
reminder, it's at:
http://www.whitver.net/~josh/chimera-pulldown-bug.mov  

Comment 9

15 years ago
This page uses the same JavaScript technique as bug 160707:
(window.open(popup.options[popup.selectedIndex].value, '_top');

Both are duplicates of bug 155351.

*** This bug has been marked as a duplicate of 155351 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.