Closed Bug 1681529 Opened 4 months ago Closed 2 months ago

Fission Crash in [@ mozilla::ipc::InputStreamHelper::SerializeInputStreamAsPipe] on Google Image search page

Categories

(Core :: IPC, defect, P1)

defect

Tracking

()

RESOLVED FIXED
87 Branch
Fission Milestone M6c
Tracking Status
firefox-esr78 --- disabled
firefox83 --- disabled
firefox84 --- disabled
firefox85 --- disabled
firefox86 --- wontfix
firefox87 --- fixed

People

(Reporter: aryx, Assigned: nika)

References

Details

(Keywords: crash, Whiteboard: [2/5] patches re-pushed)

Crash Data

Attachments

(12 files, 1 obsolete file)

48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review

All crashes with Fission enabled and on the google image search page, like https://www.google.de/searchbyimage/upload - uploading an image or submitting an image url works locally.

Crash report: https://crash-stats.mozilla.org/report/index/6e33071c-929d-4bef-9180-3ecd00201209

MOZ_CRASH Reason: MOZ_DIAGNOSTIC_ASSERT(false) (NS_SUCCEEDED(aInputStream->IsNonBlocking(&nonBlocking)))

Top 10 frames of crashing thread:

0 xul.dll static mozilla::ipc::InputStreamHelper::SerializeInputStreamAsPipe ipc/glue/InputStreamUtils.cpp:159
1 xul.dll nsMIMEInputStream::SerializeInternal<mozilla::ipc::ParentToChildStreamActorManager> netwerk/base/nsMIMEInputStream.cpp:384
2 xul.dll mozilla::ipc::`anonymous namespace'::SerializeInputStreamWithFdsParent<mozilla::dom::ContentParent> ipc/glue/IPCStreamUtils.cpp:82
3 xul.dll mozilla::ipc::AutoIPCStream::Serialize ipc/glue/IPCStreamUtils.cpp:403
4 xul.dll static mozilla::ipc::IPDLParamTraits<nsIInputStream*>::Write ipc/glue/IPCStreamUtils.cpp:503
5 xul.dll static mozilla::ipc::IPDLParamTraits<mozilla::dom::DocShellLoadStateInit>::Write ipc/ipdl/DOMTypes.cpp:2231
6 xul.dll static mozilla::ipc::IPDLParamTraits<nsDocShellLoadState*>::Write dom/ipc/DocShellMessageUtils.cpp:18
7 xul.dll static mozilla::ipc::IPDLParamTraits<mozilla::Maybe<RefPtr<nsDocShellLoadState> > >::Write ipc/glue/IPDLParamTraits.h:256
8 xul.dll std::_Func_impl_no_alloc<`lambda at /builds/worker/workspace/obj-build/ipc/ipdl/PContentParent.cpp:12878:54', void, mozilla::Tuple<const bool&, const mozilla::Maybe<RefPtr<nsDocShellLoadState> >&, const mozilla::Maybe<bool>&> >::_Do_call 
9 xul.dll mozilla::dom::ContentParent::RecvNotifyOnHistoryReload dom/ipc/ContentParent.cpp:6998
Fission Milestone: --- → ?

P1 because this is a parent process. Crash when reloading a page with a postdata stream from an image upload.

IsNonBlocking() should be infallible. Why is it failing?

needinfo'ing Nika

Severity: -- → S1
Fission Milestone: ? → M6c
Flags: needinfo?(nika)
Priority: -- → P1

I found a crash from Nightly 83 (with Fission enabled): bp-6269a4a9-526c-40d9-bcd0-d2dd50201011

So this has been happening in builds from at least since October.

The URLs for all of the other crashes were variants on that "search by image" URL, but for the crash I linked in my previous comment it is https://bugzilla.mozilla.org/post_bug.cgi

(In reply to Chris Peterson [:cpeterson] from comment #1)

IsNonBlocking() should be infallible. Why is it failing?

Taking a quick look at searchfox, there are a number of nsIInputStreams that wrap another stream and can return an error if the inner stream is null: 1 2 3 4 5 6

If that's the case, it might have been better if it had just crashed so that we could at least find out which concrete class it was.

I've done some investigation and figured out why this crash is likely happening. It's related to the serialization behaviour of nsStringInputStream with large serialization buffers, which can lead to some input streams being created in an invalid state. It's probably not come up before in tests because it requires a string payload of over 1mb.

I've written a test which should help exercise this code path, and confirmed my theory with rr, but have yet to come up with a concrete patch. self-assigning.

Assignee: nobody → nika
Flags: needinfo?(nika)

Without the other patches in this series, this test fails with both with and
without Fission enabled, for two different reasons.

With Fission disabled, the second reload request appears as empty, due to us
being unable to rewind the postData nsIInputStream. With Fission enabled, the
second reload request causes crashes due to the nsMIMEInputStream's invariant of
requiring a seekable stream is invalidated, causing the nsICloneableInputStream
implementation to misbehave.

In a later part of this patch series, this will be necessary to handle cases
when BackgroundParentImpl* (or other PBackgroundParent subclasses) are passed to
RemoteLazyInputStreamParent::Create, as previously this would've caused an
undefined linker symbol error. By using an explicit overload set, we can move
the subclass conversion to the caller, and avoid this issue.

Previously, we would apply the InputStreamLengthWrapper before
DelayedStartInputStream, which meant that a stream serialized with aDelayedStart
would not correctly implement nsIInputStreamLength. By inverting the order of
these wrappers, the nsIInputStreamLength implementation is visible, without
impacting the functionality of the DelayedStartInputStream wrapper.

When aDelayedStart is specified, if the created IPCStream contains an internal
IPC stream actor, an actor is used under the hood to send raw data between
processes when needed. This is usually done to reduce overhead in cases where
the target process may not use the nsIInputStream immediately, if at all.

By switching to using RemoteLazyInputStream when sending DelayedStart actors
from parent to content, the amount of data sent in the initial payload is
reduced even further, and the stream is optimized to allow sending it back to
the parent process without streaming the data through the content process again.

Normal delayed start streams are still used when sending payloads from other
processes, as RemoteLazyInputStream is only supported for nsIInputStreams
originating in the parent process.

The current set of cases where a nsIInputStream is directly serialized over IPC
is fairly limited, and includes cases where the IPDL struct may be directly
stored within a content process, having the nsIInputStream left unused.

By switching this serialization to DelayedStart, we can avoid performing
unnecessary streaming copies of IPC data when sending postdata streams related
to session history and document navigation, while also avoiding issues like this
coming up again due to delayed start being the default.

This patch introduces a new SeekableStreamWrapper class which handles adapting
nsIInputStreams which support being cheaply cloned using nsICloneableInputStream
into seekable input streams by operating on a clone of the original stream, and
re-cloning that stream when seeking backwards.

This wrapper is generally intended to be used with nsPipeInputStream as that
type supports both a fairly cheap clone operation, and keeping a large internal
buffer which is fairly cheap to seek using this method, but should also work
with other types such as RemoteLazyInputStream or nsStringStream.

An alternate strategy was considered where nsPipe was given internal support for
a mSeekable flag to be set on creation. This flag would then have a similar
effect, except with additional optimizations due to being visible within the
implementation of the nsPipe, rather than relying on an unadvanced
nsPipeInputStream to keep the buffer alive.

I ended up choosing this approach instead for a few reasons:

  • The seekable adapter can be applied to an already-created nsPipeInputStream,
    such as one received from IPC. With the nsPipe approach, making an IPC stream
    seekable either requires telling IPCStreamDestination to use a seekable pipe
    ahead of time, or performing a NS_AsyncCopy from the IPC-provided pipe into a
    different seekable pipe, which is likely wasted effort and would prevent
    optimizations such as RemoteLazyInputStream and DelayedStart streams.
  • The adapter can support other features of the underlying stream, such as
    nsIInputStreamLength, without resorting to adding additional adapter layers
    on top of the returned nsPipe.
  • The performance is unlikely to be substantially different in the most common
    case, which is using Seek(NS_SEEK_SET, 0) to return to the beginning of the
    stream.
  • Less additional complexity is added to the already-complicated internals of
    nsPipe, and instead it is kept in a separate wrapper stream, which is easier
    to review.

Using nsStorageStream, as is used by EnsureUploadStreamIsCloneable, was also
considered, but was rejected as it has similar problems to the seekable nsPipe
approach and also doesn't implement nsIAsyncStream, meaning that one must wait
for the NS_AsyncCopy to be completed before reading the stream.

It may actually be possible to replace the existing uses of nsStorageStream with
a wrapped nsPipe in the future, but that is left as follow-up material, and may
have memory overhead implications due to nsPipe not resizing the final segment,
unlike nsStorageStream.

nsMIMEInputStream has a requirement that the inner nsIInputStream object
implement nsISeekableStream, which is usually enforced by the SetData method.
This check was bypassed by the Deserialize method, which unfortunately meant
that non-seekable IPC payloads could end up within a nsMIMEInputStream when sent
from another process (e.g. due to large nsStringStreams being serialized as
nsPipes over IPC).

This patch uses the SeekableStreamWrapper introduced in the previous patch to
wrap the inner stream when deserializing nsMIMEInputStream, avoiding the
previously mentioned issue.

Previously if Clone() was called on a closed nsPipeInputStream, it could cause
crashes due to the already-closed nsPipeInputStream being added to mInputList,
violating internal nsPipe invariants. Skipping adding the stream to that list
should avoid this edge-case, as the pipe is already closed.

This basic GTest exercises some of the basic functionality of the
SeekableStreamWrapper when applied to a nsPipe.

Attachment #9197168 - Attachment is obsolete: true

Given that we're in the soft-freeze and these changes are fairly significant, I think I'm going to wait until the beginning of the next nightly cycle to land this. We don't allow enabling Fission outside of nightly, so beta users should be unimpacted by the crash.

Pushed by nlayzell@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/43cc14af229d
Part 1: Add a test for reloading a page with a large postdata payload, r=peterv
https://hg.mozilla.org/integration/autoland/rev/49c28bfc4da4
Part 2: Use an overload set instead of template for RemoteLazyInputStreamParent::Create, r=baku
https://hg.mozilla.org/integration/autoland/rev/3385635e9521
Part 3: Apply InputStreamLengthWrapper after DelayedStartInputStream, r=baku
https://hg.mozilla.org/integration/autoland/rev/1a33ea8b533d
Part 4: Serialize aDelayedStart streams from parent to child as RemoteLazyInputStreams, r=baku
https://hg.mozilla.org/integration/autoland/rev/9852de883959
Part 5: Serialize `nsIInputStream` over IPC with aDelayedStart by default, r=baku
https://hg.mozilla.org/integration/autoland/rev/ceb55436928a
Part 6: Introduce a SeekableStreamWrapper to make pipes seekable, r=baku
https://hg.mozilla.org/integration/autoland/rev/5a5f514a6cfe
Part 7: Wrap the inner streams in a nsMIMEInputStream to make them seekable, r=baku,necko-reviewers,dragana
https://hg.mozilla.org/integration/autoland/rev/b562b6038855
Part 8: Handle clones of closed nsPipeInputStreams, r=baku
https://hg.mozilla.org/integration/autoland/rev/99d1c9682dc2
Part 9: Add a basic test for the seekable stream wrapper, r=baku

Backed out for bustage on TestSeekableStreamWrapper.cpp

backout: https://hg.mozilla.org/integration/autoland/rev/2e6eecc66391840e949a63febe927f78cf4773fc

push: https://treeherder.mozilla.org/jobs?repo=autoland&group_state=expanded&revision=99d1c9682dc23c505442b6146b2b7cd9e768ccb4&searchStr=build&selectedTaskRun=IpV7JM74Rk2Mg0aBl2PIRw.0

failure log: https://treeherder.mozilla.org/logviewer?job_id=327746148&repo=autoland&lineNumber=43660

[task 2021-01-25T21:27:27.807Z] 21:27:27 INFO - In file included from Unified_cpp_xpcom_tests_gtest2.cpp:38:
[task 2021-01-25T21:27:27.808Z] 21:27:27 ERROR - /builds/worker/checkouts/gecko/xpcom/tests/gtest/TestSeekableStreamWrapper.cpp:18:7: error: use of undeclared identifier 'NS_NewPipe2'
[task 2021-01-25T21:27:27.808Z] 21:27:27 INFO - NS_NewPipe2(getter_AddRefs(reader), getter_AddRefs(writer), true, true);
[task 2021-01-25T21:27:27.808Z] 21:27:27 INFO - ^
[task 2021-01-25T21:27:27.808Z] 21:27:27 INFO - 1 error generated.
[task 2021-01-25T21:27:27.808Z] 21:27:27 ERROR - make[4]: *** [/builds/worker/checkouts/gecko/config/rules.mk:676: Unified_cpp_xpcom_tests_gtest2.o] Error 1
[task 2021-01-25T21:27:27.808Z] 21:27:27 INFO - make[4]: Leaving directory '/builds/worker/workspace/obj-build/xpcom/tests/gtest'
[task 2021-01-25T21:27:27.808Z] 21:27:27 INFO - make[4]: *** Waiting for unfinished jobs....

Flags: needinfo?(nika)

SetData will check that mStartedReading has not been set yet to ensure the
stream is in a non-partially-read state. This can lead to assertion failures
when sending a stream not seeked to the beginning over IPC.

Streams serialized with the default nsIInputStream serializer will be serialized
with delayedStart, meaning that when sent from the parent process to the content
process it will be serialized as a RemoteLazyInputStream.

In the specific case of SendOpenStream this causes issues, as the content
process code depends on the synchronous nature of nsIFileInputStream to allow it
to be wrapped in a SnappyUncompressInputStream, which requires a sync stream.

Relying on this property is not generally correct and only works because we know
only nsFileInputStream will be sent by the parent process. Other types of sync
streams may be received as async if they are sufficiently large, such as
nsStringInputStream.

Flags: needinfo?(nika)
Pushed by nlayzell@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/91979e21aa8e
Part 1: Add a test for reloading a page with a large postdata payload, r=peterv
https://hg.mozilla.org/integration/autoland/rev/f0893f544219
Part 2: Use an overload set instead of template for RemoteLazyInputStreamParent::Create, r=baku
https://hg.mozilla.org/integration/autoland/rev/dbc85d0bffaf
Part 3: Apply InputStreamLengthWrapper after DelayedStartInputStream, r=baku
https://hg.mozilla.org/integration/autoland/rev/7ea2e9cc8bad
Part 4: Serialize aDelayedStart streams from parent to child as RemoteLazyInputStreams, r=baku
https://hg.mozilla.org/integration/autoland/rev/ecd8c3b8fdb4
Part 5: Serialize `nsIInputStream` over IPC with aDelayedStart by default, r=baku
https://hg.mozilla.org/integration/autoland/rev/f2515096b378
Part 6: Introduce a SeekableStreamWrapper to make pipes seekable, r=baku
https://hg.mozilla.org/integration/autoland/rev/d0b11c08666a
Part 7: Wrap the inner streams in a nsMIMEInputStream to make them seekable, r=baku,necko-reviewers,dragana
https://hg.mozilla.org/integration/autoland/rev/6e185ec2c4a4
Part 8: Handle clones of closed nsPipeInputStreams, r=baku
https://hg.mozilla.org/integration/autoland/rev/dbea9952ec79
Part 9: Add a basic test for the seekable stream wrapper, r=baku
https://hg.mozilla.org/integration/autoland/rev/f0ba367de05e
Part 10: Set StartedReading after calling SetData, r=baku,necko-reviewers,valentin
https://hg.mozilla.org/integration/autoland/rev/f1f988155c82
Part 11: Avoid using DelayedStart when serialzing the reply from SendOpenStream, r=asuth
Pushed by nlayzell@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/968e17db71df
Part 1: Add a test for reloading a page with a large postdata payload, r=peterv
https://hg.mozilla.org/integration/autoland/rev/a5a8eac68b87
Part 2: Use an overload set instead of template for RemoteLazyInputStreamParent::Create, r=baku
https://hg.mozilla.org/integration/autoland/rev/636b1a7c13e4
Part 3: Apply InputStreamLengthWrapper after DelayedStartInputStream, r=baku
https://hg.mozilla.org/integration/autoland/rev/e8620622208a
Part 4: Serialize aDelayedStart streams from parent to child as RemoteLazyInputStreams, r=baku
https://hg.mozilla.org/integration/autoland/rev/b1d1550a66ca
Part 5: Serialize `nsIInputStream` over IPC with aDelayedStart by default, r=baku
https://hg.mozilla.org/integration/autoland/rev/78b186ec645a
Part 6: Introduce a SeekableStreamWrapper to make pipes seekable, r=baku
https://hg.mozilla.org/integration/autoland/rev/ce57c5a26c25
Part 7: Wrap the inner streams in a nsMIMEInputStream to make them seekable, r=baku,necko-reviewers,dragana
https://hg.mozilla.org/integration/autoland/rev/4def7578ced0
Part 8: Handle clones of closed nsPipeInputStreams, r=baku
https://hg.mozilla.org/integration/autoland/rev/29df8d4c984a
Part 9: Add a basic test for the seekable stream wrapper, r=baku
https://hg.mozilla.org/integration/autoland/rev/b1269f35d525
Part 10: Set StartedReading after calling SetData, r=baku,necko-reviewers,valentin
https://hg.mozilla.org/integration/autoland/rev/c87d0f32d7a6
Part 11: Avoid using DelayedStart when serialzing the reply from SendOpenStream, r=asuth

Backed out 11 changesets (bug 1681529) for talos crashes.

Push with failures: https://treeherder.mozilla.org/jobs?repo=autoland&group_state=expanded&fromchange=c09ab610821bfadb714fcfd632968cd95ebeb22a&searchStr=talos&selectedTaskRun=f0QDGAqtSvmy60_HEBgzSA.0&tochange=4206476fa548c5e5681d945371cdcc8b8a9b8259

Backout link: https://hg.mozilla.org/integration/autoland/rev/4206476fa548c5e5681d945371cdcc8b8a9b8259

Failure log: https://treeherder.mozilla.org/logviewer?job_id=328671790&repo=autoland&lineNumber=1047

[task 2021-02-03T07:19:53.311Z] 07:19:53     INFO -  TEST-START | ts_paint_webext
[task 2021-02-03T07:19:53.313Z] 07:19:53     INFO -  Initialising browser for ts_paint_webext test...
[task 2021-02-03T07:19:53.313Z] 07:19:53     INFO -  Cloning profile located at C:\Users\task_1612332554\build\tests\talos\talos\base_profile
[task 2021-02-03T07:19:53.315Z] 07:19:53     INFO -  Merging profile: C:\Users\task_1612332554\build\tests\talos\talos\profile_data\base
[task 2021-02-03T07:19:53.315Z] 07:19:53     INFO -  Merging profile: C:\Users\task_1612332554\build\tests\talos\talos\profile_data\common
[task 2021-02-03T07:19:53.320Z] 07:19:53     INFO -  Merging profile: C:\Users\task_1612332554\build\tests\talos\talos\profile_data\perf
[task 2021-02-03T07:19:53.325Z] 07:19:53     INFO -  Installing Add-ons:
[task 2021-02-03T07:19:53.325Z] 07:19:53     INFO -  ['C:\\Users\\task_1612332554\\build\\tests\\talos\\talos/talos-powers']
[task 2021-02-03T07:19:53.330Z] 07:19:53     INFO -  Installing Webextensions:
[task 2021-02-03T07:19:53.330Z] 07:19:53     INFO -  C:\Users\task_1612332554\build\tests\talos\talos\webextensions\dummy\dummy.xpi
[task 2021-02-03T07:19:53.334Z] 07:19:53     INFO -  Application command: C:\Users\task_1612332554\build\application\firefox\firefox -wait-for-browser -no-deelevate http://127.0.0.1:49903/getInfo.html --wait-for-browser -profile c:\users\task_1612332554\appdata\local\temp\tmproheyz\profile
[task 2021-02-03T07:19:53.344Z] 07:19:53     INFO -  TEST-INFO | started process 7844 (C:\Users\task_1612332554\build\application\firefox\firefox -wait-for-browser -no-deelevate http://127.0.0.1:49903/getInfo.html)
[task 2021-02-03T07:19:54.839Z] 07:19:54    ERROR -  JavaScript error: moz-extension://2c4a030d-a875-4af5-8148-fcb35b6cf99f/chrome/talos-powers-content.js, line 158: SyntaxError: missing } after function body
[task 2021-02-03T07:19:54.839Z] 07:19:54     INFO -  JavaScript note: moz-extension://2c4a030d-a875-4af5-8148-fcb35b6cf99f/chrome/talos-powers-content.js, line 152: { opened at line 152, column 7
[task 2021-02-03T07:19:55.364Z] 07:19:55    ERROR -  JavaScript error: moz-extension://2c4a030d-a875-4af5-8148-fcb35b6cf99f/chrome/talos-powers-content.js, line 158: SyntaxError: missing } after function body
[task 2021-02-03T07:19:55.364Z] 07:19:55     INFO -  JavaScript note: moz-extension://2c4a030d-a875-4af5-8148-fcb35b6cf99f/chrome/talos-powers-content.js, line 152: { opened at line 152, column 7
[task 2021-02-03T07:19:55.395Z] 07:19:55     INFO -  console.warn: SearchSettings: "get: No settings file exists, new profile?" (new Error("", "(unknown module)"))
[task 2021-02-03T07:19:56.078Z] 07:19:56    ERROR -  JavaScript error: moz-extension://2c4a030d-a875-4af5-8148-fcb35b6cf99f/chrome/talos-powers-content.js, line 158: SyntaxError: missing } after function body
[task 2021-02-03T07:19:56.078Z] 07:19:56     INFO -  JavaScript note: moz-extension://2c4a030d-a875-4af5-8148-fcb35b6cf99f/chrome/talos-powers-content.js, line 152: { opened at line 152, column 7
[task 2021-02-03T07:20:26.170Z] 07:20:26     INFO -  TEST-INFO | 7844: exit 23c
[task 2021-02-03T07:20:26.188Z] 07:20:26     INFO -  Browser initialized.
[task 2021-02-03T07:20:26.188Z] 07:20:26     INFO -  Fission enabled: False
[task 2021-02-03T07:20:26.446Z] 07:20:26     INFO -  Running cycle 1/20 for ts_paint_webext test...
[task 2021-02-03T07:20:26.446Z] 07:20:26     INFO -  Using env: {'ALLUSERSPROFILE': 'C:\\ProgramData',
[task 2021-02-03T07:20:26.446Z] 07:20:26     INFO -   'APPDATA': 'C:\\Users\\task_1612332554\\AppData\\Roaming',
[task 2021-02-03T07:20:26.446Z] 07:20:26     INFO -   'COMMONPROGRAMFILES': 'C:\\Program Files\\Common Files',
[task 2021-02-03T07:20:26.446Z] 07:20:26     INFO -   'COMMONPROGRAMFILES(X86)': 'C:\\Program Files (x86)\\Common Files',
[task 2021-02-03T07:20:26.446Z] 07:20:26     INFO -   'COMMONPROGRAMW6432': 'C:\\Program Files\\Common Files',
[task 2021-02-03T07:20:26.446Z] 07:20:26     INFO -   'COMPUTERNAME': 'T-W1064-MS-030',
[task 2021-02-03T07:20:26.447Z] 07:20:26     INFO -   'COMSPEC': 'C:\\windows\\system32\\cmd.exe',
[task 2021-02-03T07:20:26.447Z] 07:20:26     INFO -   'DRIVERDATA': 'C:\\Windows\\System32\\Drivers\\DriverData',
[task 2021-02-03T07:20:26.447Z] 07:20:26     INFO -   'EXTRA_MOZHARNESS_CONFIG': '{"installer_url": "https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/QmAkEWJkTn2Fb7mICyqWkA/artifacts/public/build/target.zip", "test_packages_url": "https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/QmAkEWJkTn2Fb7mICyqWkA/artifacts/public/build/target.test_packages.json"}',
[task 2021-02-03T07:20:26.447Z] 07:20:26     INFO -   'GECKO_HEAD_REPOSITORY': 'https://hg.mozilla.org/integration/autoland',
[task 2021-02-03T07:20:26.447Z] 07:20:26     INFO -   'GECKO_HEAD_REV': 'c87d0f32d7a6a33765ecedbc69c6278f235b1c57',
[task 2021-02-03T07:20:26.447Z] 07:20:26     INFO -   'HG_CACHE': 'C:\\tooltool-cache',
[task 2021-02-03T07:20:26.447Z] 07:20:26     INFO -   'HOMEDRIVE': 'C:',
[task 2021-02-03T07:20:26.447Z] 07:20:26     INFO -   'HOMEPATH': '\\Users\\task_1612332554',
[task 2021-02-03T07:20:26.447Z] 07:20:26     INFO -   'JSGC_DISABLE_POISONING': '1',
[task 2021-02-03T07:20:26.448Z] 07:20:26     INFO -   'LD_LIBRARY_PATH': 'C:\\Users\\task_1612332554\\build\\application\\firefox',
[task 2021-02-03T07:20:26.448Z] 07:20:26     INFO -   'LOCALAPPDATA': 'C:\\Users\\task_1612332554\\AppData\\Local',
[task 2021-02-03T07:20:26.448Z] 07:20:26     INFO -   'LOGONSERVER': '\\\\T-W1064-MS-030',
[task 2021-02-03T07:20:26.448Z] 07:20:26     INFO -   'MINIDUMP_SAVE_PATH': 'C:\\Users\\task_1612332554\\build\\blobber_upload_dir',
[task 2021-02-03T07:20:26.448Z] 07:20:26     INFO -   'MINIDUMP_STACKWALK': 'C:/Users/task_1612332554/fetches\\minidump_stackwalk\\minidump_stackwalk.exe',
[task 2021-02-03T07:20:26.448Z] 07:20:26     INFO -   'MOZILLABUILD': 'C:\\mozilla-build',
[task 2021-02-03T07:20:26.448Z] 07:20:26     INFO -   'MOZ_AUTOMATION': '1',
[task 2021-02-03T07:20:26.448Z] 07:20:26     INFO -   'MOZ_CRASHREPORTER': '1',
[task 2021-02-03T07:20:26.448Z] 07:20:26     INFO -   'MOZ_CRASHREPORTER_NO_REPORT': '1',
[task 2021-02-03T07:20:26.448Z] 07:20:26     INFO -   'MOZ_DISABLE_NONLOCAL_CONNECTIONS': '1',
[task 2021-02-03T07:20:26.448Z] 07:20:26     INFO -   'MOZ_FETCHES': '[{"artifact": "public/build/fix-stacks.tar.bz2", "extract": true, "task": "LOixcniRSM-W796fepiIWQ"}, {"artifact": "public/build/minidump_stackwalk.tar.xz", "extract": true, "task": "WPw7g48bTL68eTz_1lb6Jw"}]',
[task 2021-02-03T07:20:26.449Z] 07:20:26     INFO -   'MOZ_FETCHES_DIR': 'C:/Users/task_1612332554/fetches',
[task 2021-02-03T07:20:26.449Z] 07:20:26     INFO -   'MOZ_SCM_LEVEL': '3',
[task 2021-02-03T07:20:26.449Z] 07:20:26     INFO -   'MOZ_UPLOAD_DIR': 'C:\\Users\\task_1612332554\\build\\blobber_upload_dir',
[task 2021-02-03T07:20:26.449Z] 07:20:26     INFO -   'MOZ_WEBRENDER': '0',
[task 2021-02-03T07:20:26.449Z] 07:20:26     INFO -   'NO_EM_RESTART': '1',
[task 2021-02-03T07:20:26.449Z] 07:20:26     INFO -   'NUMBER_OF_PROCESSORS': '8',
[task 2021-02-03T07:20:26.449Z] 07:20:26     INFO -   'ONEDRIVE': 'C:\\Users\\task_1612332554\\OneDrive',
[task 2021-02-03T07:20:26.449Z] 07:20:26     INFO -   'OS': 'Windows_NT',
[task 2021-02-03T07:20:26.449Z] 07:20:26     INFO -   'PATH': 'C:\\Users\\task_1612332554\\build\\venv\\Scripts;C:\\windows\\system32;C:\\windows;C:\\windows\\System32\\Wbem;C:\\windows\\System32\\WindowsPowerShell\\v1.0\\;C:\\windows\\System32\\OpenSSH\\;C:\\Program Files\\Puppet Labs\\Puppet\\bin;C:\\Program Files\\Mellanox\\MLNX_VPI\\IB\\Tools;C:\\Program Files\\Mellanox\\MLNX_CIMProvider\\lib\\mft;C:\\Program Files\\Git\\cmd;C:\\Program Files (x86)\\GNU\\GnuPG\\pub;C:\\Program Files\\Mercurial\\;C:\\Program Files\\Mercurial;C:\\mozilla-build\\bin;C:\\mozilla-build\\kdiff;C:\\mozilla-build\\moztools-x64\\bin;C:\\mozilla-build\\mozmake;C:\\mozilla-build\\nsis-3.01;C:\\mozilla-build\\python;C:\\mozilla-build\\python\\Scripts;C:\\mozilla-build\\python3;C:\\mozilla-build\\msys\\bin;C:\\mozilla-build\\msys\\local\\bin;C:\\Program Files (x86)\\Windows Kits\\10\\Windows Performance Toolkit\\;C:\\Users\\task_1612332554\\AppData\\Local\\Microsoft\\WindowsApps',
[task 2021-02-03T07:20:26.449Z] 07:20:26     INFO -   'PATHEXT': '.COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH;.MSC',
[task 2021-02-03T07:20:26.449Z] 07:20:26     INFO -   'PIP_DOWNLOAD_CACHE': 'C:\\pip-cache',
[task 2021-02-03T07:20:26.449Z] 07:20:26     INFO -   'PROCESSOR_ARCHITECTURE': 'AMD64',
[task 2021-02-03T07:20:26.449Z] 07:20:26     INFO -   'PROCESSOR_IDENTIFIER': 'Intel64 Family 6 Model 94 Stepping 3, GenuineIntel',
[task 2021-02-03T07:20:26.449Z] 07:20:26     INFO -   'PROCESSOR_LEVEL': '6',
[task 2021-02-03T07:20:26.449Z] 07:20:26     INFO -   'PROCESSOR_REVISION': '5e03',
[task 2021-02-03T07:20:26.449Z] 07:20:26     INFO -   'PROGRAMDATA': 'C:\\ProgramData',
[task 2021-02-03T07:20:26.449Z] 07:20:26     INFO -   'PROGRAMFILES': 'C:\\Program Files',
[task 2021-02-03T07:20:26.449Z] 07:20:26     INFO -   'PROGRAMFILES(X86)': 'C:\\Program Files (x86)',
[task 2021-02-03T07:20:26.449Z] 07:20:26     INFO -   'PROGRAMW6432': 'C:\\Program Files',
[task 2021-02-03T07:20:26.449Z] 07:20:26     INFO -   'PROMPT': '$P$G',
[task 2021-02-03T07:20:26.450Z] 07:20:26     INFO -   'PSMODULEPATH': '%ProgramFiles%\\WindowsPowerShell\\Modules;C:\\windows\\system32\\WindowsPowerShell\\v1.0\\Modules;C:\\Program Files\\Mellanox\\MLNX_VPI\\Tools\\WMI\\Modules;C:\\Program Files\\Mellanox\\MLNX_CIMProvider\\WMI\\Modules',
[task 2021-02-03T07:20:26.450Z] 07:20:26     INFO -   'PUBLIC': 'C:\\Users\\Public',
[task 2021-02-03T07:20:26.450Z] 07:20:26     INFO -   'PYTHONPATH': 'C:\\Users\\task_1612332554\\build\\tests\\talos',
[task 2021-02-03T07:20:26.450Z] 07:20:26     INFO -   'RUST_BACKTRACE': 'full',
[task 2021-02-03T07:20:26.450Z] 07:20:26     INFO -   'SCCACHE_DISABLE': '1',
[task 2021-02-03T07:20:26.450Z] 07:20:26     INFO -   'STYLO_FORCE_ENABLED': '1',
[task 2021-02-03T07:20:26.450Z] 07:20:26     INFO -   'SYSTEMDRIVE': 'C:',
[task 2021-02-03T07:20:26.450Z] 07:20:26     INFO -   'SYSTEMROOT': 'C:\\windows',
[task 2021-02-03T07:20:26.450Z] 07:20:26     INFO -   'TASKCLUSTER_ROOT_URL': 'https://firefox-ci-tc.services.mozilla.com',
[task 2021-02-03T07:20:26.450Z] 07:20:26     INFO -   'TASK_ID': 'f0QDGAqtSvmy60_HEBgzSA',
[task 2021-02-03T07:20:26.450Z] 07:20:26     INFO -   'TASK_STOP_TIME': '1612333561',
[task 2021-02-03T07:20:26.451Z] 07:20:26     INFO -   'TEMP': 'C:\\Users\\task_1612332554\\AppData\\Local\\Temp',
[task 2021-02-03T07:20:26.451Z] 07:20:26     INFO -   'TMP': 'C:\\Users\\task_1612332554\\AppData\\Local\\Temp',
[task 2021-02-03T07:20:26.451Z] 07:20:26     INFO -   'TOOLTOOL_CACHE': 'C:\\builds\\tooltool_cache',
[task 2021-02-03T07:20:26.451Z] 07:20:26     INFO -   'USERDOMAIN': 'T-W1064-MS-030',
[task 2021-02-03T07:20:26.451Z] 07:20:26     INFO -   'USERDOMAIN_ROAMINGPROFILE': 'T-W1064-MS-030',
[task 2021-02-03T07:20:26.451Z] 07:20:26     INFO -   'USERNAME': 'task_1612332554',
[task 2021-02-03T07:20:26.451Z] 07:20:26     INFO -   'USERPROFILE': 'C:\\Users\\task_1612332554',
[task 2021-02-03T07:20:26.451Z] 07:20:26     INFO -   'VIRTUAL_ENV': 'C:\\Users\\task_1612332554\\build\\venv',
[task 2021-02-03T07:20:26.452Z] 07:20:26     INFO -   'WINDIR': 'C:\\windows'}
[task 2021-02-03T07:20:26.452Z] 07:20:26     INFO -  TEST-INFO | started process 4104 (C:\Users\task_1612332554\build\application\firefox\firefox -wait-for-browser -no-deelevate -profile c:\users\task_1612332554\appdata\local\temp\tmproheyz\profile http://127.0.0.1:49903/startup_test/tspaint_test.html)
[task 2021-02-03T07:20:27.480Z] 07:20:27     INFO -  PID 4104 | __start_report356__end_report
[task 2021-02-03T07:20:27.480Z] 07:20:27     INFO -  PID 4104 |
[task 2021-02-03T07:20:27.480Z] 07:20:27     INFO -  PID 4104 | __startTimestamp616.48__endTimestamp
[task 2021-02-03T07:20:27.683Z] 07:20:27     INFO -  PID 4104 | *** UTM:SVC TimerManager:registerTimer called after profile-before-change notification. Ignoring timer registration for id: recipe-client-addon-run
[task 2021-02-03T07:20:27.854Z] 07:20:27     INFO -  TEST-INFO | 4104: exit 0
[task 2021-02-03T07:20:28.107Z] 07:20:28     INFO -  mozcrash checking c:\users\task_1612332554\appdata\local\temp\tmproheyz\profile\minidumps for minidumps...
[task 2021-02-03T07:20:28.107Z] 07:20:28     INFO -  Running cycle 2/20 for ts_paint_webext test...
[task 2021-02-03T07:20:28.110Z] 07:20:28     INFO -  Using env: {'ALLUSERSPROFILE': 'C:\\ProgramData',
[task 2021-02-03T07:20:28.111Z] 07:20:28     INFO -   'APPDATA': 'C:\\Users\\task_1612332554\\AppData\\Roaming',
[task 2021-02-03T07:20:28.111Z] 07:20:28     INFO -   'COMMONPROGRAMFILES': 'C:\\Program Files\\Common Files',
[task 2021-02-03T07:20:28.112Z] 07:20:28     INFO -   'COMMONPROGRAMFILES(X86)': 'C:\\Program Files (x86)\\Common Files',
[task 2021-02-03T07:20:28.112Z] 07:20:28     INFO -   'COMMONPROGRAMW6432': 'C:\\Program Files\\Common Files',
[task 2021-02-03T07:20:28.113Z] 07:20:28     INFO -   'COMPUTERNAME': 'T-W1064-MS-030',
[task 2021-02-03T07:20:28.113Z] 07:20:28     INFO -   'COMSPEC': 'C:\\windows\\system32\\cmd.exe',
[task 2021-02-03T07:20:28.113Z] 07:20:28     INFO -   'DRIVERDATA': 'C:\\Windows\\System32\\Drivers\\DriverData',
[task 2021-02-03T07:20:28.114Z] 07:20:28     INFO -   'EXTRA_MOZHARNESS_CONFIG': '{"installer_url": "https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/QmAkEWJkTn2Fb7mICyqWkA/artifacts/public/build/target.zip", "test_packages_url": "https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/QmAkEWJkTn2Fb7mICyqWkA/artifacts/public/build/target.test_packages.json"}',
[task 2021-02-03T07:20:28.114Z] 07:20:28     INFO -   'GECKO_HEAD_REPOSITORY': 'https://hg.mozilla.org/integration/autoland',
[task 2021-02-03T07:20:28.114Z] 07:20:28     INFO -   'GECKO_HEAD_REV': 'c87d0f32d7a6a33765ecedbc69c6278f235b1c57',
[task 2021-02-03T07:20:28.114Z] 07:20:28     INFO -   'HG_CACHE': 'C:\\tooltool-cache',
[task 2021-02-03T07:20:28.114Z] 07:20:28     INFO -   'HOMEDRIVE': 'C:',
[task 2021-02-03T07:20:28.114Z] 07:20:28     INFO -   'HOMEPATH': '\\Users\\task_1612332554',
...
...
...
[task 2021-02-03T07:20:28.125Z] 07:20:28     INFO -   'WINDIR': 'C:\\windows'}
[task 2021-02-03T07:20:28.125Z] 07:20:28     INFO -  TEST-INFO | started process 10176 (C:\Users\task_1612332554\build\application\firefox\firefox -wait-for-browser -no-deelevate -profile c:\users\task_1612332554\appdata\local\temp\tmproheyz\profile http://127.0.0.1:49903/startup_test/tspaint_test.html)
[task 2021-02-03T07:20:28.638Z] 07:20:28     INFO -  PID 10176 | JavaScript note: moz-extension://2c4a030d-a875-4af5-8148-fcb35b6cf99f/chrome/talos-powers-content.js, line 152: { opened at line 152, column 7
[task 2021-02-03T07:20:33.556Z] 07:20:33     INFO -  PID 10176 | BROWSER FAILED TO GENERATE MOZAFTERPAINT IN 5 SECONDS
[task 2021-02-03T07:20:33.556Z] 07:20:33     INFO -  PID 10176 | __startTimestamp5048.66__endTimestamp
[task 2021-02-03T07:21:11.580Z] 07:21:11     INFO -  Browser shutdown timed out after 20 seconds, killing process.
[task 2021-02-03T07:21:11.580Z] 07:21:11     INFO -  Launcher process psutil.Process(pid=10176L, name='firefox.exe', started='07:20:28') detected. Killing parent process psutil.Process(pid=1480, name='firefox.exe', started='07:20:28') instead.
[task 2021-02-03T07:21:11.580Z] 07:21:11     INFO -  Killing psutil.Process(pid=1480, name='firefox.exe', started='07:20:28') and writing a minidump file
[task 2021-02-03T07:21:11.580Z] 07:21:11     INFO -  mozcrash Writing a dump to c:\users\task_1612332554\appdata\local\temp\tmproheyz\profile\minidumps\5b39d293-6821-4a2e-b275-e4d3782c91e7.dmp for [1480]
[task 2021-02-03T07:21:11.704Z] 07:21:11     INFO -  PID 10176 | Exiting due to channel error.
[task 2021-02-03T07:21:11.704Z] 07:21:11     INFO -  PID 10176 | Exiting due to channel error.
[task 2021-02-03T07:21:11.704Z] 07:21:11     INFO -  PID 10176 | Exiting due to channel error.
[task 2021-02-03T07:21:11.762Z] 07:21:11     INFO -  mozcrash checking c:\users\task_1612332554\appdata\local\temp\tmproheyz\profile\minidumps for minidumps...
[task 2021-02-03T07:21:11.762Z] 07:21:11     INFO -  mozcrash Downloading symbols from: https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/QmAkEWJkTn2Fb7mICyqWkA/artifacts/public/build/target.crashreporter-symbols.zip
[task 2021-02-03T07:21:13.398Z] 07:21:13     INFO -  mozcrash Copy/paste: C:/Users/task_1612332554/fetches\minidump_stackwalk\minidump_stackwalk.exe c:\users\task_1612332554\appdata\local\temp\tmproheyz\profile\minidumps\5b39d293-6821-4a2e-b275-e4d3782c91e7.dmp c:\users\task_1612332554\appdata\local\temp\tmpxyzyfv
[task 2021-02-03T07:21:17.508Z] 07:21:17     INFO -  mozcrash Saved minidump as C:\Users\task_1612332554\build\blobber_upload_dir\5b39d293-6821-4a2e-b275-e4d3782c91e7.dmp
[task 2021-02-03T07:21:17.508Z] 07:21:17     INFO -  PROCESS-CRASH | ts_paint_webext | application crashed [unknown top frame]
[task 2021-02-03T07:21:17.509Z] 07:21:17     INFO -  Crash dump filename: c:\users\task_1612332554\appdata\local\temp\tmproheyz\profile\minidumps\5b39d293-6821-4a2e-b275-e4d3782c91e7.dmp
[task 2021-02-03T07:21:17.509Z] 07:21:17     INFO -  Operating system: Windows NT
[task 2021-02-03T07:21:17.509Z] 07:21:17     INFO -                    10.0.17134
[task 2021-02-03T07:21:17.510Z] 07:21:17     INFO -  CPU: amd64
[task 2021-02-03T07:21:17.510Z] 07:21:17     INFO -       family 6 model 94 stepping 3
[task 2021-02-03T07:21:17.510Z] 07:21:17     INFO -       8 CPUs
[task 2021-02-03T07:21:17.510Z] 07:21:17     INFO -  GPU: UNKNOWN
[task 2021-02-03T07:21:17.511Z] 07:21:17     INFO -  No crash
[task 2021-02-03T07:21:17.511Z] 07:21:17     INFO -  Process uptime: 43 seconds
[task 2021-02-03T07:21:17.511Z] 07:21:17     INFO -  Thread 0
[task 2021-02-03T07:21:17.511Z] 07:21:17     INFO -   0  win32u.dll!NtUserMsgWaitForMultipleObjectsEx + 0x14
[task 2021-02-03T07:21:17.512Z] 07:21:17     INFO -      rax = 0x0000000000001436   rdx = 0x0000000000000000
[task 2021-02-03T07:21:17.512Z] 07:21:17     INFO -      rcx = 0x0000000000000000   rbx = 0x0000000000000000
[task 2021-02-03T07:21:17.512Z] 07:21:17     INFO -      rsi = 0x00000000ffffffff   rdi = 0x00007ffa29a384c0
[task 2021-02-03T07:21:17.512Z] 07:21:17     INFO -      rbp = 0x0000020a56d0a500   rsp = 0x0000005d1fbfe5b8
[task 2021-02-03T07:21:17.512Z] 07:21:17     INFO -       r8 = 0x0000000000000000    r9 = 0x0000000000000000
[task 2021-02-03T07:21:17.513Z] 07:21:17     INFO -      r10 = 0x00000fff3d58c3d0   r11 = 0x0411040000010000
[task 2021-02-03T07:21:17.513Z] 07:21:17     INFO -      r12 = 0x0000005d1fbfe630   r13 = 0x00007ffa29a40b40
[task 2021-02-03T07:21:17.513Z] 07:21:17     INFO -      r14 = 0x0000000000317783   r15 = 0x00007ffa29a40200
[task 2021-02-03T07:21:17.513Z] 07:21:17     INFO -      rip = 0x00007ffa271396e4
[task 2021-02-03T07:21:17.514Z] 07:21:17     INFO -      Found by: given as instruction pointer in context
[task 2021-02-03T07:21:17.514Z] 07:21:17     INFO -   1  user32.dll!guard_dispatch_icall_nop + 0x1593d
[task 2021-02-03T07:21:17.514Z] 07:21:17     INFO -      rbx = 0x0000000000000000   rbp = 0x0000020a56d0a500
[task 2021-02-03T07:21:17.514Z] 07:21:17     INFO -      rsp = 0x0000005d1fbfe5c0   r12 = 0x0000005d1fbfe630
[task 2021-02-03T07:21:17.514Z] 07:21:17     INFO -      r13 = 0x00007ffa29a40b40   r14 = 0x0000000000317783
[task 2021-02-03T07:21:17.515Z] 07:21:17     INFO -      r15 = 0x00007ffa29a40200   rip = 0x00007ffa29a4029d
[task 2021-02-03T07:21:17.515Z] 07:21:17     INFO -      Found by: call frame info
[task 2021-02-03T07:21:17.515Z] 07:21:17     INFO -   2  xul.dll!mozilla::CycleCollectedJSContext::PerformMicroTaskCheckPoint(bool) [CycleCollectedJSContext.cpp:c87d0f32d7a6a33765ecedbc69c6278f235b1c57 : 661 + 0x10]
[task 2021-02-03T07:21:17.515Z] 07:21:17     INFO -      rbp = 0x0000020a56d0a500   rsp = 0x0000005d1fbfe5f0
[task 2021-02-03T07:21:17.515Z] 07:21:17     INFO -      rip = 0x00007ff9e982f60c
[task 2021-02-03T07:21:17.516Z] 07:21:17     INFO -      Found by: stack scanning
[task 2021-02-03T07:21:17.516Z] 07:21:17     INFO -   3  xul.dll!nsThread::ProcessNextEvent(bool, bool*) [nsThread.cpp:c87d0f32d7a6a33765ecedbc69c6278f235b1c57 : 1074 + 0x52]
[task 2021-02-03T07:21:17.516Z] 07:21:17     INFO -      rbp = 0x0000020a56d0a500   rsp = 0x0000005d1fbfe950
[task 2021-02-03T07:21:17.516Z] 07:21:17     INFO -      rip = 0x00007ff9e95a2275
[task 2021-02-03T07:21:17.516Z] 07:21:17     INFO -      Found by: call frame info
[task 2021-02-03T07:21:17.517Z] 07:21:17     INFO -   4  xul.dll!mozilla::ipc::MessagePump::Run(base::MessagePump::Delegate*) [MessagePump.cpp:c87d0f32d7a6a33765ecedbc69c6278f235b1c57 : 109 + 0x29]
[task 2021-02-03T07:21:17.517Z] 07:21:17     INFO -      rbp = 0x0000020a56d0a500   rsp = 0x0000005d1fbfece0
[task 2021-02-03T07:21:17.517Z] 07:21:17     INFO -      rip = 0x00007ff9ea8419f0
[task 2021-02-03T07:21:17.517Z] 07:21:17     INFO -      Found by: call frame info
[task 2021-02-03T07:21:17.517Z] 07:21:17     INFO -   5  xul.dll!MessageLoop::RunHandler() [message_loop.cc:c87d0f32d7a6a33765ecedbc69c6278f235b1c57 : 328 + 0x16]
[task 2021-02-03T07:21:17.517Z] 07:21:17     INFO -      rbp = 0x0000020a56d0a500   rsp = 0x0000005d1fbfed80
[task 2021-02-03T07:21:17.518Z] 07:21:17     INFO -      rip = 0x00007ff9ea817cbf
[task 2021-02-03T07:21:17.518Z] 07:21:17     INFO -      Found by: call frame info
[task 2021-02-03T07:21:17.518Z] 07:21:17     INFO -   6  xul.dll!MessageLoop::Run() [message_loop.cc:c87d0f32d7a6a33765ecedbc69c6278f235b1c57 : 310 + 0x5]
[task 2021-02-03T07:21:17.518Z] 07:21:17     INFO -      rbp = 0x0000020a56d0a500   rsp = 0x0000005d1fbfedd0
[task 2021-02-03T07:21:17.518Z] 07:21:17     INFO -      rip = 0x00007ff9e95a19ae
[task 2021-02-03T07:21:17.518Z] 07:21:17     INFO -      Found by: call frame info
[task 2021-02-03T07:21:17.519Z] 07:21:17     INFO -   7  xul.dll!nsBaseAppShell::Run() [nsBaseAppShell.cpp:c87d0f32d7a6a33765ecedbc69c6278f235b1c57 : 137 + 0xd]
[task 2021-02-03T07:21:17.519Z] 07:21:17     INFO -      rbp = 0x0000020a56d0a500   rsp = 0x0000005d1fbfee30
[task 2021-02-03T07:21:17.519Z] 07:21:17     INFO -      rip = 0x00007ff9e995a8c8
[task 2021-02-03T07:21:17.519Z] 07:21:17     INFO -      Found by: call frame info
[task 2021-02-03T07:21:17.519Z] 07:21:17     INFO -   8  xul.dll!nsAppShell::Run() [nsAppShell.cpp:c87d0f32d7a6a33765ecedbc69c6278f235b1c57 : 602 + 0x8]
[task 2021-02-03T07:21:17.520Z] 07:21:17     INFO -      rbp = 0x0000020a56d0a500   rsp = 0x0000005d1fbfee70
[task 2021-02-03T07:21:17.520Z] 07:21:17     INFO -      rip = 0x00007ff9e995965f
[task 2021-02-03T07:21:17.520Z] 07:21:17     INFO -      Found by: call frame info
[task 2021-02-03T07:21:17.520Z] 07:21:17     INFO -   9  xul.dll!nsAppStartup::Run() [nsAppStartup.cpp:c87d0f32d7a6a33765ecedbc69c6278f235b1c57 : 271 + 0xd]
[task 2021-02-03T07:21:17.521Z] 07:21:17     INFO -      rbp = 0x0000020a56d0a500   rsp = 0x0000005d1fbfefe0
[task 2021-02-03T07:21:17.521Z] 07:21:17     INFO -      rip = 0x00007ff9ed18a61a
[task 2021-02-03T07:21:17.521Z] 07:21:17     INFO -      Found by: call frame info
[task 2021-02-03T07:21:17.521Z] 07:21:17     INFO -  10  xul.dll!XREMain::XRE_mainRun() [nsAppRunner.cpp:c87d0f32d7a6a33765ecedbc69c6278f235b1c57 : 5248 + 0xd]
[task 2021-02-03T07:21:17.521Z] 07:21:17     INFO -      rbp = 0x0000020a56d0a500   rsp = 0x0000005d1fbff030
[task 2021-02-03T07:21:17.521Z] 07:21:17     INFO -      rip = 0x00007ff9ed226fd2
[task 2021-02-03T07:21:17.522Z] 07:21:17     INFO -      Found by: call frame info
[task 2021-02-03T07:21:17.522Z] 07:21:17     INFO -  11  xul.dll!XREMain::XRE_main(int, char**, mozilla::BootstrapConfig const&) [nsAppRunner.cpp:c87d0f32d7a6a33765ecedbc69c6278f235b1c57 : 5440 + 0x8]
[task 2021-02-03T07:21:17.522Z] 07:21:17     INFO -      rbp = 0x0000020a56d0a500   rsp = 0x0000005d1fbff370
[task 2021-02-03T07:21:17.522Z] 07:21:17     INFO -      rip = 0x00007ff9ed22854a
[task 2021-02-03T07:21:17.522Z] 07:21:17     INFO -      Found by: call frame info
[task 2021-02-03T07:21:17.522Z] 07:21:17     INFO -  12  xul.dll!XRE_main(int, char**, mozilla::BootstrapConfig const&) [nsAppRunner.cpp:c87d0f32d7a6a33765ecedbc69c6278f235b1c57 : 5503 + 0x10]
[task 2021-02-03T07:21:17.523Z] 07:21:17     INFO -      rbp = 0x0000020a56d0a500   rsp = 0x0000005d1fbff440
[task 2021-02-03T07:21:17.523Z] 07:21:17     INFO -      rip = 0x00007ff9e9563f53
[task 2021-02-03T07:21:17.523Z] 07:21:17     INFO -      Found by: call frame info
[task 2021-02-03T07:21:17.523Z] 07:21:17     INFO -  13  firefox.exe!wmain(int, wchar_t**) [nsWindowsWMain.cpp:c87d0f32d7a6a33765ecedbc69c6278f235b1c57 : 138 + 0x1da]
[task 2021-02-03T07:21:17.523Z] 07:21:17     INFO -      rbp = 0x0000020a56d0a500   rsp = 0x0000005d1fbff5a0
[task 2021-02-03T07:21:17.524Z] 07:21:17     INFO -      rip = 0x00007ff7fe721594
[task 2021-02-03T07:21:17.524Z] 07:21:17     INFO -      Found by: call frame info
[task 2021-02-03T07:21:17.524Z] 07:21:17     INFO -  14  firefox.exe!__scrt_common_main_seh() [exe_common.inl : 288 + 0x22]
[task 2021-02-03T07:21:17.524Z] 07:21:17     INFO -      rbp = 0x0000020a56d0a500   rsp = 0x0000005d1fbff7c0
[task 2021-02-03T07:21:17.524Z] 07:21:17     INFO -      rip = 0x00007ff7fe76e8f8
[task 2021-02-03T07:21:17.525Z] 07:21:17     INFO -      Found by: call frame info
[task 2021-02-03T07:21:17.525Z] 07:21:17     INFO -  15  kernel32.dll!guard_dispatch_icall_nop + 0x86d4
[task 2021-02-03T07:21:17.525Z] 07:21:17     INFO -      rbp = 0x0000020a56d0a500   rsp = 0x0000005d1fbff800
[task 2021-02-03T07:21:17.525Z] 07:21:17     INFO -      rip = 0x00007ffa27793034
[task 2021-02-03T07:21:17.525Z] 07:21:17     INFO -      Found by: call frame info
[task 2021-02-03T07:21:17.526Z] 07:21:17     INFO -  16  ntdll.dll!guard_dispatch_icall_nop + 0x66b01
[task 2021-02-03T07:21:17.526Z] 07:21:17     INFO -      rbp = 0x0000020a56d0a500   rsp = 0x0000005d1fbff830
[task 2021-02-03T07:21:17.526Z] 07:21:17     INFO -      rip = 0x00007ffa2a141461
[task 2021-02-03T07:21:17.526Z] 07:21:17     INFO -      Found by: stack scanning
Status: NEW → ASSIGNED
Whiteboard: [2/4] patches bounced, Nika working on the fix

The baseURI is a moz-extension: URI, which does not support being loaded
synchronously from a content process, as framescripts are.

This patch does not attempt to prohibit future synchronous uses of
moz-extension: URIs, as that is outside of the scope of this issue, but we
should likely do so in a follow-up.

Pushed by nlayzell@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2705d8f1a121
Part 1: Add a test for reloading a page with a large postdata payload, r=peterv
https://hg.mozilla.org/integration/autoland/rev/401d2bddc67d
Part 2: Use an overload set instead of template for RemoteLazyInputStreamParent::Create, r=baku
https://hg.mozilla.org/integration/autoland/rev/ebad88c5a2ed
Part 3: Apply InputStreamLengthWrapper after DelayedStartInputStream, r=baku
https://hg.mozilla.org/integration/autoland/rev/9dd84b89520e
Part 4: Serialize aDelayedStart streams from parent to child as RemoteLazyInputStreams, r=baku
https://hg.mozilla.org/integration/autoland/rev/1fcb10027e8e
Part 5: Serialize `nsIInputStream` over IPC with aDelayedStart by default, r=baku
https://hg.mozilla.org/integration/autoland/rev/20af3995d4f2
Part 6: Introduce a SeekableStreamWrapper to make pipes seekable, r=baku
https://hg.mozilla.org/integration/autoland/rev/558b963aa59c
Part 7: Wrap the inner streams in a nsMIMEInputStream to make them seekable, r=baku,necko-reviewers,dragana
https://hg.mozilla.org/integration/autoland/rev/417f0a2e055f
Part 8: Handle clones of closed nsPipeInputStreams, r=baku
https://hg.mozilla.org/integration/autoland/rev/1692dbe44c82
Part 9: Add a basic test for the seekable stream wrapper, r=baku
https://hg.mozilla.org/integration/autoland/rev/8bae068eea9d
Part 10: Set StartedReading after calling SetData, r=baku,necko-reviewers,valentin
https://hg.mozilla.org/integration/autoland/rev/c38587dbe583
Part 11: Avoid using DelayedStart when serialzing the reply from SendOpenStream, r=asuth
https://hg.mozilla.org/integration/autoland/rev/1ec45093bcfe
Part 12: Use rootURI for talos-powers frame script instead of baseURI, r=kmag,perftest-reviewers
Flags: needinfo?(nika)
Whiteboard: [2/4] patches bounced, Nika working on the fix → [2/5] patches re-pushed
You need to log in before you can comment on or make changes to this bug.