Have a link to all the bugs assigned to the bug owner when bug status is ASSIGNED

RESOLVED WONTFIX

Status

()

Bugzilla
Query/Bug List
--
enhancement
RESOLVED WONTFIX
16 years ago
11 years ago

People

(Reporter: Stephen Ostermiller, Assigned: Nobody's working on this, feel free to take it)

Tracking

Details

(Reporter)

Description

16 years ago
The best way to know how soon a bug is going to be fixed is to look at all the
bugs assigned to the developer that has accepted the bug and see where it is on
their priority list.  I like to think of this as a link to the developer's workload.

Such a link would be be informative and provide access to information that is
obtainable, but for which currently you have to do a time consuming search. 
Once click access is desireable.

In my bugzilla installation I added the link to the edit.html.tmpl in
template/en/default/bug/  I changed the 
"Leave as ASSIGNED" 
option to 
"Leave as ASSIGNED to developer@domain.tld (Joe Developer) [view workload]"
where view workload is a link to buglist.cgi showing all bugs assigned to Joe.

Here is the new code in template/ne/default/bug/edit.html.tmpl
  <input type="radio" name="knob" value="none" checked="checked">
  Leave as <b>[% bug.bug_status FILTER html %]&nbsp;
              [% bug.resolution FILTER html %]</b>
  [% IF bug.bug_status == "ASSIGNED" %]
   to [% bug.assigned_to FILTER html %] [<a
href="buglist.cgi?bug_status=UNCONFIRMED&bug_status=NEW&bug_status=ASSIGNED&bug_status=REOPENED&emailassigned_to1=1&emailtype1=exact&email1=[%
bug.assigned_to_email FILTER uri FILTER html %]">view workload</a>]
  [% END %]

I have filtered all untrusted data that is written to the page.
(Reporter)

Comment 1

16 years ago
FILTER uri FILTER html
in the above should be changed to:
FILTER url_quote

Updated

15 years ago
Hardware: PC → All
Assignee: endico → nobody

Updated

12 years ago
QA Contact: mattyt-bugzilla → default-qa

Comment 2

11 years ago
Since Bugzilla 3.2, ASSIGNED is no longer a hardcoded bug status. So implementing a feature which depends on something customizable doesn't make sense. This would make ASSIGNED a special bug status, which we want to avoid.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.