Not all names are displayed as I type

RESOLVED WORKSFORME

Status

SeaMonkey
MailNews: Address Book & Contacts
RESOLVED WORKSFORME
16 years ago
13 years ago

People

(Reporter: Brandon Corfman, Assigned: racham)

Tracking

Trunk
x86
Windows ME

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
There are several cases where I'm typing and the name completion for the address
book doesn't work correctly during a Compose.

Maybe this is a feature, but if there are quote marks around a name in the
address book, then I have to type quote marks before it will complete the name
as well. This is a bug as far as I'm concerned. 

For instance, if I have the name "Brandon Corfman" in the address book, then
typing Brandon Corfman in the 'To:' box should complete the name anyway. Quote
marks should be ignored when resolving a name.

Comment 1

16 years ago
Reporter:
Which build for mozilla are you using?
Which address book are these in - Personal, Collected, an LDAP one?
Is this just in the autocomplete box or also if you click on the address button
and get addresses that way?
Has it worked before or has it always been this way?
(Reporter)

Comment 2

16 years ago
Build: Mozilla 1.1
Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.1) Gecko/20020826

It's happening with the Collected Addresses, not the Personal ones (since there
are no quotes in the personal ones I guess).

It's always been this way. I guess I just assumed someone else would notice.

It doesn't happen in the Address book itself, just in Autocomplete.

An example -- I have three of my own address in the Collected Address as
"BRANDON C CORFMAN"   bcorfman@amsaa.army.mil
Brandon Corfman   bcorfm1@gl.umbc.edu
Brandon Corfman   bcorfman@arl.mil

Only the last two show up when I'm typing my name in Autocomplete.
Product: Browser → Seamonkey

Comment 3

13 years ago
wow, mozilla 1.1, anything new here ?
(Reporter)

Updated

13 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---
The reporter marked this as resolved/fixed though we don't know when it was 
fixed. Marking as resolved/worksforme as this is more appropriate in this 
instance.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.