Cannot move mail from Subfolder of (IMAP-)INBOX to my Local Folders

CLOSED FIXED

Status

--
major
CLOSED FIXED
16 years ago
10 years ago

People

(Reporter: Tino.Lange, Assigned: Bienvenu)

Tracking

({imap-interop})

Trunk
x86
Linux
imap-interop

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
Hi!

I have just changed from Netscape 4.8 to Mozilla 1.1 (Linux-2.4.19) and found
the following Bug in the Mail-Client part of the software:

I cannot move a couple of mails from a subfolder of my IMAP INBOX (Cyrus Server)
to a folder in my Local Folders. It's possible to move/copy them "mail by mail",
i. e. just only one mail per step. But if I select more than one mail or even
all to be moved/copied just *nothing* happens.

This problem only occurs moving from IMAP *sub*folders of my INBOX, if I move
directly from the INBOX itself, then it works.
But I have server mail-filtering rules on the Cyrus-Server and hence lots of
mails arrive in subfolders of the IMAP INBOX, not in the INBOX.

This is quite a severe problem for me, that's why I gave it severity "major"
above, not only "normal". OK?
Could you please look at it and try to fix at as soon as possible?

If you have more questions or if you need screenshots or more details, please
let me know.
 
Thanks a lot!
BR

Tino Lange

Comment 1

16 years ago
20020912 trunk build on Windows NT

The same problem happened to me.
Assignee: mscott → bienvenu

Updated

16 years ago
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Keywords: interop

Comment 2

16 years ago
I have also observed this problem in Mozilla 1.1 and Netscape 7.0 under Windows
XP, Windows 2000, and Windows NT 4.0.  Note that the problem did not exist with
Mozilla 0.99.

Comment 3

16 years ago
*** Bug 168494 has been marked as a duplicate of this bug. ***

Comment 4

16 years ago
I see something similar with 1.1 and 1.2b since our imap server switched and
all imap folders are subfolders of Inbox: when I try to select multiple 
messages from a subfolder and file them to a local folder, the local folder takes 
on a large value as the size (somthing like -1 converted to 32bit unsigned) but 
with zero contents, and the .msf file disappears.  I then have to manually
remove the local folder and restart mozilla.  This is on Linux RedHat 7.0.
(Assignee)

Comment 5

16 years ago
I will look at this this weekend, and I hope, fix it.
(Assignee)

Comment 6

16 years ago
well, duh, this doesn't work for any imap server - in other words, copying
multiple imap msgs to a local folder seems to be broken. So, as near as I can
tell, it doesn't have anything to do with hierarchy delimiters. I'll investigate.
(Assignee)

Comment 7

16 years ago
ah, never mind - I made a change to attempt to fix this, and it broke it for all
imap servers :-) I think the correct fix is to fix
CreateCanonicalSourceFolderPathString to return the canonical path, and fix the
two places that expect the server path to use CreateServerSourceFolderPathString.
(Assignee)

Comment 8

16 years ago
Created attachment 105842 [details] [diff] [review]
proposed fix

OK, I went with the simpler fix - just make GetURI return the canonical format
uri, like it should.
(Assignee)

Comment 9

16 years ago
Cavin, can I get an r=? thx.
Comment on attachment 105842 [details] [diff] [review]
proposed fix

sr=sspitzer
Attachment #105842 - Flags: superreview+

Comment 11

16 years ago
Comment on attachment 105842 [details] [diff] [review]
proposed fix

r=cavin.
Attachment #105842 - Flags: review+
(Assignee)

Comment 12

16 years ago
fix checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
(Reporter)

Comment 13

16 years ago
Just downloaded the nightly build and - fantastic - it's solved!
Thanks a lot!

By the way: 1.3a  looks really good! I'm looking forward to it!

Best regards

Tino
Status: RESOLVED → CLOSED

Comment 14

16 years ago
*** Bug 182310 has been marked as a duplicate of this bug. ***
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.