Closed Bug 1682277 Opened 9 months ago Closed 9 months ago

[Experiment] Users enrolled in the Remote Settings Top Sites experiments using locales other than en-US, en-GB and DE will have incomplete functionality of the experiment

Categories

(Firefox :: Search, defect)

Desktop
All
defect

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox83 --- affected
firefox84 --- affected

People

(Reporter: mheres, Unassigned)

References

Details

Attachments

(1 file)

[Notes]:

  • The experiment filters allow all locales to be enrolled, but browser.search.experiment seems to be dependent on locale.

[Affected versions]:

  • Firefox Beta 84.0 (Build ID: 20201211215739)

[Affected Platforms]:

  • Windows 10
  • macOS 10.15 TBD
  • Linux Mint 20 TBD

[Prerequisites]:

  • Use a locale other than en-US, en-GB or DE (e.g. JA)
  • Have the following preferences set:
    • browser.search.region set to DE.
    • browser.search.experiment set to amazon-de-adm.
    • browser.topsites.experiment.ebay-2020-1 set to true.
    • browser.partnerlink.useAttributionURL set to true.
    • browser.topsites.useRemoteSetting set to true.

[Steps to reproduce]:

  1. Focus the Awesomebar and type "@amazon "
  2. Enter a string and press the Enter key.
  3. Observe the URL of the page you are directed at.

[Expected result]:

[Actual result]:

[Notes]:

  • The issue is also reproducible for the en-US and en-GB versions of the experiment.
  • The issue is not reproducible for the Top Site links.
  • Attached is a recording of the issue.
No longer blocks: 1653929
Component: Top Sites → Search

This is to do with the way the experiments were initially defined. At the moment we're not going to change that, but we will bear it in mind for next year when there are likely to be more experiments for this.

Status: NEW → RESOLVED
Closed: 9 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.