Closed Bug 1682842 Opened 4 years ago Closed 2 months ago

Tab (%) search does not work in Private Mode

Categories

(Firefox :: Address Bar, defect, P3)

Firefox 84
defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: aemanuelalazaj4, Unassigned)

References

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:78.0) Gecko/20100101 Firefox/78.0

Steps to reproduce:

I use % to search between active tabs when private browsing.

Actual results:

I hit the "%" and can't find any results, unlike the bookmark search.

Expected results:

The desired result is being able to search between my currently open tabs.

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: Untriaged → Bookmarks & History
Component: Bookmarks & History → Address Bar

Looks like this is intentional. See bug 1075450 comment 0 and the code here. Marco, do you remember why we hide tab results in private windows?

Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(mak)

Even if we don't end up showing tab results in private windows, we should consider hiding the tabs one-off in PBM if it doesn't work.

Severity: -- → S3
Priority: -- → P2
See Also: → 1681697

The first thing that comes to my mind is that we should not allow to switch to non-private tabs from private windows, and vice versa.
Some discussion about the original reasoning is in bug 816527, Ehsan correctly said we should not confuse users by moving them through windows of different state. Like from private to non-private or from non-private to private. That would create false assumptions.
Off-hand, I think if we'd not cross the boundary, the problem would not exist and we could provide switch to tab in private windows, you could only switch to other private tabs.
There is also permanent private browsing to consider, but technically all of this should be feasible.

Flags: needinfo?(mak)

I don't think this is critical, as well as hiding the tab button. We should just fix this when we have the time.

Bug 1681697 on the other side should be fixed sooner because it's wrong in any case.

Priority: P2 → P3

I think this is now fixed, in a PB window it should be possible to switch to other PB tabs.

Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.