Closed Bug 1682880 Opened 3 years ago Closed 3 years ago

Unsaved passwords need to be retyped frequently


(Thunderbird :: Security, defect)



(Not tracked)



(Reporter: phil, Unassigned)


(Whiteboard: [support])

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:83.0) Gecko/20100101 Firefox/83.0

Steps to reproduce:

I have an email account for which I do not save my password in Thunderbird. Instead, each time Thunderbird starts, I type this password. Until fairly recently, typing the password once each time Thunderbird started was all that was required, as Thunderbird apparently hung onto my password until it was closed and restarted (at which point I had to re-enter my password again).

After a recent update (and I've tried a few more updates since then), Thunderbird seems to forget my password after 10-15 minutes. Or, if I click on a sub-folder, I'm often asked to re-enter the password. Or, if I step away from my computer and upon returning click on "Get Messages," or a different folder, I'm prompted for my password again. BTW, in the past I would have never had to click on "Get Messages," as Thunderbird would be checking my IMAP server throughout the day, but after this timeout I notice that mail I was expecting hasn't shown up, and I think it is because of this password issue.

Actual results:

I think when the new encryption methods were put in place, Thunderbird lost the ability to keep a password in memory for any period of time. I do not know if this is by-design.

Expected results:

I'd hope Thunderbird could keep a password I key-in until such a time as Thunderbird is closed. But again, this may be by-design and a "feature" that is no longer possible.

Frankly sounds like a server issue

Component: Untriaged → Security
Whiteboard: [support]

I'm going to second this as a possible server issue. I just today wiped out all the PWs from by TB (had to do an Enterprise-wide PW change and noticed a ton of cruft in my Saved Password area) and it is not presently re-prompting me for PW. Under Tools > Options > Passwords, do you have checked on the option for Use A Primary Password? You should only need to be prompted twice, at most, for one account: once when you send and once when you receive.

How about the items in Saved Passwords? Do you have a lot there and maybe some with some old dates as it relates to the account which is giving you issues?

It isn't a server issue, as I run Thunderbird on three different machines. The basement machine is where I noticed this first, it had updated, and I purposely delayed allowing the other two machines (notebook and office) an opportunity to update.

So while the problem was being exhibited on the basement machine, the notebook and office machines were working with older versions and the expected behavior (not having to re-key the password all the time).

This went on for a couple of weeks, and then I updated the other two machines because I needed to add the LookOut add-on so I could view attachments sent via misconfigured copies of Outlook.

Arthur, I previously only did have to enter the password twice, the first time on startup and the 2nd time for sending email. But now if I don't allow Thunderbird to save that password and leave my machine unattended for a little while, on return I have to re-enter the password to view new messages or change folders, and if I send another message, I have to enter the password again.

In fact, I believe that if I start Thunderbird I have to enter the password, but then if I try to click into Sent items, I have to enter it again immediately.

re :Under Tools > Options > Passwords, do you have checked on the option for Use A Primary Password?

Just for reference, this query is asking if you have set a 'Master Password' or not. The 'Master Password' acts like a 'Master key' to unlock the viewing of all saved account passwords.

As you do not use the Password Manager to save passwords in Thunderbird, there would be no use for a Master Password.

It sounds like this is a duplicate of bug 1673446

Closed: 3 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.