Open Bug 1682955 Opened 2 years ago Updated 7 days ago

Intermittent SUMMARY: ThreadSanitizer: data race /builds/worker/checkouts/gecko/storage/mozStorageConnection.h:239:42 in connectionReady

Categories

(Toolkit :: Storage, defect, P5)

defect

Tracking

()

REOPENED

People

(Reporter: intermittent-bug-filer, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: intermittent-failure)

Filed by: ncsoregi [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer?job_id=324738801&repo=autoland
Full log: https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/Gq9V29__RniSdipJkvYsDg/runs/0/artifacts/public/logs/live_backing.log


[task 2020-12-16T19:37:15.285Z] 19:37:15     INFO - GECKO(2668) |   Thread T37 'IndexedDB #2' (tid=2728, running) created by thread T20 at:
[task 2020-12-16T19:37:15.285Z] 19:37:15     INFO - GECKO(2668) |     #0 pthread_create /builds/worker/fetches/llvm-project/llvm/projects/compiler-rt/lib/tsan/rtl/tsan_interceptors_posix.cpp:966:3 (firefox+0x5668b)
[task 2020-12-16T19:37:15.286Z] 19:37:15     INFO - GECKO(2668) |     #1 _PR_CreateThread /builds/worker/checkouts/gecko/nsprpub/pr/src/pthreads/ptthread.c:458:14 (libnspr4.so+0x3c203)
[task 2020-12-16T19:37:15.286Z] 19:37:15     INFO - GECKO(2668) |     #2 PR_CreateThread /builds/worker/checkouts/gecko/nsprpub/pr/src/pthreads/ptthread.c:533:12 (libnspr4.so+0x30b52)
[task 2020-12-16T19:37:15.286Z] 19:37:15     INFO - GECKO(2668) |     #3 nsThread::Init(nsTSubstring<char> const&) /builds/worker/checkouts/gecko/xpcom/threads/nsThread.cpp:658:8 (libxul.so+0xb85bbf)
[task 2020-12-16T19:37:15.287Z] 19:37:15     INFO - GECKO(2668) |     #4 nsThreadManager::NewNamedThread(nsTSubstring<char> const&, unsigned int, nsIThread**) /builds/worker/checkouts/gecko/xpcom/threads/nsThreadManager.cpp:641:12 (libxul.so+0xb8d0da)
[task 2020-12-16T19:37:15.287Z] 19:37:15     INFO - GECKO(2668) |     #5 NS_NewNamedThread(nsTSubstring<char> const&, nsIThread**, already_AddRefed<nsIRunnable>, unsigned int) /builds/worker/checkouts/gecko/xpcom/threads/nsThreadUtils.cpp:169:57 (libxul.so+0xb94507)
[task 2020-12-16T19:37:15.287Z] 19:37:15     INFO - GECKO(2668) |     #6 NS_NewNamedThread(nsTSubstring<char> const&, nsIThread**, nsIRunnable*, unsigned int) /builds/worker/checkouts/gecko/xpcom/threads/nsThreadUtils.cpp:160:10 (libxul.so+0xb8fa63)
[task 2020-12-16T19:37:15.288Z] 19:37:15     INFO - GECKO(2668) |     #7 mozilla::dom::indexedDB::(anonymous namespace)::ConnectionPool::ScheduleTransaction(mozilla::dom::indexedDB::(anonymous namespace)::ConnectionPool::TransactionInfo&, bool) /builds/worker/checkouts/gecko/dom/indexedDB/ActorsParent.cpp:8572:23 (libxul.so+0x44a0f14)
[task 2020-12-16T19:37:15.288Z] 19:37:15     INFO - GECKO(2668) |     #8 Start /builds/worker/checkouts/gecko/dom/indexedDB/ActorsParent.cpp:8270:15 (libxul.so+0x44a6367)
[task 2020-12-16T19:37:15.288Z] 19:37:15     INFO - GECKO(2668) |     #9 mozilla::dom::indexedDB::(anonymous namespace)::TransactionDatabaseOperationBase::StartOnConnectionPool(nsID const&, nsTSubstring<char> const&, long, nsTArray<nsTString<char16_t> > const&, bool) /builds/worker/checkouts/gecko/dom/indexedDB/ActorsParent.cpp:17797:27 (libxul.so+0x44a6367)
[task 2020-12-16T19:37:15.288Z] 19:37:15     INFO - GECKO(2668) |     #10 mozilla::dom::indexedDB::(anonymous namespace)::OpenDatabaseOp::DispatchToWorkThread() /builds/worker/checkouts/gecko/dom/indexedDB/ActorsParent.cpp:16915:45 (libxul.so+0x448fd28)
[task 2020-12-16T19:37:15.289Z] 19:37:15     INFO - GECKO(2668) |     #11 mozilla::dom::indexedDB::(anonymous namespace)::FactoryOp::Run() /builds/worker/checkouts/gecko/dom/indexedDB/ActorsParent.cpp:16159:7 (libxul.so+0x448a90c)
[task 2020-12-16T19:37:15.289Z] 19:37:15     INFO - GECKO(2668) |     #12 CallCallback /builds/worker/checkouts/gecko/dom/indexedDB/ActorsParent.cpp:9705:13 (libxul.so+0x449de91)
[task 2020-12-16T19:37:15.290Z] 19:37:15     INFO - GECKO(2668) |     #13 mozilla::dom::indexedDB::(anonymous namespace)::WaitForTransactionsHelper::MaybeWaitForFileHandles() /builds/worker/checkouts/gecko/dom/indexedDB/ActorsParent.cpp:9694:3 (libxul.so+0x449de91)
[task 2020-12-16T19:37:15.290Z] 19:37:15     INFO - GECKO(2668) |     #14 mozilla::dom::indexedDB::(anonymous namespace)::WaitForTransactionsHelper::Run() /builds/worker/fetches/clang/bin/../lib/gcc/x86_64-unknown-linux-gnu/7.4.0/../../../../include/c++/7.4.0/bits/atomic_base.h (libxul.so+0x449d7d7)
[task 2020-12-16T19:37:15.290Z] 19:37:15     INFO - GECKO(2668) |     #15 WaitForDatabasesToComplete /builds/worker/checkouts/gecko/dom/indexedDB/ActorsParent.cpp:8350:26 (libxul.so+0x449d940)
[task 2020-12-16T19:37:15.292Z] 19:37:15     INFO - GECKO(2668) |     #16 MaybeWaitForTransactions /builds/worker/checkouts/gecko/dom/indexedDB/ActorsParent.cpp:9671:21 (libxul.so+0x449d940)
[task 2020-12-16T19:37:15.292Z] 19:37:15     INFO - GECKO(2668) |     #17 mozilla::dom::indexedDB::(anonymous namespace)::WaitForTransactionsHelper::Run() /builds/worker/checkouts/gecko/dom/indexedDB/ActorsParent.cpp:9717:7 (libxul.so+0x449d940)
[task 2020-12-16T19:37:15.292Z] 19:37:15     INFO - GECKO(2668) |     #18 WaitForTransactions /builds/worker/checkouts/gecko/dom/indexedDB/ActorsParent.cpp:9660:19 (libxul.so+0x448f7b1)
[task 2020-12-16T19:37:15.292Z] 19:37:15     INFO - GECKO(2668) |     #19 WaitForTransactions /builds/worker/checkouts/gecko/dom/indexedDB/ActorsParent.cpp:15797:11 (libxul.so+0x448f7b1)
[task 2020-12-16T19:37:15.293Z] 19:37:15     INFO - GECKO(2668) |     #20 mozilla::dom::indexedDB::(anonymous namespace)::OpenDatabaseOp::BeginVersionChange() /builds/worker/checkouts/gecko/dom/indexedDB/ActorsParent.cpp:16853:5 (libxul.so+0x448f7b1)
[task 2020-12-16T19:37:15.293Z] 19:37:15     INFO - GECKO(2668) |     #21 mozilla::dom::indexedDB::(anonymous namespace)::FactoryOp::Run() /builds/worker/checkouts/gecko/dom/indexedDB/ActorsParent.cpp:16155:7 (libxul.so+0x448a819)
[task 2020-12-16T19:37:15.294Z] 19:37:15     INFO - GECKO(2668) |     #22 nsThread::ProcessNextEvent(bool, bool*) /builds/worker/checkouts/gecko/xpcom/threads/nsThread.cpp:1200:14 (libxul.so+0xb8821c)
[task 2020-12-16T19:37:15.295Z] 19:37:15     INFO - GECKO(2668) |     #23 NS_ProcessNextEvent(nsIThread*, bool) /builds/worker/checkouts/gecko/xpcom/threads/nsThreadUtils.cpp:548:10 (libxul.so+0xb8dcd2)
[task 2020-12-16T19:37:15.295Z] 19:37:15     INFO - GECKO(2668) |     #24 mozilla::ipc::MessagePumpForNonMainThreads::Run(base::MessagePump::Delegate*) /builds/worker/checkouts/gecko/ipc/glue/MessagePump.cpp:332:5 (libxul.so+0x14841e8)
[task 2020-12-16T19:37:15.295Z] 19:37:15     INFO - GECKO(2668) |     #25 RunInternal /builds/worker/checkouts/gecko/ipc/chromium/src/base/message_loop.cc:334:10 (libxul.so+0x140ec1c)
[task 2020-12-16T19:37:15.295Z] 19:37:15     INFO - GECKO(2668) |     #26 RunHandler /builds/worker/checkouts/gecko/ipc/chromium/src/base/message_loop.cc:327:3 (libxul.so+0x140ec1c)
[task 2020-12-16T19:37:15.295Z] 19:37:15     INFO - GECKO(2668) |     #27 MessageLoop::Run() /builds/worker/checkouts/gecko/ipc/chromium/src/base/message_loop.cc:309:3 (libxul.so+0x140ec1c)
[task 2020-12-16T19:37:15.296Z] 19:37:15     INFO - GECKO(2668) |     #28 nsThread::ThreadFunc(void*) /builds/worker/checkouts/gecko/xpcom/threads/nsThread.cpp:441:10 (libxul.so+0xb84670)
[task 2020-12-16T19:37:15.297Z] 19:37:15     INFO - GECKO(2668) |     #29 _pt_root /builds/worker/checkouts/gecko/nsprpub/pr/src/pthreads/ptthread.c:201:5 (libnspr4.so+0x4500b)
[task 2020-12-16T19:37:15.297Z] 19:37:15     INFO - GECKO(2668) | SUMMARY: ThreadSanitizer: data race /builds/worker/checkouts/gecko/storage/mozStorageConnection.h:239:42 in connectionReady
[task 2020-12-16T19:37:15.298Z] 19:37:15     INFO - GECKO(2668) | ==================
[task 2020-12-16T19:37:15.298Z] 19:37:15     INFO - GECKO(2668) | Crash Annotation GraphicsCriticalError: |[C0][GFX1-]: Receive IPC close with reason=AbnormalShutdown (t=2.9137) [GFX1-]: Receive IPC close with reason=AbnormalShutdown```

This is part of the family of problems caused by the connection list and minimizeMemory, see https://bugzilla.mozilla.org/show_bug.cgi?id=1615725#c15 and discussion

See Also: → 1615725
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → INCOMPLETE
Status: RESOLVED → REOPENED
Resolution: INCOMPLETE → ---
You need to log in before you can comment on or make changes to this bug.