Closed Bug 1683018 Opened 2 years ago Closed 2 years ago

Recognize reader view mode URLs vs standard URLs for bookmarking and bookmark detection

Categories

(Toolkit :: Reader Mode, defect)

Firefox 84
defect

Tracking

()

RESOLVED DUPLICATE of bug 1185918

People

(Reporter: nekohayo, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:83.0) Gecko/20100101 Firefox/83.0

Steps to reproduce:

  1. Bookmark a page, notice the bookmark "star" is now filled blue in the address bar
  2. Ctrl+alt+R to enter "Reader mode"

Actual results:

The star is not filled/blue anymore

Expected results:

  1. It should remain blue to indicate that the page was already bookmarked. Very often, I leave pages in reader view mode and come back to that tab much later, and unless I exit reader view mode I can never know if I had already bookmarked that page... which leads me to the second related problem:

  2. Bookmarking a page from within the reader view mode should bookmark the non-reader view URL of that page, not the internal reader URI.

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: Untriaged → Reader Mode
Product: Firefox → Toolkit
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1185918

Thanks for your bug report. I've closed this as a duplicate of bug 1185918. I agree that we should fix this and I hope someone will have time to contribute a fix soon.

You need to log in before you can comment on or make changes to this bug.