Closed Bug 1683615 Opened 6 months ago Closed 6 months ago

about:logins - in-page focus jumps on the meatbal menu when navigating by keyboard

Categories

(Firefox :: about:logins, defect, P2)

defect

Tracking

()

VERIFIED FIXED
86 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox84 --- unaffected
firefox85 --- unaffected
firefox86 --- verified

People

(Reporter: cfogel, Assigned: dlee)

References

(Regression)

Details

(Keywords: regression)

Attachments

(2 files)

Affected versions

  • 86.0a1 (2020-12-20), 85.0b4

Affected platforms

  • macOS 10.15, Ubuntu 18, Windows 10;

Steps to reproduce

  1. Launch Firefox, access about:logins have some accounts saved(even dummy ones);
  2. Press the TAB key to select the Name(A-Z)
  3. Press the Down Arrow key;

Expected result

  • Name(a-z) menu is open;

Actual result

  • menu for ... (Open Menu / top-right) is open;

Regression range

  • First bad: 2020-12-17;
  • Last good: 2020-12-16;
  • Pushlog: URL;
  • Potential regressor: bug 1681322;

Additional notes

  • 84.0, and latest ESR builds are unaffected;
  • same issue for having the Create New login button or logins area in focus; same for in-logins search;
  • attached recording to best illustrate the issue;
  • set S3 as severity, due to the use scenarios.
Has Regression Range: --- → yes
Has STR: --- → yes
Assignee: nobody → dlee
Status: NEW → ASSIGNED
Priority: -- → P2
Pushed by dlee@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/916213053e1c
about:login metaball menu should not handle key down/up event when it is hidden r=sfoster
Status: ASSIGNED → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → 86 Branch

The patch landed in nightly and beta is affected.
:dimi, is this bug important enough to require an uplift?
If not please set status_beta to wontfix.

For more information, please visit auto_nag documentation.

Flags: needinfo?(dlee)

Verified with 86.0a1 (2021-01-10).

Comment on attachment 9194380 [details]
Bug 1683615 - about:login metaball menu should not handle key down/up event when it is hidden

Beta/Release Uplift Approval Request

  • User impact if declined: Users cannot use keyboard to select sorting method in about:login
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: Follow the "steps to reproduce" in the description
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Not risky. This patch doesn't introduce any new behavior, it reverts the code that was mistakenly removed in Bug 1681322
  • String changes made/needed: None
Flags: needinfo?(dlee)
Attachment #9194380 - Flags: approval-mozilla-beta?
Flags: qe-verify+

Comment on attachment 9194380 [details]
Bug 1683615 - about:login metaball menu should not handle key down/up event when it is hidden

approved for 85.0b8

Attachment #9194380 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Comment on attachment 9194380 [details]
Bug 1683615 - about:login metaball menu should not handle key down/up event when it is hidden

I'm confused now.

Comment 0 points at a regression range that does not affect 85, since Dec 16 is after the central bump to 86.

In addition, grafting the change in this bug to beta hits conflicts with bug 1678616 / bug 1681322 which touched the same area and tests during 86 nightly.

Flags: needinfo?(dlee)
Flags: needinfo?(cristian.fogel)
Attachment #9194380 - Flags: approval-mozilla-beta+ → approval-mozilla-beta?

(In reply to Julien Cristau [:jcristau] from comment #8)

Comment 0 points at a regression range that does not affect 85, since Dec 16 is after the central bump to 86.

In addition, grafting the change in this bug to beta hits conflicts with bug 1678616 / bug 1681322 which touched the same area and tests during 86 nightly.

you are right, the bug that causes this regression should not affect 85, we don't have to uplift this one.
fogel, can you help double check whether this bug happens in 85? thanks!

Flags: needinfo?(dlee)
QA Whiteboard: [qa-triaged]

Indeed, there is no longer a need for it to be uplifted.
Verified with 85.0b8 and it's working as expected, updating the flags accordingly.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
Flags: needinfo?(cristian.fogel)
Attachment #9194380 - Flags: approval-mozilla-beta? → approval-mozilla-beta-
You need to log in before you can comment on or make changes to this bug.