Closed Bug 1683623 Opened 3 years ago Closed 3 years ago

Rename FunctionIndex to ScriptIndex, and use ScriptIndex instead of ScriptStencil

Categories

(Core :: JavaScript Engine, task, P1)

task

Tracking

()

RESOLVED FIXED
86 Branch
Tracking Status
firefox86 --- fixed

People

(Reporter: arai, Assigned: arai)

References

Details

Attachments

(5 files)

FunctionIndex has been an index only for function, but now initial top-level script is also indexed by FunctionIndex, and the name doesn't reflect the usage.
it should be renamed to ScriptIndex for clarity.

also, as a preparation for moving SourceExtent and gcThings out of ScriptStencil into a new vector or hashmap with same index, code that passes ScriptStencil* should be rewritten to pass ScriptIndex + CompilationStencil.

To reflect the top-level initial script usage, it should be called ScriptIndex.

Also, to use ScriptIndex in JSScript methods, it needs to be moved out of
Stencil.h.

Pushed by arai_a@mac.com:
https://hg.mozilla.org/integration/autoland/rev/7278737e2250
Part 1: Rename FunctionIndex to ScriptIndex, and move to its own header. r=tcampbell
https://hg.mozilla.org/integration/autoland/rev/b92ec7237f5e
Part 2: Remove ScriptStencil parameter from BytecodeEmitter::intoScriptStencil. r=tcampbell
https://hg.mozilla.org/integration/autoland/rev/2259750c4d4c
Part 3: Remove ScriptStencil parameter from ConvertScriptStencil. r=tcampbell
https://hg.mozilla.org/integration/autoland/rev/fa57c761af9b
Part 4: Use ScriptIndex in JSScript methods. r=tcampbell
https://hg.mozilla.org/integration/autoland/rev/6e0e587e3c42
Part 5: Remove SharedImmutableScriptData and HandleFunction parameters from JSScript::fromStencil. r=tcampbell
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: