Closed Bug 1683969 Opened 6 months ago Closed 6 months ago

Can't add search engine (easily, at least)

Categories

(Firefox :: Search, enhancement)

Firefox 84
enhancement

Tracking

()

RESOLVED INVALID

People

(Reporter: ddascalescu, Unassigned)

Details

Attachments

(2 files)

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:84.0) Gecko/20100101 Firefox/84.0

Steps to reproduce:

I'm trying to add a search engine (my Pinboard.in bookmarks). The URL is https://pinboard.in/search/u:dandv?query=<keyword>.

Actual results:

In Firefox 84 (or FF Developer 85.0b4), there's no "Add" button. How is a casual user supposed to add a search engine?

Expected results:

In Chromium, this is very easy (https://support.google.com/chrome/answer/95426): there's an "Add" button, and you type the search string, with "%s" as a placeholder for the keyword.

I'm a developer and I managed a while ago to add Pinboard (maybe I used OpenSearch somehow?), but it beats me how I did it.

Adding a search engine should definitely not be this hard.

Went to about:config. I'm surprised how opaque search is:

  • where are the search URLs for each search engine?
  • why is Yahoo! even listed, let alone as #1, when I've remove it?
  • what's up with "browser.search.param.yahoo-fr"? This is a US English installation. I expect to be able to remove that setting, but there's no trash bin icon next to it.

The hundreds of upvotes at https://superuser.com/questions/7327/how-to-add-a-custom-search-engine-to-firefox help show how annoying of a problem this is. (Remember the 1% Internet rule - the number of people impacted is at least 100x greater than the sum of all those votes).

(In reply to Dan Dascalescu from comment #0)

How is a casual user supposed to add a search engine?

You can either add the search engine from the search bar or address bar page actions button, or you can install an add-on. If the site itself doesn't provide a search engine, you can install one from the Mycroft Project. If the site doesn't provide an add-on, you might find a third-party add-on on the Firefox Add-ons site.
https://support.mozilla.org/kb/add-or-remove-search-engine-firefox

When that's not an option, you can right-click the search field and choose Add a Keyword for this Search to create a keyword bookmark. For example, if you choose the keyboard p, typing p example in the address bar allows you to search for that word. Bug 1653261 will migrate these bookmarks to the Search section of the Options tab.
https://support.mozilla.org/kb/how-search-from-address-bar

(In reply to Dan Dascalescu from comment #1)

  • where are the search URLs for each search engine?

Bug 1106626, comment 7 says once keyword bookmarks are removed, it will be possible to add and edit custom search engines in the Options tab.

  • why is Yahoo! even listed, let alone as #1, when I've remove it?
  • what's up with "browser.search.param.yahoo-fr"? This is a US English installation. I expect to be able to remove that setting, but there's no trash bin icon next to it.

Removing built-in search engines hides them from view without deleting them from the database. Only user-added preferences can be removed in about:config.

Component: Untriaged → Search

Hi, as has been already said, there are various options, in particular the side can add one, or you can add a keyword.

We are working towards allowing custom engines in bug 1650874 and its dependencies.

(In reply to Dan Dascalescu from comment #1)

Went to about:config. I'm surprised how opaque search is:

  • where are the search URLs for each search engine?

The default engines are product supplied, and we don't allow changing of those URLs. Most people don't need to, and you have other options for changing to different search engines.

  • why is Yahoo! even listed, let alone as #1, when I've remove it?

Likewise, that's an obsolete preference, and the default search engines are not changeable. If you remove them, you effectively hide them and they will not be used no activated.

  • what's up with "browser.search.param.yahoo-fr"? This is a US English installation. I expect to be able to remove that setting, but there's no trash bin icon next to it.

This is are also an obsolete default preferences set by your Linux Mint distribution. You cannot remove default preferences, you can change them, but they may / may not take affect. Generally about:config is not intended to let you change absolutely anything in the browser.

I'm resolving this as invalid, as I think this is a misplaced support request, and the main issue is already covered by existing bugs.

Status: UNCONFIRMED → RESOLVED
Closed: 6 months ago
Resolution: --- → INVALID

(In reply to Gingerbread Man from comment #3)

[...]
When that's not an option, you can right-click the search field and choose Add a Keyword for this Search to create a keyword bookmark. For example, if you choose the keyboard p, typing p example in the address bar allows you to search for that word. Bug 1653261 will migrate these bookmarks to the Search section of the Options tab.
https://support.mozilla.org/kb/how-search-from-address-bar

If it can be useful to others: on a website where this contextual Add a Keyword for this Search was not appearing even if the input was of type="search", I discovered that it was due to the fact that the input was NOT part of a form, a quick inline edit via the dev-tools in FF confirmed that as soon as i enclosed it in a form it started working.

You need to log in before you can comment on or make changes to this bug.