Closed Bug 1684149 Opened 2 years ago Closed 2 years ago

about:preferences - Privacy permissions - whole block new request inner row is clickable instead of just text+checkbox

Categories

(Firefox :: Preferences, defect, P5)

Desktop
All
defect

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox-esr78 --- wontfix
firefox84 --- wontfix
firefox85 --- wontfix
firefox86 --- fix-optional

People

(Reporter: cfogel, Unassigned)

References

Details

Attachments

(1 file)

Affected versions

  • 65.0b4, 86.0a1 (2020-12-20), 84.0.1, 78.6esr;

Affected platforms

  • macOS 10.15, Windows 10, Ubuntu 16;

Steps to reproduce

  1. Launch Firefox, access about:preferences#privacy
  2. Scroll down to the Permissions section;
  3. Click on the Settings button for [Location, Camera, Microphone, Notifications, Autoplay or Virtual Reality];
  4. On the block new requests row (one with the checkbox), hover the mouse cursor away from text (to the right);
  5. Keep clicking while moving the mouse to the right;

Expected result

  • checkbox should be toggled only while mouse is over text and checkbox;

Actual result

  • checkbox toggle is registered over the whole inner row;

Regression range

  • on initial implementation this option was not added, later on around 2018-01-09 / 2018-01-16 saw that only the checkbox was clickable;
  • result is only for when the text was made clickable:
  • First bad: 2018-01-10
  • Last good: 2018-01-09;
  • Pushlog: URL ;

Additional notes

  • attached recording to best illustrate the issue;
  • S4 as suggested severity since the impact is insignificant.
Has STR: --- → yes

(In reply to Cristian Fogel, QA [:cfogel] from comment #0)

Regression range

  • on initial implementation this option was not added, later on around 2018-01-09 / 2018-01-16 saw that only the checkbox was clickable;
  • result is only for when the text was made clickable:
  • First bad: 2020-01-10
  • Last good: 2020-01-09;
  • Pushlog: URL ;

This says 2020, but you mean 2018, right?

bug 1428581 made these clickable. Prathiksha, is this reasonably fixable without breaking wrapping for long text? I'm not sure. Perhaps we should just close as wontfix?

Blocks: 1428581
Flags: needinfo?(prathikshaprasadsuman)
Priority: -- → P5
Hardware: Unspecified → Desktop

Indeed, it's 2018; correcting in the initial post.

(In reply to :Gijs (he/him) from comment #1)

bug 1428581 made these clickable. Prathiksha, is this reasonably fixable without breaking wrapping for long text? I'm not sure. Perhaps we should just close as wontfix?

Yeah, I think this is a wontfix. I don't see a way to fix this without breaking text wrapping.

Flags: needinfo?(prathikshaprasadsuman)

wfm!

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.