about:plugins lists files that are no longer on the machine and mozilla doesn't recognise listed replacements

RESOLVED WORKSFORME

Status

()

Core
Plug-ins
P3
normal
RESOLVED WORKSFORME
16 years ago
16 years ago

People

(Reporter: Paul Maxted, Assigned: Peter Lubczynski)

Tracking

Trunk
Future
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; WinNT4.0; en-GB; rv:1.1) Gecko/20020826
Build Identifier: Mozilla/5.0 (Windows; U; WinNT4.0; en-GB; rv:1.1) Gecko/20020826

I have installed a newer version of the java VM plugins and deleted the 
old versions. Netscape 4.79 correctly lists the new plugins and functions,
Mozilla lists all the plugins (including the deleted ones) and fails to
recognise that it has any java plugins.

Reproducible: Always

Steps to Reproduce:
1.Install newer version of JRE
2.Copy new plug-in files to Mozilla plugins directory
3.Restart Mozilla
4.about:plugins
5.attempt to load java applet

Actual Results:  
about:plugins list both new and old (deleted) plugins
Mozilla show the icon to fetch the Java VM and fails to load the applet

Expected Results:  
Java applets load and run!

Comment 1

16 years ago
When you say deleted do yuo mean they were removed from the mozilla directory or
you did a sweep of the entire drive and deleted all instances? We sniff outside
of the mozilla directory for certain plug-ins.
(Reporter)

Comment 2

16 years ago
To clarify - I seached the C: drive of the NT machine and removed
all copies of the old dll files.

Comment 3

16 years ago
can you please turn on this pref, and then display about:plugins and paste in
here the contents of that page

pref ("plugin.expose_full_path", true)  -- turn this on for example in all.js
(Reporter)

Comment 4

16 years ago
OK this did identify a missed directory containing old versions - not sure 
how find missed it. Now they don't appear in "about:plugins", only the new
ones are listed, but java still doesn't work. If I load the following page ...

http://java.sun.com/docs/books/tutorial/essential/threads/index.html

... I still get the jigsaw logo and "Java Console" is greyed out on the 
tools menu.

"about:plugins gives" ...

Installed plug-ins
Find more information about browser plug-ins at Netscape.com
<http://home.netscape.com/plugins/index.html>.

------------------------------------------------------------------------
Mozilla Default Plug-in

    File name: C:\Program Files\mozilla.org\Mozilla\plugins\npnul32.dll
Default Plug-in

MIME Type Description Suffixes Enabled
* Mozilla Default Plug-in (*.*) * Yes

------------------------------------------------------------------------

Shockwave Flash

    File name: C:\Program Files\mozilla.org\Mozilla\plugins\NPSWF32.dll
Shockwave Flash 6.0 r47

MIME Type Description Suffixes Enabled
application/x-shockwave-flash Macromedia Flash movie (*.swf) swf Yes
application/futuresplash FutureSplash movie (*.spl) spl Yes

------------------------------------------------------------------------

Java Plug-in

    File name: C:\Program Files\mozilla.org\Mozilla\plugins\NPJava11.dll
Java Plug-in 1.3.1_04 for Netscape Navigator (DLL Helper)

MIME Type Description Suffixes Enabled
application/x-java-applet;version=1.1.1 Java Applet Yes
application/x-java-bean;version=1.1.1 JavaBeans Yes
application/x-java-applet;version=1.1 Java Applet Yes
application/x-java-bean;version=1.1 JavaBeans Yes
application/x-java-applet Java Applet Yes
application/x-java-bean JavaBeans Yes

------------------------------------------------------------------------

Java Plug-in

    File name: C:\Program Files\mozilla.org\Mozilla\plugins\NPJava12.dll
Java Plug-in 1.3.1_04 for Netscape Navigator (DLL Helper)

MIME Type Description Suffixes Enabled
application/x-java-applet;version=1.2 Java Applet Yes
application/x-java-bean;version=1.2 JavaBeans Yes
application/x-java-applet;version=1.1.3 Java Applet Yes
application/x-java-bean;version=1.1.3 JavaBeans Yes
application/x-java-applet;version=1.1.2 Java Applet Yes
application/x-java-bean;version=1.1.2 JavaBeans Yes

------------------------------------------------------------------------

Java Plug-in

    File name: C:\Program Files\mozilla.org\Mozilla\plugins\NPJava131_04.dll
Java Plug-in 1.3.1_04 for Netscape Navigator (DLL Helper)

MIME Type Description Suffixes Enabled
application/x-java-applet;jpi-version=1.3.1_04 Java Applet Yes
application/x-java-bean;jpi-version=1.3.1_04 JavaBeans Yes

------------------------------------------------------------------------

Java Plug-in

    File name: C:\Program Files\mozilla.org\Mozilla\plugins\NPJava32.dll
Java Plug-in 1.3.1_04 for Netscape Navigator (DLL Helper)

MIME Type Description Suffixes Enabled
application/x-java-applet;version=1.3 Java Applet Yes
application/x-java-bean;version=1.3 JavaBeans Yes
application/x-java-applet;version=1.2.2 Java Applet Yes
application/x-java-bean;version=1.2.2 JavaBeans Yes
application/x-java-applet;version=1.2.1 Java Applet Yes
application/x-java-bean;version=1.2.1 JavaBeans Yes

------------------------------------------------------------------------

Java Plug-in

    File name: C:\Program Files\mozilla.org\Mozilla\plugins\NPOJI600.dll
Java Plug-in 1.3.1_04 for Netscape Navigator (DLL Helper)

MIME Type Description Suffixes Enabled
application/x-java-vm Java Virtual Machine for Netscape 6.x Yes

------------------------------------------------------------------------

Java Plug-in 1.3 for Netscape Navigator

    File name: C:\Program Files\ESOE\JavaSoft\JRE\1.3\bin\npjava11.dll
Java Plug-in 1.3 for Netscape Navigator with JDK/JRE 1.3 (DLL Helper)

MIME Type Description Suffixes Enabled
application/x-java-applet;version=1.1.1 Java Applet Yes
application/x-java-bean;version=1.1.1 JavaBeans Yes
application/x-java-applet;version=1.1 Java Applet Yes
application/x-java-bean;version=1.1 JavaBeans Yes
application/x-java-applet Java Applet Yes
application/x-java-bean JavaBeans Yes

------------------------------------------------------------------------

Java Plug-in 1.3 for Netscape Navigator

    File name: C:\Program Files\ESOE\JavaSoft\JRE\1.3\bin\npjava12.dll
Java Plug-in 1.3 for Netscape Navigator with JDK/JRE 1.3 (DLL Helper)

MIME Type Description Suffixes Enabled
application/x-java-applet;version=1.2 Java Applet Yes
application/x-java-bean;version=1.2 JavaBeans Yes
application/x-java-applet;version=1.1.3 Java Applet Yes
application/x-java-bean;version=1.1.3 JavaBeans Yes
application/x-java-applet;version=1.1.2 Java Applet Yes
application/x-java-bean;version=1.1.2 JavaBeans Yes

------------------------------------------------------------------------

Java Plug-in 1.3 for Netscape Navigator

    File name: C:\Program Files\ESOE\JavaSoft\JRE\1.3\bin\npjava32.dll
Java Plug-in 1.3 for Netscape Navigator with JDK/JRE 1.3

MIME Type Description Suffixes Enabled
application/x-java-vm Java Virtual Machine Yes
application/x-java-applet;version=1.3 Java Applet Yes
application/x-java-bean;version=1.3 JavaBeans Yes
application/x-java-applet;version=1.2.2 Java Applet Yes
application/x-java-bean;version=1.2.2 JavaBeans Yes
application/x-java-applet;version=1.2.1 Java Applet Yes
application/x-java-bean;version=1.2.1 JavaBeans Yes

------------------------------------------------------------------------

Adobe Acrobat

    File name: C:\Program Files\Adobe\Acrobat 5.0\Reader\browser\nppdf32.dll
Adobe Acrobat Plug-In Version 5.00 for Netscape

MIME Type Description Suffixes Enabled
application/pdf Acrobat (*.pdf) pdf Yes

------------------------------------------------------------------------

Shockwave for Director

    File name: C:\Program
    Files\ESOE\Netscape\Communicator\Program\Plugins\np32dsw.dll
Macromedia Shockwave for Director Netscape plug-in, version 7.0.3

MIME Type Description Suffixes Enabled
application/x-director Shockwave Movie (*.dir;*.dxr;*.dcr) dir,dxr,dcr Yes

------------------------------------------------------------------------

QuickTime Plug-in 4.0.1

    File name: C:\Program
    Files\ESOE\Netscape\Communicator\Program\Plugins\npqtplugin.dll
    The QuickTime Plugin allows you to view a wide variety of multimedia
    content in web pages. For more information, visit the QuickTime
<http://www.apple.com/quicktime/> web site.

MIME Type Description Suffixes Enabled
video/quicktime QuickTime Movie (*.mov,*.qt) mov,qt Yes
audio/wav WAV Audio (*.wav) wav Yes
audio/x-wav WAV Audio (*.wav) wav Yes
audio/aiff AIFF Audio (*.aiff,*.aif,*.aifc) aiff,aif,aifc Yes
audio/x-aiff AIFF Audio (*.aiff,*.aif,*.aifc) aiff,aif,aifc Yes
audio/basic AU Audio (*.au,*.snd,*.ulw) au,snd,ulw Yes
video/flc FLC Animation (*.flc,*.fli) flc,fli Yes
audio/midi MIDI (*.midi,*.mid,*.smf,*.kar) midi,mid,smf,kar Yes

------------------------------------------------------------------------

QuickTime Plug-in 4.0.1

    File name: C:\Program
    Files\ESOE\Netscape\Communicator\Program\Plugins\npqtplugin2.dll
    The QuickTime Plugin allows you to view a wide variety of multimedia
    content in web pages. For more information, visit the QuickTime
<http://www.apple.com/quicktime/> web site.

MIME Type Description Suffixes Enabled
audio/x-midi MIDI (*.midi,*.mid,*.smf,*.kar) midi,mid,smf,kar Yes
audio/mid MIDI (*.midi,*.mid,*.smf,*.kar) midi,mid,smf,kar Yes
audio/vnd.qcelp QCP Audio (*.qcp) qcp Yes
application/x-rtsp Real Time Streaming Protocol (*.rtsp,*.rts) rtsp,rts Yes
application/sdp Session Description Protocol (*.sdp) sdp Yes
image/x-sgi SGI Image (*.sgi,*.rgb) sgi,rgb Yes
image/x-photoshop Photoshop Image (*.psd) psd Yes
image/x-macpaint MacPaint Image (*.pntg,*.pnt,*.mac) pntg,pnt,mac Yes

------------------------------------------------------------------------

Comment 5

16 years ago
Peter: in his about plugins list, note there are two instances of the java
plugin, could this be the reason that he cannot get java to function?

Paul: can you verify that in Edit|Preferences|Advanced - that "Enable Java" is
selected.

Comment 6

16 years ago
>    File name: C:\Program Files\mozilla.org\Mozilla\plugins\NPOJI600.dll
>Java Plug-in 1.3.1_04 for Netscape Navigator (DLL Helper)
>application/x-java-vm Java Virtual Machine for Netscape 6.x Yes

That's the magic mime type we look for with applet tags. There's only one of
those in the list. The rest are helpers.

The testcase works fine for me with JRE 1.4.1 on WinXP with NS 7.0 branch.
Disabling Java does not get the default plugin to come up for me.

Try removing all the Java DLL's and reinstall the latest JRE from Sun.

Comment 7

16 years ago
Paul: after the upgrade to the more current releases, did that resolve the problem?

Comment 8

16 years ago
reassign
Assignee: beppe → peterl

Comment 9

16 years ago
This WFM in today build.

Reporter: Be sure you are using the latest Mozilla build and reinstall the
latest version of the JRE (1.4.1) from Sun. 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Priority: -- → P3
Resolution: --- → WORKSFORME
Target Milestone: --- → Future
You need to log in before you can comment on or make changes to this bug.