Status

()

Core
DOM
P3
critical
VERIFIED FIXED
19 years ago
18 years ago

People

(Reporter: dbaron, Assigned: kinmoz)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
DESCRIPTION:
 In my test page for Document interfaces I'm getting a crash
with the following stack trace:

#0  0x4114cf53 in nsDOMAttributeMap::SetNamedItem (this=0x8184f08,
    aNode=0x8183178, aReturn=0xbfffd41c) at nsDOMAttributeMap.cpp:355
#1  0x4115499c in nsGenericElement::SetAttributeNode (this=0x816b594,
    aAttribute=0x8183178, aReturn=0xbfffd4cc) at nsGenericElement.cpp:486
#2  0x40fd9922 in nsHTMLLIElement::SetAttributeNode (this=0x816b580,
    aNewAttr=0x8183178, aReturn=0xbfffd4cc) at nsHTMLLIElement.cpp:50
#3  0x40767921 in ?? ()
   from /home/david/mozilla/src/mozilla/dist/bin/libjsdom.so


STEPS TO REPRODUCE:

 * load http://www.fas.harvard.edu/~dbaron/dom/test/one-core-html/Document
 * hit the *second* button


ACTUAL RESULTS:
crash


EXPECTED RESULTS:
no crash


DOES NOT WORK CORRECTLY ON:
 * Linux, apprunner, 1999-10-19-08-M11
 * Linux, viewer, my debug build, source pull Friday? (source of stack trace)


WORKS CORRECTLY ON:


 * older builds
(Reporter)

Comment 1

19 years ago
http://www.fas.harvard.edu/~dbaron/dom/test/one-core-html/NamedNodeMap is also
crashing.  I suspect it's the same problem, but I didn't get a stack trace.
(Assignee)

Comment 2

19 years ago
This looks like a dup of 16701. 16701 has some details on what is causing the
problem.

Updated

19 years ago
QA Contact: gerardok → janc
(Assignee)

Updated

19 years ago
Assignee: vidur → kin
Target Milestone: M11
(Assignee)

Comment 4

19 years ago
Reassigning to kin@netscape.com, I have a fix for this.
(Assignee)

Comment 5

19 years ago
Checked the following fix into:

     mozilla/layout/base/src/nsDOMAttributeMap.cpp  revision 1.7

Fix was reviewed by vidur@netscape.com.


Index: nsDOMAttributeMap.cpp
===================================================================
RCS file: /cvsroot/mozilla/layout/base/src/nsDOMAttributeMap.cpp,v
retrieving revision 1.6
diff -c -r1.6 nsDOMAttributeMap.cpp
*** nsDOMAttributeMap.cpp       1999/10/07 00:34:29     1.6
--- nsDOMAttributeMap.cpp       1999/10/25 13:44:40
***************
*** 342,348 ****
            else {
              attrPrivate->SetContent(mContent);
              attrPrivate->SetName(name);
-             NS_RELEASE(attrPrivate);

              // Add the new attribute node to the hash table (maintaining
              // a reference to it)
--- 342,347 ----
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 6

19 years ago
Verified fixed, Linux mozilla, 1999-11-13.
You need to log in before you can comment on or make changes to this bug.