Load opened windows... in the background focuses on wrong page

VERIFIED DUPLICATE of bug 159410

Status

Camino Graveyard
Accessibility
--
minor
VERIFIED DUPLICATE of bug 159410
15 years ago
15 years ago

People

(Reporter: alex taylor, Assigned: Brian Ryner (not reading))

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
Chimera 0.5.0 Build 2002090913

I have the "Load opened windows or tabs in the background" option checked
(Preferences>Navigation>Tabbed Browsing>Load...). When I right-click Chimera
(correctly) opens pages behind the page I'm linking from so I can still see what
I was reading when I encountered the link. But the hidden page is the active one
(OS widgets and everything). If I try to scroll with a mouse wheel it scrolls
the hidden window instead of the frontmost one. If I open a new tab (right-click
again) the browser behaves correctly and the focus is left in the foremost tab.
I hope this is clear enough, this is my first bug report.

Cheers, Alex

Comment 1

15 years ago
WorksForMe using Chimera/2002090913 on 10.1.5. Reassigning to Accessibility.
Assignee: sfraser → bryner
Component: Preferences → Accessibility

Comment 2

15 years ago
Created attachment 104449 [details] [diff] [review]
proposed fix

This patch fixes the focus problem (and also the accompanying annoying flash
as the new window is drawn and then pushed under the current window). I'm not
very familiar with the source yet, so it's possible it breaks something else
(although it doesn't seem to so far).

The comment above the changed line should probably be changed as well.

Comment 3

15 years ago
sfraser's fix for bug 159410 (just post-0.6) fixed this as well

Comment 4

15 years ago
Resolving dup per comment 3; the fix makes this a dup, though the descriptions
are a bit different.

*** This bug has been marked as a duplicate of 159410 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Keywords: patch, review
Resolution: --- → DUPLICATE
v dup
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.