Calendar event status either "Needs Action" or nothing at all.

RESOLVED FIXED

Status

Calendar
General
RESOLVED FIXED
15 years ago
11 years ago

People

(Reporter: Kathleen Jones, Assigned: Mike Potter)

Tracking

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1) Gecko/20020826
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1) Gecko/20020826

When editting a task, if no progress is indicated, then the Event Status is
"Needs Action". If the event is any percent complete, then Event Status will not
keep the selected "In Progress", or "Completed", or "Cancelled". It always goes
back to Status.

Reproducible: Always

Steps to Reproduce:
1. Edit a task to be a percent completed.
2. Reopen the task and change the event status.
3. Close and reopen, the event status does not show anything selected.

Actual Results:  
The event status is back to Status.

Expected Results:  
The event status should have been "In Progress" or whatever status I selected.

Using Calendar 0.8.

Comment 1

15 years ago
Confirming.
Also, when creating a new task, the Categories dropdown has 'Categories',
this should probably be blank.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Updated

15 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 2

15 years ago
OK. I've removed the drop down box, since it was really just adding some
complexity to what should be a simple thing.
If the progress > 0, then the task is in progress.  Its its 0 then the status is
needs action. I've added a checkbox where the drop down box was for cancelled,
and if the task is completed then the status is completed.
The drop down box should have catgories in it first, since that tells the user
what's in the drop down box (plus it doesn't resize after you click on one of them)
Marking this as fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 3

15 years ago
Default QA Contact for Calendar has changed.  If you wish to remain the QA
contact for this bug, feel free to change it back.
QA Contact: colint → brantgurganus2001
The bugspam monkeys have been set free and are feeding on Calendar :: General. Be afraid for your sanity!
QA Contact: gurganbl → general
You need to log in before you can comment on or make changes to this bug.