Context menu not working in toolbar bookmarks

VERIFIED DUPLICATE of bug 169591

Status

Camino Graveyard
Toolbars & Menus
VERIFIED DUPLICATE of bug 169591
16 years ago
16 years ago

People

(Reporter: Joachim Fornallaz, Assigned: Brade)

Tracking

Details

(Reporter)

Description

16 years ago
Since build ID 2002091305 there is no context menu available in the bookmark
toolbar.

Step(s) to reproduce:
1) Control-Click on a toolbar bookmark item opens the link instead of the
context menu

Comment 1

16 years ago
I can't reproduce with build 2002091305.
I open the sidebar, select a bookmark, ctrl-click, menu shows up fine.
Summary: Context menu not working in toolbar bookmarks → Context menu not working in toolbar bookmarks
(Reporter)

Comment 2

16 years ago
I am talking about the toolbar bookmarks, not the ones in the sidebar.

Comment 3

16 years ago
Yeah, I see this now. I normally only have folders in my toolbar, not single
bookmarks, but placing one there and ctrl-clicking it does cause the link to be
followed rather than brining up a contextual menu.

Exact steps:
1. Open a new browser window.
2. Make sure that the Bookmarks Toolbar is visible (View -> Show Bookmark Toolbar)
3. Place a bookmark into the Bookmark Toolbar (drag and drop will work)
4. Control-click on the bookmark.

Expected behavior:
A contextual menu should appear with choices to manage the bookmark. (As it does
with you control-click a bookmark in the sidebar.)

Actual behavior:
The bookmark activates as if it was clicked without the control key.
(Reporter)

Comment 4

16 years ago
Actually, control-click on any item in the bookmark toolbar should open a
context menu, including folders (bookmark groups).
dupping

*** This bug has been marked as a duplicate of 169591 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
v
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.