Enigmail: Networking crashes [@ nsHttpChannel::~nsHttpChannel] Trunk, M1.2a

VERIFIED WORKSFORME

Status

()

--
critical
VERIFIED WORKSFORME
16 years ago
7 years ago

People

(Reporter: greer, Assigned: darin.moz)

Tracking

({crash, topcrash-})

Trunk
x86
All
crash, topcrash-
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [enigmail], crash signature)

(Reporter)

Description

16 years ago
The only user comments under this signature in Talkback are:
(10418146 - 2002090408) - [Windows NT  5.0 build 2195]: Tried to read an email. 
(10580423 - 2002090804) - [Linux 2.4.17]: Looks like an Enigmail thing... URL:  

Darin, is this a dupe of 168513?

	 nsHttpChannel::~nsHttpChannel
[c:/builds/seamonkey/mozilla/netwerk/protocol/http/src/nsHttpChannel.cpp  line 112]
	 nsHttpChannel::`scalar deleting destructor'
	 nsHttpChannel::Release
[c:/builds/seamonkey/mozilla/netwerk/protocol/http/src/nsHttpChannel.cpp  line 2084]
	 nsCOMPtr_base::~nsCOMPtr_base
[c:/builds/seamonkey/mozilla/xpcom/glue/nsCOMPtr.cpp  line 65]
	 nsHTMLDocument::~nsHTMLDocument
[c:/builds/seamonkey/mozilla/content/html/document/src/nsHTMLDocument.cpp  line 375]
	 nsDocument::Release
[c:/builds/seamonkey/mozilla/content/base/src/nsDocument.cpp  line 699]
	 XPCJSRuntime::GCCallback
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcjsruntime.cpp  line 539]
	 js_GC	[c:/builds/seamonkey/mozilla/js/src/jsgc.c  line 1400]
	 js_ForceGC	[c:/builds/seamonkey/mozilla/js/src/jsgc.c  line 994]
	 JS_GC	[c:/builds/seamonkey/mozilla/js/src/jsapi.c  line 1660]
	 nsJSContext::Notify
[c:/builds/seamonkey/mozilla/dom/src/base/nsJSEnvironment.cpp  line 1598]
	 nsTimerManager::FireNextIdleTimer
[c:/builds/seamonkey/mozilla/xpcom/threads/nsTimerImpl.cpp  line 591]
	 nsAppShellService::Run
[c:/builds/seamonkey/mozilla/xpfe/appshell/src/nsAppShellService.cpp  line 472]
	 main1	[c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp  line 1524]
	 nsAppShellService::Run
[c:/builds/seamonkey/mozilla/xpfe/appshell/src/nsAppShellService.cpp  line 472]
	 main1	[c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp  line 1524]
	 main	[c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp  line 1871]
	 WinMain	[c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp  line 1889]
	 WinMainCRTStartup()
	 KERNEL32.DLL + 0x1ca90 (0x77e9ca90)
(Reporter)

Updated

16 years ago
Keywords: crash, topcrash
(Reporter)

Comment 1

16 years ago
My apologies, this is a dupe of 164053.

*** This bug has been marked as a duplicate of 164053 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

16 years ago
v
Status: RESOLVED → VERIFIED
(Assignee)

Comment 3

16 years ago
actually, this stack trace looks entirely different to me.  REOPENING.
Status: VERIFIED → REOPENED
Resolution: DUPLICATE → ---
(Assignee)

Updated

16 years ago
Whiteboard: [enigmail]
(Assignee)

Comment 4

16 years ago
severity:critical is wrong for this bug.  minor at best, probably INVALID.  sent
mail to enigmail@mozdev.org, hoping to get some feedback from the enigmail
developers.
Severity: critical → minor
Summary: Networking crashes [@ nsHttpChannel::~nsHttpChannel] Trunk, M1.2a → Enigmail: Networking crashes [@ nsHttpChannel::~nsHttpChannel] Trunk, M1.2a

Comment 5

16 years ago
By the definitions on <http://bugzilla.mozilla.org/bug_status.html#severity> and
<http://bugzilla.mozilla.org/enter_bug.cgi?format=guided>, crashing and dataloss
bugs are of critical or possibly higher severity.  Only changing open bugs to
minimize unnecessary spam.  Keywords to trigger this would be crash, topcrash,
topcrash+, zt4newcrash, dataloss.
Severity: minor → critical

Comment 6

16 years ago
There are only 2 talkback incidents of this stack signature reported in 2003
which were in builds 2003011308 and 2003010908. 

Marking this bug talkback-
Fixed?
Keywords: topcrash → topcrash-

Comment 7

15 years ago
The last comment is one year old. Does anyone still see this?
(CCing current Enigmail maintainer)

Comment 8

15 years ago
This has been fixed in Enigmail long ago. I wasn't aware that such a bug exists
in Mozilla bugzilla -- you can close this one.

Comment 9

15 years ago
Marking WFM as per Patricks comment.
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago15 years ago
Resolution: --- → WORKSFORME
verified, although per comment 8 this was probably an enigmail bug, not a
mozilla bug, and thus INVALID would have been better,
Status: RESOLVED → VERIFIED
Crash Signature: [@ nsHttpChannel::~nsHttpChannel]
You need to log in before you can comment on or make changes to this bug.