[RFE] Support MSHTML object or implement similar DHTML behavior in Mozilla

VERIFIED DUPLICATE of bug 130796

Status

SeaMonkey
Composer
--
enhancement
VERIFIED DUPLICATE of bug 130796
15 years ago
13 years ago

People

(Reporter: fstmaurice, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1) Gecko/20020826
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1) Gecko/20020826

This is an example of a now more and more used feature in IE by web developpers.
It allows non-programmers or people not accustomized to HTML to farmat HTML text
by WYSIWYG interface, directly in the browser.

I'm sure this goal is attainable with XUL, except that I have yet to see a
usable example that reproduce this IE DHTML behaviour. It forces us developpers
to use a java applet to reproduce the look and feel of IE. This is a very costly
solution though.

See the following doc to have more information on the MSHTML object:
http://msdn.microsoft.com/library/default.asp?url=/workshop/browser/editing/mshtmleditor.asp

Load the attachement in IE to see what I would like to have in Mozilla browser.

Reproducible: Always

Steps to Reproduce:
1. Load the example in IE
2. Play around with the text...format it as you like, view the HTML generated
with the view HTML mode checkbox
3. The javascript is encrypted for copyright purposes...



Expected Results:  
There should be a way to have the same type of widget in Mozilla browsers
(Reporter)

Comment 1

15 years ago
Created attachment 99078 [details]
MSHTML example...load it in IE

Comment 2

15 years ago
Not a JavaScript Engine issue. Not sure of the right component for this,
but it seems most closely related to our Composer app. 

Therefore reassigning to Editor: Composer for further triage -
Assignee: rogerl → syd
Status: UNCONFIRMED → NEW
Component: JavaScript Engine → Editor: Composer
Ever confirmed: true
QA Contact: pschwartau → sujay
Summary: Enhancement: Support MSHTML object or implement similar DHTML behavior in Mozilla → [RFE] Support MSHTML object or implement similar DHTML behavior in Mozilla

Comment 3

15 years ago
dup of bug 130796

*** This bug has been marked as a duplicate of 130796 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 5

15 years ago
verified.
Status: RESOLVED → VERIFIED

Comment 6

15 years ago
reset owner in case bugs are reopened
Assignee: syd → composer
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.