Mozilla doesn't respect "overflow:hidden"-style (CCS2) on <td> elements

RESOLVED INVALID

Status

()

RESOLVED INVALID
16 years ago
16 years ago

People

(Reporter: nospam, Assigned: karnaze)

Tracking

({css2})

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1) Gecko/20020826
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1) Gecko/20020826

Although DOM-Inspector lists overflow:hidden in it's "Computed Style", the
specified width and height are not respected, instead it behaves like
overflow:show (the default behaviour).

<table style="border:solid 1px">
  <tr>
    <td style="width:20px; height:20px; overflow:hidden; white-space:nowrap">
      a long line which should be clipped and hidden
    </td>
  </tr>
</table>

See attachment for more test cases.

Reproducible: Always

Steps to Reproduce:
(Reporter)

Updated

16 years ago
Keywords: css2
(Reporter)

Comment 1

16 years ago
Created attachment 99100 [details]
various test-cases for <td> and overflow:hidden

Comment 2

16 years ago
Reporter, please check bug 93905. If that is the same problem as you are
experiencing, please resolve this bug as a duplicate.
From http://www.w3.org/TR/CSS2/tables.html#auto-table-layout:

  Column widths are determined as follows:

  1)  Calculate the minimum content width (MCW) of each cell: the formatted
      content may span any number of lines but may not overflow the cell box.

The algorithm then goes on to say that cells may not be smaller than the minimum
width thus calculated.  Thus in the auto-layout case table cells cannot
overflow, by definition.

All the testcases you posted are auto layout.  Including the ones for which you
said "table-layout: fixed", because at
http://www.w3.org/TR/CSS2/tables.html#fixed-table-layout we have:

   The table's width may be specified explicitly with the 'width' property. A
   value of 'auto' (for both 'display: table' and 'display: inline-table') means
   use the automatic table layout algorithm.

Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.