Type Ahead Find makes anoying system beep when no links are found

VERIFIED DUPLICATE of bug 176602

Status

()

VERIFIED DUPLICATE of bug 176602
16 years ago
16 years ago

People

(Reporter: hhg, Assigned: aaronlev)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
The new Type Ahead Find-feature should have some checkbox or pref-setting that
would make it not beep when no links are found. The system beep is really
anoying when surfing in a library or at night, for instance, and it makes for
people to "be afraid" to touch the keyboard whilst surfing. I also feel thet the
beep should be opt-in and not opt-out.
-> Keyboard nav
Assignee: asa → aaronl
Component: Browser-General → Keyboard Navigation
QA Contact: asa → sairuh

Comment 2

16 years ago
No dupes, valid bug. But No More Prefs.

Let's just drop the goddamn beep, it's extremely annoying.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 3

16 years ago
I totally understand that the beep is irritating. At the same time, a lot of
people have told me they like the beep -- otherwise there is not very good feedback.

We're probably going to need a Keyboard Navigation prefs panel anyway -- we'll
probably expose at least 1 other Type Ahead Find pref there.

I know we have too many prefs -- but I really think the audio feedback is important.
Status: NEW → ASSIGNED

Comment 4

16 years ago
The beep is pretty awful - a beep from a UI point of view is "telling off" the
user and making them feel like the program is fragile. Kill it please by
default. Some sort of flash would be better.

Also the beep on XWindows doesn't seem to use the XWindows beep. I have XFree86
set so the beep volume is 0, but still it doesn't stop this beep. I think the
program should be using the XBell X function rather than whatever it is using
currently.
(Assignee)

Comment 5

16 years ago
Is there something better that I can do than this?

805       nsCOMPtr<nsISound> soundInterface =
806         do_CreateInstance("@mozilla.org/sound;1");
807       if (soundInterface) {
808         soundInterface->Beep();

The default beep is supposed to be user-configurable through the OS.

Comment 6

16 years ago
Doing a bit of research on this, soundInterface->Beep() calls gdk_beep (part of
gtk+). Unfortunately in gtk+ 1.2.x, gdk_beep calls XBell(display, 100), which
makes a beep but increasing the volume of the beep up by 100%. This overrides
the default volume setting (which I have set to 0). Therefore there is no
ability to configure the volume on X.

gtk+ 2.x correctly calls XBell(display, 0), which makes a beep at the default
volume (which is user-configurable).

So
1. Mozilla should modify nsCOMPtr<nsISound> on the gtk port to call
XBell(display, 0) instead of gdk_beep (or remove the call altogether),
2. We wait until Mozilla is properly ported to gtk+ 2.x (yawn and lots of
annoyance), or
3. We remove the beep.

I think I beep is almost always a bad idea (anyone who has ever used Locoscript
on an Amstrad PCW will testify to that). Are there any usability people this can
get referred to? Beeps are also no use to the deaf.
(Assignee)

Comment 7

16 years ago
It is annoying. Either we'll remove the beep, or have a pref. Not sure which yet.

I think you should file a bug on the nsISound->Beep() problem and submit a patch
-- what do you think?

Comment 8

16 years ago
Another vote for losing the annoying beep when links/text not found. 

On WinXP the sound is like a loud quick burp, for lack of a better
description--it feels like I'm being punished for searching for something that's
not there.

It just occurred to me however, that if one has the status bar hidden, then
audio feedback could be useful. If a pref is made for the beep instead of losing
it altogether, and if the opt-out route ends up being chosen, perhaps the beep
should only happen if the status bar is hidden? I agree with the reporter
though, if it's going to be a pref it should be opt-in.

Another thought, if a pref is made: on windows platform the user should be able
to change the beep via Control Panel -> Sounds and Audio Devices -> Sounds ->
Program Events. (This is for XP but I believe this control panel is available
under 95/98/ME/2K as well, just under a different name/clickpath) This way, one
can choose a more pleasant sound file as the beep, or turn it off by choosing
"(None)".

That's a lot more work though, when you can simply get rid of the beep
altogether. =) 

Comment 9

16 years ago
Isn't this a duplicate of bug 176602?

For anyone still annoyed by the beep, there is now a pref to turn it off, see
bug 176602.
(Assignee)

Comment 10

16 years ago

*** This bug has been marked as a duplicate of 176602 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
v dup.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.