The default bug view has changed. See this FAQ.

Freeze nsIEditingSession interface

RESOLVED WONTFIX

Status

()

Core
Embedding: APIs
RESOLVED WONTFIX
15 years ago
7 years ago

People

(Reporter: Juan José Mata, Unassigned)

Tracking

(Depends on: 1 bug, {topembed+})

Trunk
mozilla1.6alpha
topembed+
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
From http://www.mozilla.org/projects/embedding/apiReviewNotes.html#nsIEditingSession
, issues to be addressed:

    *  Need a new API on this interface (bug 132700 logged on this) for handling
of subframes.
    * Split interface into two, so that init(...), setupEditorOnWindow(...) and
tearDownEditorWindow(...) can be separate and private.
    * Need to add a way to make a window non-editable.
    * Cannot control what kind of editor is created (we pass no flags down to
the editor code), like mail editting-type or HTML vs. plaintext.
    * Remove nsIEditingShell from includes.
    * Also need to figure out a way to handle the types of content that cannot
be edited.
    * Remove nsIEditor as well, since the whole idea going forward is to have
the CommandManager/CommandParams mechanism to access the editor functionality.

Please follow the guidelines outlined in the "How to mark an interface as
FROZEN" at http://www.mozilla.org/projects/embedding/HowToFreeze.html

Comment 1

15 years ago
Over to mike
Assignee: sfraser → mjudge
(Reporter)

Comment 2

15 years ago
Set milestone (1.2beta) as well as dependency info.
Blocks: 157137
Depends on: 79895, 132700
Target Milestone: --- → mozilla1.2beta

Comment 3

15 years ago
um, ver 1.2 is still not part of the build, the idl file as is doesn't follow
style and has at least one visible typo:
51                   the session (usually the content root frame.
52               */

is there a reason this bug is unconfirmed? is it a stealth freeze?

Comment 4

15 years ago
confirm; not a stealth freeze
It's more desirable to freeze nsIEditingSession than freeze the editor apis.
If it's not part of the builds, I suspect it will be in the next few months.  :-)
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 5

14 years ago
Removing already-past target milestone.  Mike/Chris please re-target.

Nominating topembed since editor embedding clients will need this interface frozen.
Keywords: topembed
Target Milestone: mozilla1.2beta → ---

Comment 6

14 years ago
topembed+, let's just freeze it
Keywords: topembed → topembed+

Comment 7

14 years ago
picking milestone to make sure this is on the radar for 1.6
Target Milestone: --- → mozilla1.6alpha
Assignee: mjudge → nobody
QA Contact: dunn5557 → apis
We don't freeze interfaces anymore.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.