Closed Bug 1686205 Opened 10 months ago Closed 9 months ago

Crash in [@ mozilla::ipc::FatalError | mozilla::dom::PContentChild::OnMessageReceived]

Categories

(Core :: Layout: Text and Fonts, defect)

Unspecified
Linux
defect

Tracking

()

RESOLVED DUPLICATE of bug 1664151

People

(Reporter: gsvelto, Unassigned)

Details

(Keywords: crash)

Crash Data

Crash report: https://crash-stats.mozilla.org/report/index/449403e4-fdf5-4c32-be11-a25e90210109

MOZ_CRASH Reason: IPDL error: "Error deserializing 'SharedMemoryHandle[]'". abort()ing as a result.

Top 10 frames of crashing thread:

0 libxul.so mozilla::ipc::FatalError ipc/glue/ProtocolUtils.cpp:194
1 libxul.so mozilla::dom::PContentChild::OnMessageReceived ipc/ipdl/PContentChild.cpp:11398
2 libxul.so mozilla::ipc::MessageChannel::DispatchMessage ipc/glue/MessageChannel.cpp:2077
3 libxul.so mozilla::TaskController::DoExecuteNextTaskOnlyMainThreadInternal xpcom/threads/TaskController.cpp:739
4 libxul.so nsThread::ProcessNextEvent xpcom/threads/nsThread.cpp:1200
5 libxul.so mozilla::ipc::MessagePump::Run ipc/glue/MessagePump.cpp:109
6 libxul.so MessageLoop::Run ipc/chromium/src/base/message_loop.cc:309
7 libxul.so nsBaseAppShell::Run widget/nsBaseAppShell.cpp:137
8 libxul.so XRE_RunAppShell toolkit/xre/nsEmbedFunctions.cpp:902
9 libxul.so MessageLoop::Run ipc/chromium/src/base/message_loop.cc:309

Lots of crash reports but mostly coming from a single user so it could be malfunctioning hardware - though it's odd that it would always fail here.

Based on a few crash reports, it looks like this is specifically the sharedFontListBlocks argument to SetXPCOMProcessAttributes.

Component: DOM: Content Processes → Layout: Text and Fonts

This looks like a duplicate of bug 1664151; see previous discussion there.

Status: NEW → RESOLVED
Closed: 9 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1664151
You need to log in before you can comment on or make changes to this bug.