Closed Bug 168627 Opened 22 years ago Closed 19 years ago

Use bullets instead of stars for password masking in HTML forms

Categories

(Camino Graveyard :: HTML Form Controls, defect, P5)

PowerPC
macOS
defect

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 97811
Camino1.6

People

(Reporter: cosm7x, Assigned: bryner)

References

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20020913
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20020913

For the sake of consistency. Stars are not used in OS X for password masking. 

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Bug 97811 is about doing this for Mozilla. Dup? Or, dependent on a transition to
native text fields (bug 148098)?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Use the 'dots' instead of stars for password masking in html forms → Use bullets instead of stars for password masking in HTML forms
Be careful when this is actually done. MSIE uses bullets as password mask but
the mask becomes Chinese characters when the page encoding is not in english.
Other language sets might be affected too.
http://developer.apple.com/techpubs/macosx/Essentials/AquaHIGuidelines/AHIGUserInput/Entering_Passwords.html

When a user types a password into a text field, each typed character should
appear as a BULLET, matching the number of characters typed by the user. If the
user deletes a character with the Delete key, one bullet is deleted from the
text field and the insertion point moves back one bullet, as if the bullet
represented an actual character. Double-clicking bulleted text in a password
field selects all the bullets in the text field.

When the user leaves the text field (by pressing Tab, for example), the number
of bullets in the text field should be MODIFIED so that the field does not
reflect the actual number of characters in the password.
Macs use bullets for passwords, never stars. This seems like an easy thing to
fix in Chimera and Mozilla. Although I think this is a gecko thing, so it should
be fixed in mozilla first.
still true with 2003082402
fwiw safari uses bullets, but does not do any character count
modification/masking when a user leaves the form control
I wasn't sure how this was an enhancement. Definitely a bug in my book. I'm
targeting for 1.0. We should integrate well enough to support this visually.
Severity: enhancement → trivial
Priority: -- → P5
Target Milestone: --- → Camino1.0
Depends on: 97811
This is really a duplicate of a core bug (bug 97811) which has a patch.  If
someone wants to fix this bug, I'd be happy to review (reassign bug 97811 to
yourself).

The issue is that the bullet character that is always available is VERY small
(about one pixel bigger than a period).  It is so bad that it is better to stick
with the asterisk.  The bullet I'd like to use is not available in all fonts.

What is needed is some logic to determine when it's ok to use the big bullet
character and when an asterisk or some other character should be used.

Another possibility would be to use the bullet character that is always
available but make it much bigger; this might make the password field too tall(?).
minor, not for 1.0.
Target Milestone: Camino1.0 → Camino1.2
*** Bug 328695 has been marked as a duplicate of this bug. ***
Marking as a dupe of the Core bug, which I'm willing to take if someone can help me out with the fallback logic. I know *nothing* about non-Roman character sets.

cl

*** This bug has been marked as a duplicate of 97811 ***
Status: NEW → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
No longer depends on: 97811
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.