Closed Bug 1686298 Opened 2 years ago Closed 2 years ago

Port Bug 1629113 to Thunderbird - Move caret browsing handler to tabbrowser.js (It's no longer possible to enable caret browsing on Thunderbird with F7)

Categories

(Thunderbird :: Upstream Synchronization, defect, P2)

Tracking

(thunderbird_esr78 wontfix)

VERIFIED FIXED
91 Branch
Tracking Status
thunderbird_esr78 --- wontfix

People

(Reporter: foss, Assigned: henry-x)

References

(Regression)

Details

(Keywords: access, regression)

Attachments

(1 file)

Hello,

This issue is a regression.

Caret browsing means moving with the keyboard on mails and displaying the keyboard focus/caret .

Steps to reproduce:

  1. Open any mail (here with Thunderbird Daily on Debian GNU/Linux)
  2. Press F7

Result:
Nothing is happening.

  1. Open a webpage in Firefox and press F7 or try it with Thunderbird 68 (I don't have 78 to try). Choose the button yes to enable caret browsing and verify moving with the keyboard works.

Intended behavior:
it displays a pop-up allowing to activate caret browsing and pressing the yes buttons works to add a caret on the screen.

It is important for low-vision people who would like to move into mails with the keyboard, without it, it's impossible to move with the keyboard focus within a mail.

It's also very useful when debugging a caret issue where it doesn't go up/down one line (not theoretical, I'm having the bug on one mail in Daily, a bug is coming).

I don't know precisely when the problem lands in Thunderbird mostly because I use the screen reader to read my mails and the screen reader activate caret browsing for the user when opening a mail (but don't display the caret itself).

Thanks in advance.

Hello Alex Arnaud, thank you for your bug report.

I can confirm that caret browsing works on Thunderbird 68 (as well as current Firefox 84), but it is no longer working on Thunderbird 78. It's a bug which should be fixed asap. Caret browsing is an important accessibility feature, not only for low-vision users, but also for general keyboard efficiency.

Alice, could you kindly find the regression range between Thunderbird 68 and 78? Tia!

Severity: -- → S3
Flags: needinfo?(alice0775)
Priority: -- → P2
Component: Untriaged → Disability Access
Version: unspecified → 78
Regressed by: 1629113

Magnus, any idea what might be the missing piece here?
It would be quite important for access to get this fixed.

This was regressed by https://phabricator.services.mozilla.com/D72724 - Bug 1629113 - Move caret browsing handler to tabbrowser.js. r=NeilDeakin

Flags: needinfo?(mkmelin+mozilla)

Looks like toggleCaretBrowsing() + hooking that up needs to be added in tabmail.js

Assignee: nobody → henry
Component: Disability Access → Upstream Synchronization
Flags: needinfo?(mkmelin+mozilla)
Summary: It's no longer possible to enable caret browsing on Thunderbird with F7 → Port Bug 1629113 to Thunderbird - Move caret browsing handler to tabbrowser.js (It's no longer possible to enable caret browsing on Thunderbird with F7)

I think I've got the general idea for how to implement the same sort of thing in Thunderbird. Two things I'm not sure about:

  1. Do you want the keypress handler set up in MozTabmail.connectedCallback?
  2. I don't know exactly what this line does https://hg.mozilla.org/integration/autoland/rev/5b97f74fb6fd#l1.15. Is the idea that the F? keypresses are not available to window.addEventListener("keypress")? What would I need to do in TB to use addSystemEventListener?
Flags: needinfo?(mkmelin+mozilla)

1: probably yes.
2: not sure exactly why it's done like that. But you should be able to just copy paste the code into a suitable location. Nothing special needed to call Services.els.addSystemEventListener.

Flags: needinfo?(mkmelin+mozilla)

The current patch re-enables this for the tabbed window. However, if you "Open Message in New Window" and focus on it, then pressing F7 does nothing. Does anyone know whether you could before enable caret browsing from a message window?

Just tried it in 68, and there it works in the standalone message window as well.

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/d794dca2df1f
Re-enable toggling caret browsing with F7. r=mkmelin

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → 91 Branch

Awesome! Thanks to Magnus and Henry for getting this fixed this so fast!

(In reply to Magnus Melin [:mkmelin] from comment #9)

Just tried it in 68, and there it works in the standalone message window as well.

I think we should re-enable this for standalone message windows - this is important for users depending on accessibility features.

Henry, would you prefer to fix this in a new bug or to add a followup patch here? (That's a catch-22 ;-))

Flags: needinfo?(henry)

The patch already fixed the standalone message window as well. Working just fine on trunk.

Flags: needinfo?(henry)

(In reply to Magnus Melin [:mkmelin] from comment #12)

The patch already fixed the standalone message window as well. Working just fine on trunk.

Ah, that's great news, thanks!

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.