Closed Bug 1686331 Opened 2 years ago Closed 2 years ago

(regression) library panel has a scrollbar

Categories

(Firefox :: Menus, defect)

defect

Tracking

()

RESOLVED FIXED
86 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox84 --- unaffected
firefox85 --- unaffected
firefox86 + fixed

People

(Reporter: soeren.hentzschel, Assigned: ewright)

References

(Regression)

Details

(Keywords: regression)

Attachments

(2 files)

The library panel has a scrollbar for no obvious reason. According to mozregression it's a regression from bug 1685133. I don't know why this change should affect the library menu but I executed mozregression two times to be sure and the result was the same.

0:37.25 INFO: Got as far as we can go bisecting nightlies...
0:37.25 INFO: Last good revision: e7ad4ad7c65b441e3cd8e5845ff84df4a28de210 (2021-01-08)
0:37.25 INFO: First bad revision: 87c24c64eece98464a05f684742798f2c9ae00de (2021-01-09)
0:37.25 INFO: Pushlog:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=e7ad4ad7c65b441e3cd8e5845ff84df4a28de210&tochange=87c24c64eece98464a05f684742798f2c9ae00de

Tested on macOS 11.1.

Flags: needinfo?(ewright)
Attached image screenshot

(In reply to Sören Hentzschel from comment #0)

The library panel has a scrollbar for no obvious reason.

My guess is that the code added to browser/components/customizableui/content/panelUI.js in the regressing patch slows down layout enough that the window sizes before we have the contents populated.

Flags: needinfo?(ewright)

Tracking as it seems to be a visible issue for end users and we are approaching the beta merge. Erica, do you have an opinion on this bug? Is that a cross-platform bug or only mac?

Flags: needinfo?(ewright)

looking into it now. I think it is a pretty easy CSS change. Odd that it happened though. I will assign myself.

Assignee: nobody → ewright
Status: NEW → ASSIGNED
Flags: needinfo?(ewright)

(In reply to Pascal Chevrel:pascalc from comment #3)

Tracking as it seems to be a visible issue for end users and we are approaching the beta merge. Erica, do you have an opinion on this bug? Is that a cross-platform bug or only mac?
@pascal - there is no scroll bar when the experimental pref is off, so this is less concerning. Note that this pref will remain off for 86 except for experiments.

Pushed by flodolo@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/775a35e213ab
Library menu should not have a scroll bar. r=prathiksha,flod
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → 86 Branch
Has Regression Range: --- → yes
You need to log in before you can comment on or make changes to this bug.