Closed Bug 1686387 Opened 5 days ago Closed 4 days ago

Crash in [@ google_breakpad::ExceptionHandler::HandleInvalidParameter]

Categories

(Toolkit :: Crash Reporting, defect, P1)

Firefox 86
x86_64
Windows 10
defect

Tracking

()

RESOLVED FIXED
86 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox84 --- unaffected
firefox85 --- unaffected
firefox86 blocking fixed

People

(Reporter: copyliu, Unassigned)

References

(Regression)

Details

(Keywords: regression)

Crash Data

Crash report: https://crash-stats.mozilla.org/report/index/4e47360e-7e61-41f6-abf0-35ccc0210113

Reason: 0xc000000d / 0x00000000

Top 10 frames of crashing thread:

0 xul.dll static google_breakpad::ExceptionHandler::HandleInvalidParameter toolkit/crashreporter/breakpad-client/windows/handler/exception_handler.cc:596
1 ucrtbase.dll invalid_parameter 
2 xul.dll trunc 
3 ucrtbase.dll acrt_FlsGetValue 
4 ucrtbase.dll invalid_parameter_noinfo 
5 xul.dll trunc 
6 ucrtbase.dll errno 
7 xul.dll trunc 
8 xul.dll trunc 
9 ucrtbase.dll common_fdopen<char> 

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: General → Crash Reporting
Product: Firefox → Toolkit
Duplicate of this bug: 1686389

This is looking bad. Nightly updates disabled.

Severity: -- → S1
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P1

Bug 1680402 seems extremely likely.

Regressed by: 1680402

For the record, I'm fairly sure that bug 1680402 is the correct regressor, because I can make the crash stop happening by running with -attach-console; with that, I can see the error message that my crash dump tells me was trying to get printed show up on the console without incident.

Crash Signature: [@ google_breakpad::ExceptionHandler::HandleInvalidParameter] → [@ google_breakpad::ExceptionHandler::HandleInvalidParameter] [@ RtlComputePrivatizedDllName_U + 0x110] [@ ucrtbase.dll + 0xa0d6b]
Crash Signature: [@ google_breakpad::ExceptionHandler::HandleInvalidParameter] [@ RtlComputePrivatizedDllName_U + 0x110] [@ ucrtbase.dll + 0xa0d6b] → [@ google_breakpad::ExceptionHandler::HandleInvalidParameter] [@ RtlComputePrivatizedDllName_U + 0x110] [@ ucrtbase.dll + 0xa0d6b] [@ static google_breakpad::ExceptionHandler::HandleInvalidParameter(wchar_t const*, wchar_t const*, wchar_t const*, unsigned…

Fixed by backout, nightly updates are re-enabled.

https://hg.mozilla.org/mozilla-central/rev/9594d105ec37

Status: NEW → RESOLVED
Crash Signature: [@ google_breakpad::ExceptionHandler::HandleInvalidParameter] [@ RtlComputePrivatizedDllName_U + 0x110] [@ ucrtbase.dll + 0xa0d6b] [@ static google_breakpad::ExceptionHandler::HandleInvalidParameter(wchar_t const*, wchar_t const*, wchar_t const* → [@ google_breakpad::ExceptionHandler::HandleInvalidParameter] [@ RtlComputePrivatizedDllName_U + 0x110] [@ ucrtbase.dll + 0xa0d6b] [@ static google_breakpad::ExceptionHandler::HandleInvalidParameter(wchar_t const*, wchar_t const*, wchar_t const*
Closed: 4 days ago
Resolution: --- → FIXED
Target Milestone: --- → 86 Branch
Crash Signature: , unsigned int, unsigned long long)] → , unsigned int, unsigned long long)] [@ _invalid_parameter + 0x121]

In case it helps: fdopen stuck an EBADF into errno before raising the exception.

Crash Signature: , unsigned int, unsigned long long)] [@ _invalid_parameter + 0x121] → , unsigned int, unsigned long long)] [@ _invalid_parameter + 0x121]

Probably checking the return value of _fileno is sufficient to fix this.

You need to log in before you can comment on or make changes to this bug.