Closed Bug 1686529 Opened 11 months ago Closed 9 months ago

Refresh the default/light/dark theme colour palette

Categories

(Firefox :: Toolbars and Customization, enhancement, P1)

enhancement
Points:
3

Tracking

()

RESOLVED FIXED
89 Branch
Tracking Status
firefox89 --- fixed

People

(Reporter: mstriemer, Assigned: jaws, NeedInfo)

References

(Blocks 1 open bug)

Details

(Whiteboard: [proton-toolbar])

Attachments

(1 file)

There will likely be some changes to the built-in themes' colour palettes.

Whiteboard: [proton-toolbar]

It would also make sense for the "default"/system theme to look the same as the "light" theme when the system is in light mode. Currently there is no easy way to have a 'proper' light theme (with the tab bar being white as well, instead of gray) but also have it adapt to the system light/dark mode pref.

Priority: -- → P2

UX mentioned that the separator colours are off in the tabs/toolbar hand-off.

The tabs/nav-bar separator can be set with toolbar_top_separator and should match the nav-bar's colour (from toolbarColor). There is no longer a separator visible here in the built-in light/dark themes.

The toolbox/content separator should be updated toolbar_bottom_separator.

Points: --- → 3

Not sure this belongs here, but I find the lack of contrast between the toolbar and the urlbar to be disturbing.

See bug 1693819 comment 5 for updates to the dark in-content background colour that are still needed.

Assignee: nobody → jaws
Status: NEW → ASSIGNED

macOS was done in bug 1694526.

Depends on: 1694526

(In reply to Tim Nguyen :ntim from comment #6)

macOS was done in bug 1694526.

I don't think macOS can be considered as done based on this comment from Asa Dotzler:
https://bugzilla.mozilla.org/show_bug.cgi?id=1697559#c8

It probably affects all platforms but I can only speak for macOS and what he says is still true on macOS.

(In reply to Sören Hentzschel from comment #7)

It probably affects all platforms but I can only speak for macOS and what he says is still true on macOS.

I was just saying "done" as in the scope of dropping in proton colors (which is what this bug is about), bug 1697559 is a different scope of work (seems to be on target for the initial release according to the priority change on that bug).

See Also: → 1697559

Thanks for clarifying. 😊

Priority: P2 → P1
Duplicate of this bug: 1688241
Duplicate of this bug: 1697559
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c10c8cecab42
Update the tab and toolbar colors for Proton Light and Proton Dark themes. r=desktop-theme-reviewers,harry

Backed out for causing browser-chrome failures in browser_preferences_usage

Backout link: https://hg.mozilla.org/integration/autoland/rev/dcecf8835dbadf7458a376cfe224b88ac9145e2c

Push with failures

Failure log

INFO - Buffered messages finished
[task 2021-03-26T01:47:59.797Z] 01:47:59 INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/performance/browser_preferences_usage.js | browser.proton.tabs.enabled should not be accessed more than 40 times. - 44 <= 40 - JS frame :: chrome://mochitests/content/browser/browser/base/content/test/performance/browser_preferences_usage.js :: checkPrefGetters :: line 42
[task 2021-03-26T01:47:59.797Z] 01:47:59 INFO - Stack trace:
[task 2021-03-26T01:47:59.798Z] 01:47:59 INFO - chrome://mochitests/content/browser/browser/base/content/test/performance/browser_preferences_usage.js:checkPrefGetters:42
[task 2021-03-26T01:47:59.798Z] 01:47:59 INFO - chrome://mochitests/content/browser/browser/base/content/test/performance/browser_preferences_usage.js:startup:142

Flags: needinfo?(jaws)
Flags: needinfo?(jaws)
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8905f966acac
Update the tab and toolbar colors for Proton Light and Proton Dark themes. r=desktop-theme-reviewers,harry
Status: ASSIGNED → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → 89 Branch
Regressions: 1701281
Regressions: 1701266
No longer regressions: 1701266
See Also: → 1701266

I noticed this bug reintroduced ntp_background and ntp_text for default-theme's dark_theme.colors that was removed as part of bug 1546540 just a few weeks before this bug was fixed.

Removal:
https://hg.mozilla.org/mozilla-central/rev/69785e213145

Addition (some reason searchfox incorrectly blames bug 1695345):
https://hg.mozilla.org/mozilla-central/rev/8905f966acaca52e7becc86e937c4428219c7417#l14.39

Was that intentional or it doesn't really affect users (i.e., maybe redundant code but no default/dark theme regression on linux)?

See Also: → 1546540

(In reply to Ed Lee :Mardak from comment #17)

I noticed this bug reintroduced ntp_background and ntp_text for default-theme's dark_theme.colors that was removed as part of bug 1546540 just a few weeks before this bug was fixed.

Removal:
https://hg.mozilla.org/mozilla-central/rev/69785e213145

Addition (some reason searchfox incorrectly blames bug 1695345):
https://hg.mozilla.org/mozilla-central/rev/8905f966acaca52e7becc86e937c4428219c7417#l14.39

Was that intentional or it doesn't really affect users (i.e., maybe redundant code but no default/dark theme regression on linux)?

Setting needinfo so this gets seen...

Flags: needinfo?(jaws)
You need to log in before you can comment on or make changes to this bug.