cannot properly enter text in yahoo chat java applet

RESOLVED WORKSFORME

Status

--
major
RESOLVED WORKSFORME
16 years ago
7 years ago

People

(Reporter: cold_pet_rat, Assigned: blackconnect)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020826
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020826

the focus in the chat applet will not stay long enough to enter text.  you must
click on the form to regain focus after every letter or two.  this happens for
me wiht both mozilla 1.0.1 and 1.0 with both sun j2sdk1.4.0_01 and j2re1.4.0_02
using linux. i have not seen this problem using the same version of mozilla and
java plugin on windows.

as an added note found a post to a mozilla newsgroup about the same problem. the
post is:

 From: Helge Hielscher (hhielscher@unternehmen.com)
Subject: chat.yahoo.com with Java 1.4.0
Newsgroups: netscape.public.mozilla.java 
Date: 2002-04-01 19:13:05 PST

since I upgraded to Mozilla 0.9.9 and Java 1.4.0 the chat applet from 
yahoo has problems with the focus. I can type one letter, then click to 
gain focus, type the next letter ...

What is wrong Yahoo's applet, JRE 1.4.0 or mozilla?

Reproducible: Always

Steps to Reproduce:
1.
2.
3.



Expected Results:  
focus should stay on the proper area of the applet.
(Reporter)

Comment 1

16 years ago
i have traced this to the use of sun java, both the jre and sdk.  this bug does
not occur when using the netscape java plugin using the software installer, only
when creating a symbolic link in the plugins dir to sun's libjavaplugin

Comment 2

16 years ago
I am having the same problem - for me though, its not a focus problem at all. 
Everytime I type anything in yahoo chat, it just does not appear in the text box
- I have to keep typing the same letter many times before it finally appears.

Comment 3

16 years ago
Works for me using build ID 20030531 on mandrake 9.0 with Java(TM) Plug-in
1.4.2-beta-b19. I can enter text in the "Chat:" box, and all the usual text
editing keys work.

Boris, can you reproduce this with a current revision of mozilla (and preferably
java 1.4.1 or 1.4.2 beta)?

Comment 4

15 years ago
Since over 1 month no answer from the reporter, so closing bug as wfm.
If the bug exists in newer builds (1.4 final) then look for a similar bug or
reopen this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Component: Java-Implemented Plugins → Java-Implemented Plugins
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.