XSLT has a delay before displaying result

RESOLVED WORKSFORME

Status

()

Core
XSLT
RESOLVED WORKSFORME
16 years ago
15 years ago

People

(Reporter: Lapo Luchini, Assigned: sicking)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
Every page, in a data-independant way, seems to have 3-5 seconds of delay before
output is displayed.

I created a *basic* testcase to confirm my suspects and I can't notice any
change in delay between that one and longer XSLT I made working on an XML.
(Reporter)

Comment 1

16 years ago
Created attachment 99204 [details]
Test stylesheet
(Reporter)

Comment 2

16 years ago
Created attachment 99205 [details]
Test XML
Well, loading and parsing the stylesheet and doing the transform take time. We
can improve the performance but I don't think we need this bug report but rather
specific bugs for specific improvments. Wontfix?
(Reporter)

Comment 4

16 years ago
I tought this was a bug given the fact that a 200 lines XSLT and a 2 lines XSLT
had the same convert time... but if you say it's normal, then I'd guess it's the
"load" and "initialize" time of the XSLT library and not the "execute" time that
get most of it... it's a pity: I had to use I.E. to make that work in time as
waiting 4 seconds for each page change is a bit too much (IE does that almost
instantly). I hate to use IE, but this time I was forced =(
actually i think this is a real bug. I suspect that painsupression or some such
is biting us. At least it's worth investigating
Status: UNCONFIRMED → NEW
Ever confirmed: true
Paint-supression? Very doubtful, Gecko doesnt do incremental layout for XML
documents. Try timing the two steps (loading/parsing the stylesheet, transform).
Assignee: peterv → sicking

Comment 7

16 years ago
how about adding MOZ_TIMELINE to module?
Not sure how to do this really really right, though. End of transformation
could be done, but I can't think of a descent way to signal the load of 
scripts or CSS. At least when I looked at it, a few weeks back
(Reporter)

Comment 8

16 years ago
Don't know why nor since what version exactly but with Mozilla 1.2b (2002102504)
navigating an XML website with XSLT is as fast as navigating an HTML website...
no more 5 seconds delay.
Someone knows if this has been indeed "fixed" or it is a pure chance?
I wonder if setting 

user_pref("nglayout.initialpaint.delay", 1200);

will cause this again. This pref was changed in october 2002 from 1200 to 250.

Comment 10

15 years ago
I don't know if it is exactly this bug. When I do whatever XSL transformation, 
the page will flash with a dark background for one-tenth of a second before 
showing the result about a second later. Since it appears every page, it is 
annoying. I am using 1.3 release.
please file a new bug on that
Ok, i can't reproduce this so either it wasn't a problem or it has been fixed
since this bug was filed. I tried cranking up nglayout.initialpaint.delay to
10000 but it didn't make a difference
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.