Closed Bug 1686815 Opened 9 months ago Closed 1 month ago

Crash in [@ gfxPlatform::Init | mozilla::gl::SurfaceFactory::Create]

Categories

(Core :: Canvas: WebGL, defect)

Unspecified
Linux
defect

Tracking

()

RESOLVED DUPLICATE of bug 1729656
Fission Milestone Future

People

(Reporter: mccr8, Unassigned)

Details

(Keywords: crash)

Crash Data

Maybe Fission related. (DOMFissionEnabled=1)

Crash report: https://crash-stats.mozilla.org/report/index/94b747f9-bb4e-4a6f-b599-892440210113

MOZ_CRASH Reason: MOZ_RELEASE_ASSERT(!XRE_IsGPUProcess()) (GFX: Not allowed in GPU process.)

Top 10 frames of crashing thread:

0 libxul.so gfxPlatform::Init gfx/thebes/gfxPlatform.cpp:818
1 libxul.so gfxPlatform::GetPlatform gfx/thebes/gfxPlatform.cpp:505
2 libxul.so mozilla::gl::SurfaceFactory::Create gfx/gl/SharedSurface.cpp:116
3 libxul.so mozilla::WebGLContext::Present dom/canvas/WebGLContext.cpp:914
4 libxul.so mozilla::dom::WebGLParent::RecvDispatchCommands dom/canvas/WebGLParent.cpp:68
5 libxul.so mozilla::dom::PWebGLParent::OnMessageReceived ipc/ipdl/PWebGLParent.cpp:201
6 libxul.so mozilla::layers::PCompositorManagerParent::OnMessageReceived ipc/ipdl/PCompositorManagerParent.cpp:205
7 libxul.so mozilla::ipc::MessageChannel::DispatchMessage ipc/glue/MessageChannel.cpp:2077
8 libxul.so nsThread::ProcessNextEvent xpcom/threads/nsThread.cpp:1200
9 libxul.so mozilla::ipc::MessagePumpForNonMainThreads::Run ipc/glue/MessagePump.cpp:302

There are only crashes from two different install times, but it seems odd to this kind of release assert. The first build this appears on is 20210113100240.

It looks like there are some older crashes, going back to at least 20201229095620. All but the two oldest of these crashes in the last 3 months have Fission enabled, so I'll mark it for Fission tracking.

Fission Milestone: --- → ?
Component: Graphics → Canvas: WebGL

Crash volume is low, tracking for Fission MVP to keep an eye on these Fission crashes.

Fission Milestone: ? → MVP
OS: Unspecified → Linux

The crash is not fission-related. Here's the STR:

  1. Set layers.gpu-process.enabled and webgl.out-of-process to true.
  2. Start Firefox on X11 with EGL (MOZ_X11_EGL=1). I haven't tested Wayland.
  3. Open any page with some WebGL running, like https://webglsamples.org/aquarium/aquarium.html.

Crash volume is low. This bug doesn't need to block Fission MVP.

Fission Milestone: MVP → Future
Status: NEW → RESOLVED
Closed: 1 month ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1729656
You need to log in before you can comment on or make changes to this bug.